]> git.pld-linux.org Git - packages/libnsfb.git/blob - libnsfb.spec
- updated to 0.2.1
[packages/libnsfb.git] / libnsfb.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Framebuffer abstraction library
6 Summary(pl.UTF-8):      Biblioteka abstrakcji bufora ramki
7 Name:           libnsfb
8 Version:        0.2.1
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  0b8f8eccd675ce058c55a4ab41af14c1
14 Patch0:         %{name}-link.patch
15 URL:            http://www.netsurf-browser.org/projects/libnsfb/
16 BuildRequires:  SDL-devel
17 BuildRequires:  libvncserver-devel
18 BuildRequires:  libxcb-devel >= 1.3
19 BuildRequires:  netsurf-buildsystem >= 1.8
20 BuildRequires:  pkgconfig
21 BuildRequires:  wayland-devel
22 BuildRequires:  xcb-util-devel
23 BuildRequires:  xcb-util-image-devel
24 BuildRequires:  xcb-util-keysyms-devel
25 BuildRequires:  xcb-util-wm-devel >= 0.3.8
26 Requires:       libxcb-devel >= 1.3
27 Requires:       xcb-util-wm-devel >= 0.3.8
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 LibNSFB is a framebuffer abstraction library, written in C. It is
32 currently in development for use with NetSurf and is intended to be
33 suitable for use in other projects too.
34
35 The overall idea of the library is to provide a generic abstraction to
36 a linear section of memory which corresponds to a visible array of
37 pixel elements on a display device. Different colour depths are
38 supported and the library provides routines for tasks such as drawing
39 onto the framebuffer and rectangle copy operations.
40
41 LibNSFB currently supports the following as framebuffer providers:
42 - Linux framebuffer
43 - X
44 - SDL
45 - VNC
46 - ABLE framebuffer
47
48 %description
49 LibNSFB to napisana w C biblioteka abstrakcji bufora ramki. Obecnie
50 jest rozwijana pod kątem użycia w przeglądarce NetSurf, ale może być
51 także używana w innych projektach.
52
53 Ogólną ideą biblioteki jest zapewnienie ogólnej abstrakcji liniowego
54 obszaru pamięci, który odpowiada widocznej tablicy pikseli na
55 urządzeniu wyświetlającym. Obsługiwane są różne głębie koloru, a
56 biblioteka udostępnia takie operacje, jak rysowanie w buforze ramki
57 czy kopiowanie prostokątów.
58
59 LibNSFB obecnie obsługuje następujące bufory ramki:
60 - linuksowy framebuffer
61 - X
62 - SDL
63 - VNC
64 - framebuffer ABLE
65
66 %package devel
67 Summary:        libnsfb library headers
68 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnsfb
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       SDL-devel
72 Requires:       libvncserver-devel
73 Requires:       libxcb-devel >= 1.3
74 Requires:       wayland-devel
75 Requires:       xcb-util-devel
76 Requires:       xcb-util-image-devel
77 Requires:       xcb-util-keysyms-devel
78 Requires:       xcb-util-wm-devel >= 0.3.8
79
80 %description devel
81 This package contains the include files and other resources you can
82 use to incorporate libnsfb into applications.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe pozwalające na używanie biblioteki libnsfb w swoich
86 programach.
87
88 %package static
89 Summary:        libnsfb static library
90 Summary(pl.UTF-8):      Statyczna biblioteka libnsfb
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 This is package with static libnsfb library.
96
97 %description static -l pl.UTF-8
98 Statyczna biblioteka libnsfb.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103
104 %build
105 export AR="%{__ar}"
106 export CC="%{__cc}"
107 export CFLAGS="%{rpmcflags}"
108 export LDFLAGS="%{rpmldflags}"
109
110 %{__make} \
111         Q= \
112         PREFIX=%{_prefix} \
113         COMPONENT_TYPE=lib-shared
114 %if %{with static_libs}
115 %{__make} \
116         Q= \
117         PREFIX=%{_prefix} \
118         COMPONENT_TYPE=lib-static
119 %endif
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 export AR="%{__ar}"
125 export CC="%{__cc}"
126 export CFLAGS="%{rpmcflags}"
127 export LDFLAGS="%{rpmldflags}"
128
129 %{__make} install \
130         Q= \
131         PREFIX=%{_prefix} \
132         LIBDIR=%{_lib} \
133         COMPONENT_TYPE=lib-shared \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 %if %{with static_libs}
137 %{__make} install \
138         Q= \
139         PREFIX=%{_prefix} \
140         LIBDIR=%{_lib} \
141         COMPONENT_TYPE=lib-static \
142         DESTDIR=$RPM_BUILD_ROOT
143 %endif
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %files
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/libnsfb.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libnsfb.so.0
155
156 %files devel
157 %defattr(644,root,root,755)
158 %doc usage
159 %attr(755,root,root) %{_libdir}/libnsfb.so
160 %{_includedir}/libnsfb*.h
161 %{_pkgconfigdir}/libnsfb.pc
162
163 %if %{with static_libs}
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libnsfb.a
167 %endif
This page took 0.065814 seconds and 3 git commands to generate.