]> git.pld-linux.org Git - packages/libmng.git/commitdiff
- updated for 1.0.10
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 16 Jul 2007 18:12:24 +0000 (18:12 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    libmng-automake.patch -> 1.5
    libmng-gcc4.patch -> 1.2

libmng-automake.patch
libmng-gcc4.patch

index fbaa16e9839fc0c5ac80996c4bbe2e2ef48749d0..73663ac26f297294dfa2311e1aca2271f223b096 100644 (file)
@@ -1,27 +1,26 @@
---- libmng-1.0.9/makefiles/Makefile.am.orig    2005-01-30 11:50:34.000000000 +0100
-+++ libmng-1.0.9/makefiles/Makefile.am 2005-02-05 20:58:13.948041296 +0100
-@@ -2,9 +2,10 @@
\r
- AUTOMAKE_OPTIONS = 1.3 foreign no-dependencies\r
\r
--# include the app subdirectories in the distribution\r
--EXTRA_DIST = makefiles doc contrib\r
-+SUBDIRS = doc\r
\r
-+# include the app subdirectories in the distribution\r
-+EXTRA_DIST = makefiles contrib\r
\r
- # libmng release @VERSION@\r
- libmng_la_LDFLAGS = -version-info 1:0:0\r
---- libmng-1.0.9/makefiles/configure.in.orig   2005-01-30 11:50:34.000000000 +0100
-+++ libmng-1.0.9/makefiles/configure.in        2005-02-05 20:58:38.560299664 +0100
+--- libmng-1.0.10/makefiles/Makefile.am.orig   2004-09-18 09:39:43.000000000 +0200
++++ libmng-1.0.10/makefiles/Makefile.am        2007-07-16 19:43:07.285858201 +0200
+@@ -2,8 +2,10 @@
+ AUTOMAKE_OPTIONS = 1.3 foreign no-dependencies
++SUBDIRS = doc
++
+ # include the app subdirectories in the distribution
+-EXTRA_DIST = makefiles doc contrib
++EXTRA_DIST = makefiles contrib
+ # libmng release @VERSION@
+--- libmng-1.0.10/makefiles/configure.in.orig  2005-01-30 11:28:00.000000000 +0100
++++ libmng-1.0.10/makefiles/configure.in       2007-07-16 19:43:24.774854842 +0200
 @@ -189,5 +189,5 @@
\r
-   test $_restore -eq 1 && CPPFLAGS=$_cppflags LDFLAGS=$_ldflags\r
\r
--AC_CONFIG_FILES([Makefile])\r
-+  AC_CONFIG_FILES([Makefile doc/Makefile doc/man/Makefile])\r
- AC_OUTPUT\r
+   test $_restore -eq 1 && CPPFLAGS=$_cppflags LDFLAGS=$_ldflags
+-AC_CONFIG_FILES([Makefile])
++  AC_CONFIG_FILES([Makefile doc/Makefile doc/man/Makefile])
+ AC_OUTPUT
 diff -Nru libmng-1.0.5.orig/doc/makefiles/Makefile.am libmng-1.0.5/doc/makefiles/Makefile.am
 --- libmng-1.0.5.orig/doc/makefiles/Makefile.am        Thu Jan  1 01:00:00 1970
 +++ libmng-1.0.5/doc/makefiles/Makefile.am     Tue Mar  4 09:25:11 2003
index 50814b30d2789b1d78e0515310a571b3e27f151e..cdd79f0e1a15038fd9bdd5cb061fac9092643ea1 100644 (file)
@@ -4,25 +4,25 @@ mng.c: In function 'copyline':
 mng.c:233: error: invalid lvalue in increment
 mng.c:270: error: invalid lvalue in increment
 
---- libmng-1.0.9/contrib/gcc/fbmngplay/mng.c.orig      2005-01-30 11:50:23.000000000 +0100
-+++ libmng-1.0.9/contrib/gcc/fbmngplay/mng.c   2005-02-05 22:42:39.130650312 +0100
+--- libmng-1.0.10/contrib/gcc/fbmngplay/mng.c.orig     2003-12-07 10:45:15.000000000 +0100
++++ libmng-1.0.10/contrib/gcc/fbmngplay/mng.c  2007-07-16 19:47:18.272161096 +0200
 @@ -230,7 +230,8 @@
-               a = a * mymng->alpha / 100;\r
-               switch (mymng->fbbpp) {\r
-               case 16:\r
--                      input = *((unsigned short *) background)++;\r
+               a = a * mymng->alpha / 100;
+               switch (mymng->fbbpp) {
+               case 16:
+-                      input = *((unsigned short *) background)++;
 +                      input = *(unsigned short *)background;
 +                      background += 2;
-                       br = (input >> 8) & 0xf8;\r
-                       bg = (input >> 3) & 0xfc;\r
-                       bb = input << 3 & 0xff;\r
+                       br = (input >> 8) & 0xf8;
+                       bg = (input >> 3) & 0xfc;
+                       bb = input << 3 & 0xff;
 @@ -267,7 +268,8 @@
-                       b >>= 3;\r
\r
-                       output = (r << 11) | (g << 5) | b;\r
--                      *((unsigned short *) dest)++ = output;\r
-+                      *((unsigned short *)dest) = output;
+                       b >>= 3;
+                       output = (r << 11) | (g << 5) | b;
+-                      *((unsigned short *) dest)++ = output;
++                      *(unsigned short *)dest = output;
 +                      dest += 2;
-                       break;\r
-               case 24:\r
-                       *dest++ = b;\r
+                       break;
+               case 24:
+                       *dest++ = b;
This page took 0.050589 seconds and 4 git commands to generate.