]> git.pld-linux.org Git - packages/libmicrohttpd.git/commitdiff
- updated to 0.9.28 auto/th/libmicrohttpd-0.9.28-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 19 Jul 2013 19:36:22 +0000 (21:36 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 19 Jul 2013 19:36:22 +0000 (21:36 +0200)
- added messages patch (fixes build with messages disabled)
- added link patch (fixes libmicrospdy linking)

libmicrohttpd-link.patch [new file with mode: 0644]
libmicrohttpd-messages.patch [new file with mode: 0644]
libmicrohttpd.spec

diff --git a/libmicrohttpd-link.patch b/libmicrohttpd-link.patch
new file mode 100644 (file)
index 0000000..fe62769
--- /dev/null
@@ -0,0 +1,10 @@
+--- libmicrohttpd-0.9.28/src/microspdy/Makefile.am.orig        2013-07-08 11:49:30.000000000 +0200
++++ libmicrohttpd-0.9.28/src/microspdy/Makefile.am     2013-07-19 20:49:27.404186627 +0200
+@@ -28,6 +28,7 @@
+   alstructures.c alstructures.h 
++libmicrospdy_la_LIBADD = -lssl -lcrypto -lz
+ libmicrospdy_la_LDFLAGS = \
+   $(SPDY_LIB_LDFLAGS) 
diff --git a/libmicrohttpd-messages.patch b/libmicrohttpd-messages.patch
new file mode 100644 (file)
index 0000000..06610ec
--- /dev/null
@@ -0,0 +1,26 @@
+--- libmicrohttpd-0.9.28/src/microhttpd/daemon.c.orig  2013-07-19 17:32:13.000000000 +0200
++++ libmicrohttpd-0.9.28/src/microhttpd/daemon.c       2013-07-19 20:31:23.474232117 +0200
+@@ -612,9 +612,11 @@
+         break;
+       }
+     }
++#if HAVE_MESSAGES
+ #if DEBUG_CONNECT
+   MHD_DLOG (daemon, "Maximum socket in select set: %d\n", *max_fd);
+ #endif
++#endif
+   return MHD_YES;
+ }
+@@ -3112,9 +3114,11 @@
+         int sk_flags = fcntl (socket_fd, F_GETFL);
+         if (0 != fcntl (socket_fd, F_SETFL, sk_flags | O_NONBLOCK))
+           {
++#if HAVE_MESSAGES
+             MHD_DLOG (daemon,
+                       "Failed to make listen socket non-blocking: %s\n", 
+                       STRERROR (errno));
++#endif
+             if (0 != CLOSE (socket_fd))
+               MHD_PANIC ("close failed\n");         
+             goto free_and_fail;             
index 9ed7a16ebd7f8794be52ab659b53696503892a1c..ebd8d82533d1b987607f961668a3ca250a21bb5b 100644 (file)
@@ -5,19 +5,23 @@
 Summary:       Embeded HTTP server library
 Summary(pl.UTF-8):     Biblioteka wbudowanego serwera HTTP
 Name:          libmicrohttpd
-Version:       0.9.27
+Version:       0.9.28
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/libmicrohttpd/%{name}-%{version}.tar.gz
-# Source0-md5: a10496b7f1b495aaf6897584da52f51b
+# Source0-md5: 16c3cb66c839c6f929677471401a5b53
 Patch0:                %{name}-info.patch
+Patch1:                %{name}-messages.patch
+Patch2:                %{name}-link.patch
 URL:           http://www.gnu.org/software/libmicrohttpd/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake >= 1:1.10
 BuildRequires: gnutls-devel >= 2.8.6
 BuildRequires: libgcrypt-devel >= 1.2.4
 BuildRequires: libtool
+# for microspdy
+BuildRequires: openssl-devel
 BuildRequires: texinfo
 %if %{with tests}
 BuildRequires: curl-devel >= 7.16.4
@@ -41,6 +45,7 @@ Group:                Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      gnutls-devel >= 2.8.6
 Requires:      libgcrypt-devel >= 1.2.4
+Requires:      openssl-devel
 
 %description devel
 Header files to develop libmicrohttpd applications.
@@ -63,6 +68,8 @@ Biblioteka statyczna libmicrohttpd.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
@@ -89,6 +96,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/demo
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -104,14 +113,20 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README
+%attr(755,root,root) %{_bindir}/microspdy2http
 %attr(755,root,root) %{_libdir}/libmicrohttpd.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libmicrohttpd.so.10
+%attr(755,root,root) %{_libdir}/libmicrospdy.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libmicrospdy.so.0
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libmicrohttpd.so
+%attr(755,root,root) %{_libdir}/libmicrospdy.so
 %{_libdir}/libmicrohttpd.la
+%{_libdir}/libmicrospdy.la
 %{_includedir}/microhttpd.h
+%{_includedir}/microspdy.h
 %{_infodir}/libmicrohttpd.info*
 %{_infodir}/libmicrohttpd-tutorial.info*
 %{_mandir}/man3/libmicrohttpd.3*
@@ -120,3 +135,4 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libmicrohttpd.a
+%{_libdir}/libmicrospdy.a
This page took 0.157112 seconds and 4 git commands to generate.