]> git.pld-linux.org Git - packages/libmicrohttpd.git/blob - libmicrohttpd.spec
- 0.9.17
[packages/libmicrohttpd.git] / libmicrohttpd.spec
1 #
2 # Conditional build
3 %bcond_with     tests   # perform "make check"
4 #
5 Summary:        Embeded HTTP server library
6 Summary(pl.UTF-8):      Biblioteka wbudowanego serwera HTTP
7 Name:           libmicrohttpd
8 Version:        0.9.17
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://ftp.gnu.org/gnu/libmicrohttpd/%{name}-%{version}.tar.gz
13 # Source0-md5:  d6802049c806e903ef1fa9c5b847e555
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-missing-files.patch
16 URL:            http://www.gnu.org/software/libmicrohttpd/
17 BuildRequires:  autoconf >= 2.61
18 BuildRequires:  automake >= 1:1.10
19 BuildRequires:  libgcrypt-devel >= 1.2.4
20 BuildRequires:  libtool
21 BuildRequires:  texinfo
22 %if %{with tests}
23 BuildRequires:  curl-devel >= 7.16.4
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 GNU libmicrohttpd is a small C library that is supposed to make it
29 easy to run an HTTP server as part of another application.
30
31 %description -l pl.UTF-8
32 GNU libmicrohttpd jest małą biblioteką C, w założeniu umożliwiającą
33 uruchomienie serwera HTTP jako części innej aplikacji.
34
35 %package devel
36 Summary:        Header files to develop libmicrohttpd applications
37 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijania aplikacji używających libmicrohttpd
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files to develop libmicrohttpd applications.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe do rozwijania aplikacji używających libmicrohttpd.
46
47 %package static
48 Summary:        Static libmicrohttpd libraries
49 Summary(pl.UTF-8):      Biblioteka statyczna libmicrohttpd
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static libmicrohttpd libraries.
55
56 %description static -l pl.UTF-8
57 Biblioteka statyczna libmicrohttpd.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p1
63
64 %build
65 %{__libtoolize}
66 %{__aclocal} -I m4
67 %{__autoconf}
68 %{__autoheader}
69 %{__automake}
70 %configure \
71 %if %{with tests}
72         --enable-curl \
73         --enable-client-side \
74 %endif
75         --enable-https \
76         --disable-messages
77
78 %{__make}
79 %if %{with tests}
80 %{__make} check
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %post   devel -p /sbin/postshell
96 -/usr/sbin/fix-info-dir -c %{_infodir}
97
98 %postun devel -p /sbin/postshell
99 -/usr/sbin/fix-info-dir -c %{_infodir}
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS ChangeLog NEWS README
104 %attr(755,root,root) %{_libdir}/libmicrohttpd.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libmicrohttpd.so.10
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/libmicrohttpd.so
110 %{_libdir}/libmicrohttpd.la
111 %{_includedir}/microhttpd.h
112 %{_infodir}/microhttpd.info*
113 %{_infodir}/microhttpd-tutorial.info*
114 %{_mandir}/man3/libmicrohttpd.3*
115 %{_pkgconfigdir}/libmicrohttpd.pc
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/libmicrohttpd.a
This page took 0.043917 seconds and 3 git commands to generate.