]> git.pld-linux.org Git - packages/libmediainfo.git/blob - libmediainfo.spec
- up to 0.7.30
[packages/libmediainfo.git] / libmediainfo.spec
1 %define libzen_ver 0.4.12
2 Summary:        Supplies technical and tag information about a video or audio file
3 Name:           libmediainfo
4 Version:        0.7.30
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 URL:            http://mediainfo.sourceforge.net/
9 Source0:        http://downloads.sourceforge.net/project/mediainfo/source/libmediainfo/%{version}/%{name}_%{version}.tar.bz2
10 # Source0-md5:  e9f5965d87f829def5ffcdb894377c80
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  dos2unix
14 BuildRequires:  doxygen
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool
17 BuildRequires:  libzen-devel >= %{libzen_ver}
18 BuildRequires:  pkgconfig
19 BuildRequires:  zlib-devel
20 Requires:       libzen >= %{libzen_ver}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 MediaInfo supplies technical and tag information about a video or
25 audio file.
26
27 What information can I get from MediaInfo?
28 - General: title, author, director, album, track number, date,
29   duration...
30 - Video: codec, aspect, fps, bitrate...
31 - Audio: codec, sample rate, channels, language, bitrate...
32 - Text: language of subtitle
33 - Chapters: number of chapters, list of chapters
34
35 DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1, MPEG1,
36 MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime, RealVideo,
37 RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3, VOB, DVD, WMA,
38 VMW, ASF, 3GP, 3GPP, 3GP2
39
40 What format (container) does MediaInfo support?
41 - Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
42   MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
43 - Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
44 - Subtitles: SRT, SSA, ASS, SAMI
45
46 This package contains the shared library for MediaInfo.
47
48 %package devel
49 Summary:        Include files and mandatory libraries for development
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libzen-devel >= 0.4.9
53
54 %description devel
55 Include files and mandatory libraries for development.
56
57 %package static
58 Summary:        Static libmediainfo library
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static libmediainfo library.
64
65 %prep
66 %setup -q -n MediaInfoLib
67 cp           Release/ReadMe_DLL_Linux.txt ReadMe.txt
68 mv           History_DLL.txt History.txt
69 dos2unix     *.txt *.html Source/Doc/*.html
70 chmod 644 *.txt *.html Source/Doc/*.html
71
72 %build
73 export CFLAGS="%{rpmcflags}"
74 export CPPFLAGS="%{rpmcppflags}"
75 export CXXFLAGS="%{rpmcxxflags}"
76
77 cd Source/Doc
78         doxygen Doxyfile
79 cd ../..
80
81 cp Source/Doc/*.html ./
82
83 cd Project/GNU/Library
84         chmod +x autogen
85         ./autogen
86         %configure \
87         --enable-shared \
88         --with-libcurl=no \
89         --with-libmms=no
90
91         %{__make} clean
92         %{__make}
93 cd ../../..
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} -C Project/GNU/Library \
99         install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 # MediaInfoDLL headers and MediaInfo-config
103 for i in MediaInfo MediaInfoDLL; do
104         install -dm 755 $RPM_BUILD_ROOT%{_includedir}/$i
105         install -m 644 Source/$i/*.h $RPM_BUILD_ROOT%{_includedir}/$i
106 done
107
108 %{__sed} -i -e 's|Version: |Version: %{version}|g' Project/GNU/Library/libmediainfo.pc
109 install -dm 755 $RPM_BUILD_ROOT%{_libdir}/pkgconfig
110 install Project/GNU/Library/libmediainfo.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc History.txt License.html ReadMe.txt
121 %attr(755,root,root) %{_libdir}/libmediainfo.so.*
122
123 %files devel
124 %defattr(644,root,root,755)
125 %doc Changes.txt Documentation.html Doc/* Source/Example/HowToUse*
126 %{_includedir}/MediaInfo
127 %{_includedir}/MediaInfoDLL
128 %{_libdir}/libmediainfo.la
129 %attr(755,root,root) %{_libdir}/libmediainfo.so
130 %{_pkgconfigdir}/*.pc
131
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/libmediainfo.a
This page took 1.339562 seconds and 4 git commands to generate.