]> git.pld-linux.org Git - packages/libmediainfo.git/blob - libmediainfo.spec
- up to 0.7.60
[packages/libmediainfo.git] / libmediainfo.spec
1 %define libzen_ver 0.4.28
2 Summary:        Supplies technical and tag information about a video or audio file
3 Name:           libmediainfo
4 Version:        0.7.60
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        http://downloads.sourceforge.net/project/mediainfo/source/libmediainfo/%{version}/%{name}_%{version}.tar.bz2
9 # Source0-md5:  f2a8e921814fc188ada7a236c8a2073e
10 URL:            http://mediainfo.sourceforge.net/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  doxygen
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool
16 BuildRequires:  libzen-devel >= %{libzen_ver}
17 BuildRequires:  pkgconfig
18 BuildRequires:  zlib-devel
19 Requires:       libzen >= %{libzen_ver}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 MediaInfo supplies technical and tag information about a video or
24 audio file.
25
26 What information can I get from MediaInfo?
27 - General: title, author, director, album, track number, date,
28   duration...
29 - Video: codec, aspect, fps, bitrate...
30 - Audio: codec, sample rate, channels, language, bitrate...
31 - Text: language of subtitle
32 - Chapters: number of chapters, list of chapters
33
34 DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1, MPEG1,
35 MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime, RealVideo,
36 RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3, VOB, DVD, WMA,
37 VMW, ASF, 3GP, 3GPP, 3GP2
38
39 What format (container) does MediaInfo support?
40 - Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
41   MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
42 - Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
43 - Subtitles: SRT, SSA, ASS, SAMI
44
45 This package contains the shared library for MediaInfo.
46
47 %package devel
48 Summary:        Include files and mandatory libraries for development
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       libzen-devel >= %{libzen_ver}
52
53 %description devel
54 Include files and mandatory libraries for development.
55
56 %package static
57 Summary:        Static libmediainfo library
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static libmediainfo library.
63
64 %prep
65 %setup -q -n MediaInfoLib
66 cp           Release/ReadMe_DLL_Linux.txt ReadMe.txt
67 mv           History_DLL.txt History.txt
68 %undos *.txt *.html Source/Doc/*.html
69 chmod 644 *.txt *.html Source/Doc/*.html
70
71 %build
72 export CFLAGS="%{rpmcflags}"
73 export CPPFLAGS="%{rpmcppflags}"
74 export CXXFLAGS="%{rpmcxxflags}"
75
76 cd Source/Doc
77         doxygen Doxyfile
78 cd ../..
79
80 cp Source/Doc/*.html ./
81
82 cd Project/GNU/Library
83         chmod +x autogen
84         ./autogen
85         %configure \
86         --enable-shared \
87         --with-libcurl=no \
88         --with-libmms=no
89
90         %{__make} clean
91         %{__make}
92 cd ../../..
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} -C Project/GNU/Library \
98         install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 # MediaInfoDLL headers and MediaInfo-config
102 for i in MediaInfo MediaInfoDLL; do
103         install -dm 755 $RPM_BUILD_ROOT%{_includedir}/$i
104         install -m 644 Source/$i/*.h $RPM_BUILD_ROOT%{_includedir}/$i
105 done
106
107 %{__sed} -i -e 's|Version: |Version: %{version}|g' Project/GNU/Library/libmediainfo.pc
108 install -dm 755 $RPM_BUILD_ROOT%{_libdir}/pkgconfig
109 install Project/GNU/Library/libmediainfo.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc History.txt License.html ReadMe.txt
120 %attr(755,root,root) %{_libdir}/libmediainfo.so.*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %doc Changes.txt Documentation.html Doc/* Source/Example/HowToUse*
125 %{_includedir}/MediaInfo
126 %{_includedir}/MediaInfoDLL
127 %{_libdir}/libmediainfo.la
128 %attr(755,root,root) %{_libdir}/libmediainfo.so
129 %{_pkgconfigdir}/*.pc
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libmediainfo.a
This page took 0.044735 seconds and 3 git commands to generate.