]> git.pld-linux.org Git - packages/libkolabxml.git/blame - libkolabxml.spec
- x32 rebuild
[packages/libkolabxml.git] / libkolabxml.spec
CommitLineData
390184bb
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
c866a2f0
ER
4%bcond_without php # PHP bindings
5%bcond_without python # Python bindings
6
d2b82142 7%define php_name php55
f0ba6589
AM
8Summary: Kolab XML format collection parser library
9Name: libkolabxml
37d8e7e0 10Version: 1.0.1
d7d9d065 11Release: 10
390184bb 12License: LGPL v3+
f0ba6589 13Group: Libraries
7d487fd2 14Source0: http://mirror.kolabsys.com/pub/releases/%{name}-%{version}.tar.gz
37d8e7e0 15# Source0-md5: 7adccfa0ed91ac954c815e8d13f334ee
c866a2f0 16URL: http://www.kolab.org/
7d487fd2 17BuildRequires: QtCore-devel
f0ba6589 18BuildRequires: boost-devel
f0ba6589 19BuildRequires: cmake >= 2.6
7d487fd2 20BuildRequires: curl-devel
f0ba6589 21BuildRequires: e2fsprogs-devel
7d487fd2
AM
22BuildRequires: kde4-kdelibs-devel
23BuildRequires: kde4-kdepimlibs-devel
f0ba6589 24BuildRequires: libstdc++-devel
7d487fd2 25BuildRequires: libuuid-devel
7d487fd2 26BuildRequires: qt4-build
390184bb 27BuildRequires: rpmbuild(macros) >= 1.600
f0ba6589 28BuildRequires: swig
f0ba6589
AM
29BuildRequires: xerces-c-devel
30BuildRequires: xsd
c866a2f0
ER
31%if %{with python}
32BuildRequires: python-devel
33BuildRequires: swig-python
34%endif
35%if %{with php}
2b9dc121 36BuildRequires: %{php_name}-cli
bfe7ce4e 37BuildRequires: %{php_name}-program
c866a2f0
ER
38BuildRequires: %{php_name}-devel
39BuildRequires: swig-php
40%endif
7d487fd2 41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
f0ba6589
AM
42
43%description
44The libkolabxml parsing library interprets Kolab XML formats (xCal,
45xCard) with bindings for Python, PHP and other languages. The language
46bindings are available through sub-packages.
47
48%package devel
49Summary: Kolab XML library development headers
50Group: Development/Libraries
7d487fd2
AM
51Requires: %{name} = %{version}-%{release}
52Requires: QtCore-devel
f0ba6589 53Requires: boost-devel
f0ba6589 54Requires: cmake >= 2.6
7d487fd2 55Requires: curl-devel
f0ba6589 56Requires: e2fsprogs-devel
7d487fd2
AM
57Requires: kde4-kdelibs-devel
58Requires: kde4-kdepimlibs-devel
f0ba6589 59Requires: libstdc++-devel
7d487fd2 60Requires: libuuid-devel
f0ba6589 61Requires: swig
f0ba6589
AM
62Requires: xerces-c-devel
63Requires: xsd
64
f0ba6589
AM
65%description devel
66Development headers for the Kolab XML libraries.
67
82ea52bf 68%package -n %{php_name}-kolabformat
f0ba6589 69Summary: PHP bindings for libkolabxml
390184bb 70Group: Development/Languages/PHP
7d487fd2
AM
71Requires: %{name} = %{version}-%{release}
72%{?requires_php_extension}
f0ba6589 73
82ea52bf 74%description -n %{php_name}-kolabformat
f0ba6589
AM
75The PHP kolabformat package offers a comprehensible PHP library using
76the bindings provided through libkolabxml.
77
78%package -n python-kolabformat
79Summary: Python bindings for libkolabxml
80Group: Libraries
7d487fd2 81Requires: %{name} = %{version}-%{release}
f0ba6589
AM
82
83%description -n python-kolabformat
84The PyKolab format package offers a comprehensive Python library using
85the bindings provided through libkolabxml.
86
87%prep
88%setup -q
f0ba6589
AM
89
90%build
7d487fd2
AM
91install -d build
92cd build
390184bb
ER
93%cmake \
94 -Wno-fatal-errors -Wno-errors \
f0ba6589
AM
95 -DCMAKE_SKIP_RPATH=ON \
96 -DCMAKE_PREFIX_PATH=%{_libdir} \
f0ba6589 97 -DINCLUDE_INSTALL_DIR=%{_includedir}/kolabxml \
d8bd1264 98 -DLIB_INSTALL_DIR:PATH=%{_libdir} \
c866a2f0 99%if %{with php}
2b9dc121 100 -DPHP_EXECUTABLE=%{__php} \
f0ba6589 101 -DPHP_BINDINGS=ON \
7d487fd2 102 -DPHP_INSTALL_DIR=%{php_extensiondir} \
c866a2f0
ER
103%endif
104%if %{with python}
f0ba6589 105 -DPYTHON_BINDINGS=ON \
c866a2f0 106 -DPYTHON_INCLUDE_DIRS=%{python_include} \
f0ba6589 107 -DPYTHON_INSTALL_DIR=%{py_sitedir} \
c866a2f0 108%endif
f0ba6589
AM
109 ..
110%{__make}
7d487fd2 111cd ..
f0ba6589 112
7d487fd2
AM
113%if %{with tests}
114cd build
f0ba6589 115# Make sure libkolabxml.so.* is found, otherwise the tests fail
390184bb 116export LD_LIBRARY_PATH=$(pwd)/src
7d487fd2 117cd tests
82ea52bf
AM
118./bindingstest
119./conversiontest
120./parsingtest
c866a2f0
ER
121cd ..
122%if %{with php}
123cd src/php
82ea52bf 124php -d 'enable_dl=On' '-dextension=../../src/php/kolabformat.so' test.php
c866a2f0
ER
125cd ..
126%endif
127%if %{with python}
128cd python
82ea52bf
AM
129# FIXME
130%{__python} test.py ||
c866a2f0
ER
131cd ..
132%endif
7d487fd2
AM
133%endif
134
135%install
136rm -rf $RPM_BUILD_ROOT
7d487fd2 137%{__make} -C build install \
390184bb
ER
138 INSTALL='install -p' \
139 DESTDIR=$RPM_BUILD_ROOT
7d487fd2 140
c866a2f0
ER
141%if %{with php}
142install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_data_dir}}
390184bb 143mv $RPM_BUILD_ROOT%{php_extensiondir}/kolabformat.php $RPM_BUILD_ROOT%{php_data_dir}/kolabformat.php
c866a2f0 144cat > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/kolabformat.ini <<EOF
05d503b6 145; Enable kolabformat extension module
7d487fd2
AM
146extension=kolabformat.so
147EOF
c866a2f0 148%endif
f0ba6589 149
c866a2f0 150%if %{with python}
05d503b6
ER
151%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
152%py_comp $RPM_BUILD_ROOT%{py_sitedir}
153%py_postclean
c866a2f0 154%endif
05d503b6 155
f0ba6589
AM
156%clean
157rm -rf $RPM_BUILD_ROOT
158
05d503b6
ER
159%post -p /sbin/ldconfig
160%postun -p /sbin/ldconfig
f0ba6589
AM
161
162%files
163%defattr(644,root,root,755)
164%doc DEVELOPMENT NEWS README
7d487fd2 165%attr(755,root,root) %{_libdir}/libkolabxml.so.*.*
37d8e7e0 166%attr(755,root,root) %ghost %{_libdir}/libkolabxml.so.1
f0ba6589
AM
167
168%files devel
169%defattr(644,root,root,755)
170%{_includedir}/kolabxml
c866a2f0 171%{_libdir}/libkolabxml.so
f0ba6589
AM
172%{_libdir}/cmake/Libkolabxml
173
c866a2f0 174%if %{with php}
82ea52bf 175%files -n %{php_name}-kolabformat
f0ba6589 176%defattr(644,root,root,755)
c866a2f0 177%config(noreplace) %{php_sysconfdir}/conf.d/kolabformat.ini
05d503b6 178%attr(755,root,root) %{php_extensiondir}/kolabformat.so
390184bb 179%{php_data_dir}/kolabformat.php
c866a2f0 180%endif
f0ba6589 181
c866a2f0 182%if %{with python}
f0ba6589
AM
183%files -n python-kolabformat
184%defattr(644,root,root,755)
05d503b6 185%attr(755,root,root) %{py_sitedir}/_kolabformat.so
390184bb 186%{py_sitedir}/kolabformat.py[co]
c866a2f0 187%endif
This page took 0.230456 seconds and 4 git commands to generate.