]> git.pld-linux.org Git - packages/libkolabxml.git/blame - libkolabxml.spec
- - rebuild with boost 1.55.0
[packages/libkolabxml.git] / libkolabxml.spec
CommitLineData
390184bb
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
f0ba6589
AM
5Summary: Kolab XML format collection parser library
6Name: libkolabxml
37d8e7e0 7Version: 1.0.1
16017bb2 8Release: 2
390184bb 9License: LGPL v3+
f0ba6589 10Group: Libraries
390184bb 11URL: http://www.kolab.org/
7d487fd2 12Source0: http://mirror.kolabsys.com/pub/releases/%{name}-%{version}.tar.gz
37d8e7e0 13# Source0-md5: 7adccfa0ed91ac954c815e8d13f334ee
7d487fd2 14BuildRequires: QtCore-devel
f0ba6589 15BuildRequires: boost-devel
f0ba6589 16BuildRequires: cmake >= 2.6
7d487fd2 17BuildRequires: curl-devel
f0ba6589 18BuildRequires: e2fsprogs-devel
7d487fd2
AM
19BuildRequires: kde4-kdelibs-devel
20BuildRequires: kde4-kdepimlibs-devel
f0ba6589 21BuildRequires: libstdc++-devel
7d487fd2 22BuildRequires: libuuid-devel
f0ba6589
AM
23BuildRequires: php-devel >= 5.3
24BuildRequires: python-devel
7d487fd2 25BuildRequires: qt4-build
390184bb 26BuildRequires: rpmbuild(macros) >= 1.600
f0ba6589 27BuildRequires: swig
7d487fd2 28BuildRequires: swig-php
37d8e7e0 29BuildRequires: swig-python
f0ba6589
AM
30BuildRequires: xerces-c-devel
31BuildRequires: xsd
7d487fd2 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
f0ba6589
AM
33
34%description
35The libkolabxml parsing library interprets Kolab XML formats (xCal,
36xCard) with bindings for Python, PHP and other languages. The language
37bindings are available through sub-packages.
38
39%package devel
40Summary: Kolab XML library development headers
41Group: Development/Libraries
7d487fd2
AM
42Requires: %{name} = %{version}-%{release}
43Requires: QtCore-devel
f0ba6589 44Requires: boost-devel
f0ba6589 45Requires: cmake >= 2.6
7d487fd2 46Requires: curl-devel
f0ba6589 47Requires: e2fsprogs-devel
7d487fd2
AM
48Requires: kde4-kdelibs-devel
49Requires: kde4-kdepimlibs-devel
f0ba6589 50Requires: libstdc++-devel
7d487fd2 51Requires: libuuid-devel
f0ba6589
AM
52Requires: php-devel >= 5.3
53Requires: python-devel
f0ba6589 54Requires: swig
f0ba6589
AM
55Requires: xerces-c-devel
56Requires: xsd
57
f0ba6589
AM
58%description devel
59Development headers for the Kolab XML libraries.
60
61%package -n php-kolabformat
62Summary: PHP bindings for libkolabxml
390184bb 63Group: Development/Languages/PHP
7d487fd2
AM
64Requires: %{name} = %{version}-%{release}
65%{?requires_php_extension}
f0ba6589
AM
66
67%description -n php-kolabformat
68The PHP kolabformat package offers a comprehensible PHP library using
69the bindings provided through libkolabxml.
70
71%package -n python-kolabformat
72Summary: Python bindings for libkolabxml
73Group: Libraries
7d487fd2 74Requires: %{name} = %{version}-%{release}
f0ba6589
AM
75
76%description -n python-kolabformat
77The PyKolab format package offers a comprehensive Python library using
78the bindings provided through libkolabxml.
79
80%prep
81%setup -q
f0ba6589
AM
82
83%build
7d487fd2
AM
84install -d build
85cd build
390184bb
ER
86%cmake \
87 -Wno-fatal-errors -Wno-errors \
37d8e7e0 88 -DPHP_EXECUTABLE=%{_bindir}/php \
f0ba6589
AM
89 -DCMAKE_SKIP_RPATH=ON \
90 -DCMAKE_PREFIX_PATH=%{_libdir} \
f0ba6589
AM
91 -DINCLUDE_INSTALL_DIR=%{_includedir}/kolabxml \
92 -DPYTHON_INCLUDE_DIRS=%{python_include} \
93 -DPHP_BINDINGS=ON \
7d487fd2 94 -DPHP_INSTALL_DIR=%{php_extensiondir} \
f0ba6589
AM
95 -DPYTHON_BINDINGS=ON \
96 -DPYTHON_INSTALL_DIR=%{py_sitedir} \
97 ..
98%{__make}
7d487fd2 99cd ..
f0ba6589 100
7d487fd2
AM
101%if %{with tests}
102cd build
f0ba6589 103# Make sure libkolabxml.so.* is found, otherwise the tests fail
390184bb 104export LD_LIBRARY_PATH=$(pwd)/src
7d487fd2 105cd tests
f0ba6589
AM
106./bindingstest ||:
107./conversiontest ||:
108./parsingtest ||:
7d487fd2 109cd ..
f0ba6589 110php -d enable_dl=On -dextension=src/php/kolabformat.so src/php/test.php ||:
05d503b6 111%{__python} src/python/test.py ||:
7d487fd2
AM
112%endif
113
114%install
115rm -rf $RPM_BUILD_ROOT
7d487fd2 116%{__make} -C build install \
390184bb
ER
117 INSTALL='install -p' \
118 DESTDIR=$RPM_BUILD_ROOT
7d487fd2 119
390184bb
ER
120install -d $RPM_BUILD_ROOT%{php_data_dir}
121mv $RPM_BUILD_ROOT%{php_extensiondir}/kolabformat.php $RPM_BUILD_ROOT%{php_data_dir}/kolabformat.php
7d487fd2 122
390184bb
ER
123install -d $RPM_BUILD_ROOT%{php_sysconfdir}
124cat > $RPM_BUILD_ROOT%{php_sysconfdir}/kolabformat.ini <<EOF
05d503b6 125; Enable kolabformat extension module
7d487fd2
AM
126extension=kolabformat.so
127EOF
f0ba6589 128
05d503b6
ER
129%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
130%py_comp $RPM_BUILD_ROOT%{py_sitedir}
131%py_postclean
132
f0ba6589
AM
133%clean
134rm -rf $RPM_BUILD_ROOT
135
05d503b6
ER
136%post -p /sbin/ldconfig
137%postun -p /sbin/ldconfig
f0ba6589
AM
138
139%files
140%defattr(644,root,root,755)
141%doc DEVELOPMENT NEWS README
7d487fd2 142%attr(755,root,root) %{_libdir}/libkolabxml.so.*.*
37d8e7e0 143%attr(755,root,root) %ghost %{_libdir}/libkolabxml.so.1
f0ba6589
AM
144
145%files devel
146%defattr(644,root,root,755)
147%{_includedir}/kolabxml
148%{_libdir}/*.so
149%{_libdir}/cmake/Libkolabxml
150
151%files -n php-kolabformat
152%defattr(644,root,root,755)
7d487fd2 153%config(noreplace) %{php_sysconfdir}/kolabformat.ini
05d503b6 154%attr(755,root,root) %{php_extensiondir}/kolabformat.so
390184bb 155%{php_data_dir}/kolabformat.php
f0ba6589
AM
156
157%files -n python-kolabformat
158%defattr(644,root,root,755)
05d503b6 159%attr(755,root,root) %{py_sitedir}/_kolabformat.so
390184bb 160%{py_sitedir}/kolabformat.py[co]
This page took 0.107883 seconds and 4 git commands to generate.