]> git.pld-linux.org Git - packages/libipt.git/blob - libipt.spec
- group for devel
[packages/libipt.git] / libipt.spec
1 Summary:        Intel Processor Trace Decoder Library
2 Name:           libipt
3 Version:        2.0
4 Release:        1
5 License:        BSD
6 Group:          Libraries
7 URL:            https://github.com/01org/processor-trace
8 Source0:        https://github.com/01org/processor-trace/archive/v%{version}.tar.gz
9 # Source0-md5:  d7cc87d42479d41870056a99591096cd
10 # c++ is required only for -DPTUNIT test "ptunit-cpp".
11 # pandoc is for -DMAN.
12 BuildRequires:  cmake
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  pandoc
15 ExclusiveArch:  %{ix86} %{x8664}
16
17 %description
18 The Intel Processor Trace (Intel PT) Decoder Library is Intel's
19 reference implementation for decoding Intel PT. It can be used as a
20 standalone library or it can be partially or fully integrated into
21 your tool.
22
23 %package devel
24 Summary:        Header files and libraries for Intel Processor Trace Decoder Library
25 Group:          Development/Libraries
26 Requires:       %{name} = %{version}-%{release}
27 ExclusiveArch:  %{ix86} %{x8664}
28
29 %description devel
30 The %{name}-devel package contains the header files and libraries
31 needed to develop programs that use the Intel Processor Trace (Intel
32 PT) Decoder Library.
33
34 %prep
35 %setup -q -n processor-trace-%{version}
36
37 %build
38 install -d build
39 cd build
40 %cmake \
41         -DPTUNIT:BOOL=ON \
42         -DMAN:BOOL=ON \
43         -DDEVBUILD:BOOL=ON \
44         ..
45
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} -C build install \
52   DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post -p /sbin/ldconfig
58 %postun -p /sbin/ldconfig
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README
63 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.2
64 %attr(755,root,root) %{_libdir}/%{name}.so.*.*
65
66 %files devel
67 %defattr(644,root,root,755)
68 %doc doc/{getting_started,howto_libipt}.md
69 %{_includedir}/intel-pt.h
70 %attr(755,root,root) %{_libdir}/%{name}.so
71 %{_mandir}/man3/pt_*.3*
This page took 0.081352 seconds and 3 git commands to generate.