]> git.pld-linux.org Git - packages/libinput.git/blob - libinput.spec
- rel 2; add fixes from FC
[packages/libinput.git] / libinput.spec
1 #
2 # Conditional build:
3 %bcond_with     gui             # event-gui (noinst as of 0.4.0)
4 %bcond_with     static_libs     # static library
5 #
6 Summary:        Input device library
7 Summary(pl.UTF-8):      Biblioteka urządzeń wejściowych
8 Name:           libinput
9 Version:        0.16.0
10 Release:        2
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://www.freedesktop.org/software/libinput/%{name}-%{version}.tar.xz
14 # Source0-md5:  a5f5e1bb8eb2cd3bb9f5bd48f296def8
15 Patch0:         0001-filter-pass-last_velocity-as-argument.patch
16 Patch1:         0002-filter-up-the-motion-timeout-to-1-second.patch
17 Patch2:         0003-filter-enforce-minimum-velocity.patch
18 #Bug fc 1225998 - Tap-and-drag touchpad behavior not configurable
19 Patch3:         0001-touchpad-reduce-tap-n-drag-timeout-to-300ms.patch
20 # Bug fc 1227182 - Middle click pastes on button press instead of release
21 Patch4:         0001-evdev-always-default-to-the-middle-button-for-button.patch
22 URL:            http://www.freedesktop.org/wiki/Software/libinput/
23 %{?with_gui:BuildRequires:      cairo-devel}
24 BuildRequires:  check-devel >= 0.9.10
25 BuildRequires:  doxygen >= 1.6.0
26 %{?with_gui:BuildRequires:      glib2-devel >= 2.0}
27 BuildRequires:  graphviz >= 2.26.0
28 %{?with_gui:BuildRequires:      gtk+3-devel >= 3.0}
29 BuildRequires:  libevdev-devel >= 0.4
30 BuildRequires:  mtdev-devel >= 1.1.0
31 BuildRequires:  pkgconfig
32 BuildRequires:  udev-devel
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 libinput is a library that handles input devices for display servers
37 and other applications that need to directly deal with input devices.
38
39 It provides device detection, device handling, input device event
40 processing and abstraction so minimize the amount of custom input code
41 the user of libinput need to provide the common set of functionality
42 that users expect.
43
44 %description -l pl.UTF-8
45 libinput to biblioteka obsługująca urządzenia wejściowe dla serwerów
46 grafiki i innych aplikacji wymagających bezpośredniej obsługi urządzeń
47 wejściowych.
48
49 Biblioteka zapewnia wykrywanie urządzeń, obsługę urządzeń,
50 przetwarzanie zdarzeń urządzeń wejściowych oraz abstrakcję,
51 minimalizując ilość własnego kodu, który musi napisać użytkownik
52 biblioteki, aby zapewnić oczekiwaną funkcjonalność.
53
54 %package devel
55 Summary:        Development files for libinput
56 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libinput
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       udev-devel
60
61 %description devel
62 This package contains the header files for developing applications
63 that use libinput.
64
65 %description devel -l pl.UTF-8
66 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
67 wykorzystujących bibliotekę libinput.
68
69 %package static
70 Summary:        Static libinput library
71 Summary(pl.UTF-8):      Statyczna biblioteka libinput
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static libinput library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka libinput.
80
81 %package apidocs
82 Summary:        API documentation for libinput library
83 Summary(pl.UTF-8):      Dokumentacja API biblioteki libinput
84 Group:          Documentation
85
86 %description apidocs
87 API documentation for libinput library.
88
89 %description apidocs -l pl.UTF-8
90 Dokumentacja API biblioteki libinput.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98 %patch4 -p1
99
100 %build
101 %configure \
102         --disable-silent-rules \
103         %{?with_static_libs:--enable-static} \
104         --with-udev-dir=/lib/udev
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 # obsoleted by pkg-config
115 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc COPYING README.txt
126 %attr(755,root,root) %{_bindir}/libinput-debug-events
127 %attr(755,root,root) %{_bindir}/libinput-list-devices
128 %attr(755,root,root) %{_libdir}/libinput.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libinput.so.10
130 %attr(755,root,root) /lib/udev/libinput-device-group
131 /lib/udev/rules.d/80-libinput-device-groups.rules
132 /lib/udev/hwdb.d/90-libinput-model-quirks.hwdb
133 /lib/udev/rules.d/90-libinput-model-quirks.rules
134 %{_mandir}/man1/libinput-debug-events.1*
135 %{_mandir}/man1/libinput-list-devices.1*
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libinput.so
140 %{_includedir}/libinput.h
141 %{_pkgconfigdir}/libinput.pc
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libinput.a
147 %endif
148
149 %files apidocs
150 %defattr(644,root,root,755)
151 %doc doc/html/*
This page took 0.053319 seconds and 4 git commands to generate.