]> git.pld-linux.org Git - packages/libhubbub.git/blob - libhubbub.spec
- up to 0.3.0
[packages/libhubbub.git] / libhubbub.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        HTML5 compliant parsing library
6 Name:           libhubbub
7 Version:        0.3.0
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  9baf3f765e25336ab1b64da8968270f7
13 #Patch0:                lib.patch
14 URL:            http://www.netsurf-browser.org/projects/libhubbub/
15 BuildRequires:  libparserutils-devel >= 0.2.0
16 BuildRequires:  netsurf-buildsystem >= 1.1
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Hubbub is an HTML5 compliant parsing library, written in C. It was
21 developed as part of the NetSurf project and is available for use by
22 other software under the MIT licence.
23
24 The HTML5 specification defines a parsing algorithm, based on the
25 behaviour of mainstream browsers, which provides instructions for how
26 to parse all markup, both valid and invalid. As a result, Hubbub
27 parses web content well.
28
29 If you are looking for an HTML5 parser in Python or Ruby, you may wish
30 to look at html5lib.
31
32 Features:
33 - Parses HTML, good and bad
34 - Simple C API
35 - Fast
36 - Character encoding detection
37 - Well-tested (~90% test coverage)
38 - Portable
39 - Shared library
40
41 %package devel
42 Summary:        libhubbub library headers
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libhubbub
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 This is the libraries, include files and other resources you can use
49 to incorporate libhubbub into applications.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe pozwalające na używanie biblioteki libhubbub w swoich
53 programach.
54
55 %package static
56 Summary:        libhubbub static libraries
57 Summary(pl.UTF-8):      Statyczne biblioteki libhubbub
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 This is package with static libhubbub libraries.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka libhubbub.
66
67 %prep
68 %setup -q
69 #%%patch0 -p1
70
71 %build
72 export CC="%{__cc}"
73 export CFLAGS="%{rpmcflags}"
74 export LDFLAGS="%{rpmldflags}"
75
76 %{__make} Q= \
77         PREFIX=%{_prefix} \
78         COMPONENT_TYPE=lib-shared
79
80 %if %{with static_libs}
81 %{__make} Q= \
82         PREFIX=%{_prefix} \
83         COMPONENT_TYPE=lib-static
84 %endif
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} install Q= \
89         lib=%{_lib} \
90         PREFIX=%{_prefix} \
91         COMPONENT_TYPE=lib-shared \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %if %{with static_libs}
95 %{__make} install Q= \
96         lib=%{_lib} \
97         PREFIX=%{_prefix} \
98         COMPONENT_TYPE=lib-static \
99         DESTDIR=$RPM_BUILD_ROOT
100 %endif
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libhubbub.so.*.*.*
111 %ghost %{_libdir}/libhubbub.so.0
112
113 %files devel
114 %defattr(644,root,root,755)
115 %{_libdir}/libhubbub.so
116 %{_includedir}/hubbub
117 %{_pkgconfigdir}/libhubbub.pc
118
119 %if %{with static_libs}
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libhubbub.a
123 %endif
This page took 0.103825 seconds and 4 git commands to generate.