]> git.pld-linux.org Git - packages/libhubbub.git/blob - libhubbub.spec
lib.patch deleted
[packages/libhubbub.git] / libhubbub.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        HTML5 compliant parsing library
6 Name:           libhubbub
7 Version:        0.3.0
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  9baf3f765e25336ab1b64da8968270f7
13 URL:            http://www.netsurf-browser.org/projects/libhubbub/
14 BuildRequires:  libparserutils-devel >= 0.2.0
15 BuildRequires:  netsurf-buildsystem >= 1.1
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Hubbub is an HTML5 compliant parsing library, written in C. It was
20 developed as part of the NetSurf project and is available for use by
21 other software under the MIT licence.
22
23 The HTML5 specification defines a parsing algorithm, based on the
24 behaviour of mainstream browsers, which provides instructions for how
25 to parse all markup, both valid and invalid. As a result, Hubbub
26 parses web content well.
27
28 If you are looking for an HTML5 parser in Python or Ruby, you may wish
29 to look at html5lib.
30
31 Features:
32 - Parses HTML, good and bad
33 - Simple C API
34 - Fast
35 - Character encoding detection
36 - Well-tested (~90% test coverage)
37 - Portable
38 - Shared library
39
40 %package devel
41 Summary:        libhubbub library headers
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libhubbub
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 This is the libraries, include files and other resources you can use
48 to incorporate libhubbub into applications.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe pozwalające na używanie biblioteki libhubbub w swoich
52 programach.
53
54 %package static
55 Summary:        libhubbub static libraries
56 Summary(pl.UTF-8):      Statyczne biblioteki libhubbub
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 This is package with static libhubbub libraries.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka libhubbub.
65
66 %prep
67 %setup -q
68
69 %build
70 export CC="%{__cc}"
71 export CFLAGS="%{rpmcflags}"
72 export LDFLAGS="%{rpmldflags}"
73
74 %{__make} Q= \
75         PREFIX=%{_prefix} \
76         COMPONENT_TYPE=lib-shared
77
78 %if %{with static_libs}
79 %{__make} Q= \
80         PREFIX=%{_prefix} \
81         COMPONENT_TYPE=lib-static
82 %endif
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 %{__make} install Q= \
87         lib=%{_lib} \
88         PREFIX=%{_prefix} \
89         COMPONENT_TYPE=lib-shared \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %if %{with static_libs}
93 %{__make} install Q= \
94         lib=%{_lib} \
95         PREFIX=%{_prefix} \
96         COMPONENT_TYPE=lib-static \
97         DESTDIR=$RPM_BUILD_ROOT
98 %endif
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libhubbub.so.*.*.*
109 %ghost %{_libdir}/libhubbub.so.0
110
111 %files devel
112 %defattr(644,root,root,755)
113 %{_libdir}/libhubbub.so
114 %{_includedir}/hubbub
115 %{_pkgconfigdir}/libhubbub.pc
116
117 %if %{with static_libs}
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/libhubbub.a
121 %endif
This page took 0.076728 seconds and 3 git commands to generate.