]> git.pld-linux.org Git - packages/libgweather.git/blob - libgweather.spec
f2a567bb2f195da2d3d19b0c054acc98fcde1de3
[packages/libgweather.git] / libgweather.spec
1 #
2 # Conditional build:
3 %bcond_without  glade   # Glade catalog
4 %bcond_without  vala    # do not build Vala API
5
6 Summary:        Library to access weather information from online services for numerous locations
7 Summary(pl.UTF-8):      Biblioteka dostępu do informacji pogodowych z serwisów internetowych dla różnych miejsc
8 Name:           libgweather
9 Version:        3.32.1
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libgweather/3.32/%{name}-%{version}.tar.xz
14 # Source0-md5:  048de183cbeaf7353a875cb5ebd9b4f9
15 URL:            http://www.gnome.org/
16 BuildRequires:  geocode-glib-devel
17 BuildRequires:  gettext-tools >= 0.18
18 %{?with_glade:BuildRequires:    glade-devel >= 2.0}
19 BuildRequires:  glib2-devel >= 1:2.35.1
20 BuildRequires:  gobject-introspection-devel >= 0.10.0
21 BuildRequires:  gtk+3-devel >= 3.14.0
22 BuildRequires:  gtk-doc >= 1.11
23 BuildRequires:  libsoup-devel >= 2.44.0
24 BuildRequires:  libxml2-devel >= 1:2.6.30
25 BuildRequires:  meson >= 0.48.0
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pkgconfig >= 1:0.19
28 BuildRequires:  rpmbuild(macros) >= 1.736
29 BuildRequires:  tar >= 1:1.22
30 %{?with_vala:BuildRequires:     vala >= 2:0.18.0}
31 BuildRequires:  xz
32 Requires(post,postun):  /sbin/ldconfig
33 Requires(post,postun):  glib2 >= 1:2.35.1
34 Requires:       glib2 >= 1:2.35.1
35 Requires:       gtk+3 >= 3.14.0
36 Requires:       libsoup >= 2.44.0
37 Requires:       libxml2 >= 1:2.6.30
38 # sr@Latn vs. sr@latin
39 Conflicts:      glibc-misc < 6:2.7
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 libgweather is a library to access weather information from online
44 services for numerous locations.
45
46 %description -l pl.UTF-8
47 libgweather to biblioteka pozwalająca na dostęp do informacji
48 pogodowych z serwisów internetowych dla różnych miejsc.
49
50 %package devel
51 Summary:        Header files for libgweather
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgweather
53 Group:          X11/Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       gtk+3-devel >= 3.14.0
56 Requires:       libsoup-devel >= 2.44.0
57 Requires:       libxml2-devel >= 1:2.6.30
58 Obsoletes:      gnome-applets-devel <= 2.21.4
59 Obsoletes:      libgweather-static < 3.28.0
60
61 %description devel
62 Header files for libgweather.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki libgweather.
66
67 %package static
68 Summary:        Static libgweather library
69 Summary(pl.UTF-8):      Statyczna biblioteka libgweather
70 Group:          X11/Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static libgweather library.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka libgweather.
78
79 %package apidocs
80 Summary:        libgweather API documentation
81 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgweather
82 Group:          Documentation
83 Requires:       gtk-doc-common
84 %if "%{_rpmversion}" >= "5"
85 BuildArch:      noarch
86 %endif
87
88 %description apidocs
89 libgweather API documentation.
90
91 %description apidocs -l pl.UTF-8
92 Dokumentacja API biblioteki libgweather.
93
94 %package glade
95 Summary:        libgweather catalog file for Glade
96 Summary(pl.UTF-8):      Plik katalogu libgweather dla Glade
97 Group:          X11/Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99 Requires:       glade >= 2.0
100
101 %description glade
102 libgweather catalog file for Glade.
103
104 %description glade -l pl.UTF-8
105 Plik katalogu libgweather dla Glade.
106
107 %package -n vala-libgweather
108 Summary:        libgweather API for Vala language
109 Summary(pl.UTF-8):      API biblioteki libgweather dla języka Vala
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{version}-%{release}
112 Requires:       vala >= 2:0.18.0
113 %if "%{_rpmversion}" >= "5"
114 BuildArch:      noarch
115 %endif
116
117 %description -n vala-libgweather
118 libgweather API for Vala language.
119
120 %description -n vala-libgweather -l pl.UTF-8
121 API biblioteki libgweather dla języka Vala.
122
123 %prep
124 %setup -q
125
126 %build
127 %meson build \
128         -Dglade_catalog=%{!?with_glade:false}%{?with_glade:true} \
129         -Dgtk_doc=true \
130         -Dzoneinfo_dir=%{_datadir}/zoneinfo \
131         -Denable_vala=%{!?with_vala:false}%{?with_vala:true}
132
133 %ninja_build -C build
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %ninja_install -C build
139
140 # just a copy of es
141 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/es_ES
142
143 %find_lang libgweather-3.0 --all-name
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 /sbin/ldconfig
150 %glib_compile_schemas
151
152 %postun
153 /sbin/ldconfig
154 %glib_compile_schemas
155
156 %files -f libgweather-3.0.lang
157 %defattr(644,root,root,755)
158 %doc AUTHORS MAINTAINERS NEWS README.md
159 %attr(755,root,root) %{_libdir}/libgweather-3.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libgweather-3.so.15
161 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.enums.xml
162 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.gschema.xml
163 %dir %{_datadir}/libgweather
164 %{_datadir}/libgweather/Locations.xml
165 %{_datadir}/libgweather/locations.dtd
166 %{_libdir}/girepository-1.0/GWeather-3.0.typelib
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libgweather-3.so
171 %{_includedir}/libgweather-3.0
172 %{_pkgconfigdir}/gweather-3.0.pc
173 %{_datadir}/gir-1.0/GWeather-3.0.gir
174
175 %files apidocs
176 %defattr(644,root,root,755)
177 %{_gtkdocdir}/libgweather
178
179 %if %{with glade}
180 %files glade
181 %defattr(644,root,root,755)
182 %{_datadir}/glade/catalogs/libgweather.xml
183 %endif
184
185 %if %{with vala}
186 %files -n vala-libgweather
187 %defattr(644,root,root,755)
188 %{_datadir}/vala/vapi/gweather-3.0.vapi
189 %{_datadir}/vala/vapi/gweather-3.0.deps
190 %endif
This page took 0.031117 seconds and 2 git commands to generate.