]> git.pld-linux.org Git - packages/libgweather.git/blob - libgweather.spec
python deps for gen_locations_variant.py
[packages/libgweather.git] / libgweather.spec
1 #
2 # Conditional build:
3 %bcond_without  glade   # Glade catalog
4 %bcond_without  vala    # Vala API
5
6 Summary:        Library to access weather information from online services for numerous locations
7 Summary(pl.UTF-8):      Biblioteka dostępu do informacji pogodowych z serwisów internetowych dla różnych miejsc
8 Name:           libgweather
9 Version:        40.0
10 Release:        2
11 License:        GPL v2+
12 Group:          X11/Libraries
13 Source0:        https://download.gnome.org/sources/libgweather/40/%{name}-%{version}.tar.xz
14 # Source0-md5:  a9c0989890a837982defd8238e1eb356
15 URL:            https://wiki.gnome.org/Projects/LibGWeather
16 BuildRequires:  geocode-glib-devel
17 BuildRequires:  gettext-tools >= 0.18
18 %{?with_glade:BuildRequires:    glade-devel >= 2.0}
19 BuildRequires:  glib2-devel >= 1:2.44.0
20 BuildRequires:  gobject-introspection-devel >= 0.10.0
21 BuildRequires:  gtk+3-devel >= 3.14.0
22 BuildRequires:  gtk-doc >= 1.11
23 BuildRequires:  libsoup-devel >= 2.44.0
24 BuildRequires:  libxml2-devel >= 1:2.6.30
25 BuildRequires:  meson >= 0.50.0
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pkgconfig >= 1:0.19
28 BuildRequires:  python3
29 BuildRequires:  python3-modules
30 BuildRequires:  python3-pygobject3
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpmbuild(macros) >= 1.736
33 BuildRequires:  tar >= 1:1.22
34 %{?with_vala:BuildRequires:     vala >= 2:0.18.0}
35 BuildRequires:  xz
36 Requires(post,postun):  /sbin/ldconfig
37 Requires(post,postun):  glib2 >= 1:2.44.0
38 Requires:       glib2 >= 1:2.44.0
39 Requires:       gtk+3 >= 3.14.0
40 Requires:       libsoup >= 2.44.0
41 Requires:       libxml2 >= 1:2.6.30
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 libgweather is a library to access weather information from online
46 services for numerous locations.
47
48 %description -l pl.UTF-8
49 libgweather to biblioteka pozwalająca na dostęp do informacji
50 pogodowych z serwisów internetowych dla różnych miejsc.
51
52 %package devel
53 Summary:        Header files for libgweather
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgweather
55 Group:          X11/Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       glib2-devel >= 1:2.44.0
58 Requires:       gtk+3-devel >= 3.14.0
59 Requires:       libsoup-devel >= 2.44.0
60 Requires:       libxml2-devel >= 1:2.6.30
61 Obsoletes:      gnome-applets-devel <= 2.21.4
62 Obsoletes:      libgweather-static < 3.28.0
63
64 %description devel
65 Header files for libgweather.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe biblioteki libgweather.
69
70 %package static
71 Summary:        Static libgweather library
72 Summary(pl.UTF-8):      Statyczna biblioteka libgweather
73 Group:          X11/Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static libgweather library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka libgweather.
81
82 %package apidocs
83 Summary:        libgweather API documentation
84 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgweather
85 Group:          Documentation
86 Requires:       gtk-doc-common
87 BuildArch:      noarch
88
89 %description apidocs
90 libgweather API documentation.
91
92 %description apidocs -l pl.UTF-8
93 Dokumentacja API biblioteki libgweather.
94
95 %package glade
96 Summary:        libgweather catalog file for Glade
97 Summary(pl.UTF-8):      Plik katalogu libgweather dla Glade
98 Group:          X11/Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100 Requires:       glade >= 2.0
101 BuildArch:      noarch
102
103 %description glade
104 libgweather catalog file for Glade.
105
106 %description glade -l pl.UTF-8
107 Plik katalogu libgweather dla Glade.
108
109 %package -n vala-libgweather
110 Summary:        libgweather API for Vala language
111 Summary(pl.UTF-8):      API biblioteki libgweather dla języka Vala
112 Group:          Development/Libraries
113 Requires:       %{name}-devel = %{version}-%{release}
114 Requires:       vala >= 2:0.18.0
115 BuildArch:      noarch
116
117 %description -n vala-libgweather
118 libgweather API for Vala language.
119
120 %description -n vala-libgweather -l pl.UTF-8
121 API biblioteki libgweather dla języka Vala.
122
123 %prep
124 %setup -q
125
126 %build
127 %meson build \
128         -Dglade_catalog=%{!?with_glade:false}%{?with_glade:true} \
129         -Dgtk_doc=true \
130         -Dzoneinfo_dir=%{_datadir}/zoneinfo \
131         -Denable_vala=%{!?with_vala:false}%{?with_vala:true}
132
133 %ninja_build -C build
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %ninja_install -C build
139
140 # just a copy of es
141 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/es_ES
142
143 %find_lang libgweather-3.0 --all-name
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 /sbin/ldconfig
150 %glib_compile_schemas
151
152 %postun
153 /sbin/ldconfig
154 %glib_compile_schemas
155
156 %files -f libgweather-3.0.lang
157 %defattr(644,root,root,755)
158 %doc AUTHORS NEWS README.md
159 %attr(755,root,root) %{_libdir}/libgweather-3.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libgweather-3.so.16
161 %dir %{_libdir}/libgweather
162 %{_libdir}/libgweather/Locations.bin
163 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.enums.xml
164 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.gschema.xml
165 %dir %{_datadir}/libgweather
166 %{_datadir}/libgweather/Locations.xml
167 %{_datadir}/libgweather/locations.dtd
168 %{_libdir}/girepository-1.0/GWeather-3.0.typelib
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libgweather-3.so
173 %{_includedir}/libgweather-3.0
174 %{_pkgconfigdir}/gweather-3.0.pc
175 %{_datadir}/gir-1.0/GWeather-3.0.gir
176
177 %files apidocs
178 %defattr(644,root,root,755)
179 %{_gtkdocdir}/libgweather
180
181 %if %{with glade}
182 %files glade
183 %defattr(644,root,root,755)
184 %{_datadir}/glade/catalogs/libgweather.xml
185 %endif
186
187 %if %{with vala}
188 %files -n vala-libgweather
189 %defattr(644,root,root,755)
190 %{_datadir}/vala/vapi/gweather-3.0.vapi
191 %{_datadir}/vala/vapi/gweather-3.0.deps
192 %endif
This page took 0.58718 seconds and 3 git commands to generate.