]> git.pld-linux.org Git - packages/libglvnd.git/blob - libglvnd.spec
acd50e83a601efa4e6057f6eaf4bea0ffa644dc4
[packages/libglvnd.git] / libglvnd.spec
1 # TODO:
2 # - what should provide GL headers when %{with default_gl}? packages with khronos headers alone?
3 #
4 # Conditional build:
5 %bcond_with     default_gl      # build dispatcher as default libGL/libGLX/libGLESv1_CM/libGLESv2 provider
6 #
7 Summary:        Vendor-neutral OpenGL dispatch library
8 Summary(pl.UTF-8):      Niezależna od producenta biblioteka przekazująca wywołania OpenGL
9 Name:           libglvnd
10 Version:        0.1.1
11 Release:        1
12 License:        MIT-like
13 Group:          Libraries
14 #Source0Download: https://github.com/NVIDIA/libglvnd/releases
15 Source0:        https://github.com/NVIDIA/libglvnd/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  564820301daf6b4c7d80cbfbc04efc8c
17 URL:            https://github.com/NVIDIA/libglvnd
18 BuildRequires:  autoconf >= 2.63
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  python >= 1:2.7
23 BuildRequires:  python-modules >= 1:2.7
24 BuildRequires:  xorg-lib-libX11-devel
25 BuildRequires:  xorg-lib-libXext-devel
26 BuildRequires:  xorg-proto-glproto-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %if %{with default_gl}
30 %define         gl_libdir       %{_libdir}
31 %else
32 %define         gl_libdir       %{_libdir}/%{name}
33 %define         noautoprov_files        %{_libdir}/%{name}
34 %endif
35
36 %description
37 This is a work-in-progress implementation of the vendor-neutral
38 dispatch layer for arbitrating OpenGL API calls between multiple
39 vendors on a per-screen basis, as described by Andy Ritger's OpenGL
40 ABI proposal:
41 <https://github.com/aritger/linux-opengl-abi-proposal/blob/master/linux-opengl-abi-proposal.txt>.
42
43 Currently, only the GLX window-system API and OpenGL are supported,
44 but in the future this library may support EGL and OpenGL ES as well.
45
46 %description -l pl.UTF-8
47 Ten pakiet to (będąca w trakcie tworzenia) implementacja warstwy
48 przekazującej wywołania dowolnych wywołań API OpenGL między różnymi
49 producentami w zależności od ekranu, zgodnie z propozycją opisaną
50 przez Andy Ritgera:
51 <https://github.com/aritger/linux-opengl-abi-proposal/blob/master/linux-opengl-abi-proposal.txt>.
52
53 Obecnie obsługiwane jest tylko API systemu okienek GLX oraz OpenGL, w
54 przyszłości biblioteka może obsługiwać także EGL i OpenGL ES.
55
56 %package devel
57 Summary:        Header files for libglvnd interface
58 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu libglvnd
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 # <GL/gl.h>
62 Requires:       OpenGL-devel
63 # <GL/glx.h>
64 Requires:       OpenGL-GLX-devel
65
66 %description devel
67 Header files for libglvnd interface.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe interfejsu libglvnd.
71
72 %package libGL
73 Summary:        OpenGL 4.x interface glvnd libraries
74 Summary(pl.UTF-8):      Biblioteki glvnd interfejsu OpenGL 4.x
75 Group:          Libraries
76 Requires:       %{name} = %{version}-%{release}
77
78 %description libGL
79 OpenGL 4.x interface glvnd libraries.
80
81 %description libGL -l pl.UTF-8
82 Biblioteki glvnd interfejsu OpenGL 4.x.
83
84 %package libGL-devel
85 Summary:        Development files for glvnd OpenGL 4.x interface
86 Summary(pl.UTF-8):      Pliki programistyczne glvnd interfejsu OpenGL 4.x
87 Group:          Development/Libraries
88 Requires:       %{name}-libGL = %{version}-%{release}
89 #Requires:      khronos-OpenGL-headers(?)
90 #%{?with_default_gl:Provides:   OpenGL-devel = 4.?}
91
92 %description libGL-devel
93 Development files for glvnd OpenGL 4.x interface.
94
95 %description libGL-devel -l pl.UTF-8
96 Pliki programistyczne glvnd interfejsu OpenGL 4.x.
97
98 %package libGLES
99 Summary:        OpenGL ES 1, 2, 3 interface glvnd libraries
100 Summary(pl.UTF-8):      Biblioteki glvnd interfejsów OpenGL ES 1, 2, 3
101 Group:          Libraries
102 Requires:       %{name} = %{version}-%{release}
103
104 %description libGLES
105 OpenGL ES 1, 2, 3 interface glvnd libraries.
106
107 %description libGLES -l pl.UTF-8
108 Biblioteki glvnd interfejsów OpenGL ES 1, 2, 3.
109
110 %package libGLES-devel
111 Summary:        Development files for glvnd OpenGL ES 1, 2, 3 interfaces
112 Summary(pl.UTF-8):      Pliki programistyczne glvnd interfejsów OpenGL ES 1, 2, 3
113 Group:          Development/Libraries
114 Requires:       %{name}-libGLES = %{version}-%{release}
115 #Requires:      khronos-OpenGLES-headers(?)
116 %if 0 && %{with default_gl}
117 Provides:       OpenGLES-devel
118 Provides:       OpenGLESv1-devel = 1.?
119 Provides:       OpenGLESv2-devel = 2.?
120 Provides:       OpenGLESv3-devel = 3.?
121 %endif
122
123 %description libGLES-devel
124 Development files for glvnd OpenGL ES 1, 2, 3 interfaces.
125
126 %description libGLES-devel -l pl.UTF-8
127 Pliki programistyczne glvnd interfejsów OpenGL ES 1, 2, 3.
128
129 %prep
130 %setup -q
131
132 %build
133 %{__libtoolize}
134 %{__aclocal} -I m4
135 %{__autoconf}
136 %{__autoheader}
137 %{__automake}
138 %configure \
139         --disable-silent-rules \
140         %{!?with_static_libs:--disable-static}
141 %{__make}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
150
151 %if %{without default_gl}
152 install -d $RPM_BUILD_ROOT%{gl_libdir}
153 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib{GL,GLESv1_CM,GLESv2}.* $RPM_BUILD_ROOT%{gl_libdir}
154 %endif
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   -p /sbin/ldconfig
160 %postun -p /sbin/ldconfig
161
162 %post   libGL -p /sbin/ldconfig
163 %postun libGL -p /sbin/ldconfig
164
165 %post   libGLES -p /sbin/ldconfig
166 %postun libGLES -p /sbin/ldconfig
167
168 %files
169 %defattr(644,root,root,755)
170 %doc README.md
171 %attr(755,root,root) %{_libdir}/libGLdispatch.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libGLdispatch.so.0
173 %if %{without default_gl}
174 %dir %{_libdir}/%{name}
175 %endif
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libGLdispatch.so
180 %{_includedir}/glvnd
181 %{_pkgconfigdir}/libglvnd.pc
182
183 %files libGL
184 %defattr(644,root,root,755)
185 %if %{with default_gl}
186 %attr(755,root,root) %{_libdir}/libGL.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
188 %attr(755,root,root) %{_libdir}/libGL.so
189 %else
190 %attr(755,root,root) %{gl_libdir}/libGL.so.*.*.*
191 %attr(755,root,root) %{gl_libdir}/libGL.so.1
192 %attr(755,root,root) %{gl_libdir}/libGL.so
193 %endif
194
195 %attr(755,root,root) %{_libdir}/libGLX.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libGLX.so.0
197
198 %attr(755,root,root) %{_libdir}/libOpenGL.so.*.*.*
199 %attr(755,root,root) %ghost %{_libdir}/libOpenGL.so.0
200
201 %files libGL-devel
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/libGLX.so
204 %attr(755,root,root) %{_libdir}/libOpenGL.so
205
206 %files libGLES
207 %defattr(644,root,root,755)
208 %if %{with default_gl}
209 %attr(755,root,root) %{_libdir}/libGLESv1_CM.so.*.*.*
210 %attr(755,root,root) %ghost %{_libdir}/libGLESv1_CM.so.1
211 %attr(755,root,root) %{_libdir}/libGLESv2.so.*.*.*
212 %attr(755,root,root) %ghost %{_libdir}/libGLESv2.so.2
213 %else
214 %attr(755,root,root) %{gl_libdir}/libGLESv1_CM.so.*.*.*
215 %attr(755,root,root) %{gl_libdir}/libGLESv1_CM.so.1
216 %attr(755,root,root) %{gl_libdir}/libGLESv2.so.*.*.*
217 %attr(755,root,root) %{gl_libdir}/libGLESv2.so.2
218 %endif
219
220 %files libGLES-devel
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{gl_libdir}/libGLESv1_CM.so
223 %attr(755,root,root) %{gl_libdir}/libGLESv2.so
This page took 0.059463 seconds and 2 git commands to generate.