]> git.pld-linux.org Git - packages/libgit2.git/commitdiff
- updated to 0.19.0 auto/th/libgit2-0.19.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 21 Jul 2013 12:27:44 +0000 (14:27 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 21 Jul 2013 12:27:44 +0000 (14:27 +0200)
- removed obsolete http-parser patch

libgit2-http-parser.patch [deleted file]
libgit2.spec

diff --git a/libgit2-http-parser.patch b/libgit2-http-parser.patch
deleted file mode 100644 (file)
index f8c98d1..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-From 893373eaacf15f24c6d98e75d44833730c923f95 Mon Sep 17 00:00:00 2001
-From: Veeti Paananen <veeti.paananen@rojekti.fi>
-Date: Thu, 2 May 2013 14:07:22 +0300
-Subject: [PATCH] Build with the system's http-parser installation if available
-
----
- CMakeLists.txt                      | 15 +++++++++++---
- cmake/Modules/FindHTTP_Parser.cmake | 39 +++++++++++++++++++++++++++++++++++++
- 2 files changed, 51 insertions(+), 3 deletions(-)
- create mode 100644 cmake/Modules/FindHTTP_Parser.cmake
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 6bd25aa..10caa16 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -14,6 +14,8 @@
- PROJECT(libgit2 C)
- CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
-+SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
-+
- # Build options
- #
- OPTION( SONAME                                "Set the (SO)VERSION of the target"             ON  )
-@@ -97,8 +99,16 @@ ELSE ()
-       IF (NOT AMIGA)
-               FIND_PACKAGE(OpenSSL)
-       ENDIF ()
--      FILE(GLOB SRC_HTTP deps/http-parser/*.c)
--      INCLUDE_DIRECTORIES(deps/http-parser)
-+
-+      FIND_PACKAGE(HTTP_Parser QUIET)
-+      IF (HTTP_PARSER_FOUND AND HTTP_PARSER_VERSION_MAJOR EQUAL 2)
-+              INCLUDE_DIRECTORIES(${HTTP_PARSER_INCLUDE_DIRS})
-+              LINK_LIBRARIES(${HTTP_PARSER_LIBRARIES})
-+      ELSE()
-+              MESSAGE("http-parser was not found or is too old; using bundled 3rd-party sources.")
-+              INCLUDE_DIRECTORIES(deps/http-parser)
-+              FILE(GLOB SRC_HTTP deps/http-parser/*.c)
-+      ENDIF()
- ENDIF()
- # Specify sha1 implementation
-diff --git a/cmake/Modules/FindHTTP_Parser.cmake b/cmake/Modules/FindHTTP_Parser.cmake
-new file mode 100644
-index 0000000..d92bf75
---- /dev/null
-+++ b/cmake/Modules/FindHTTP_Parser.cmake
-@@ -0,0 +1,39 @@
-+# - Try to find http-parser
-+#
-+# Defines the following variables:
-+#
-+# HTTP_PARSER_FOUND - system has http-parser
-+# HTTP_PARSER_INCLUDE_DIR - the http-parser include directory
-+# HTTP_PARSER_LIBRARIES - Link these to use http-parser
-+# HTTP_PARSER_VERSION_MAJOR - major version
-+# HTTP_PARSER_VERSION_MINOR - minor version
-+# HTTP_PARSER_VERSION_STRING - the version of http-parser found
-+
-+# Find the header and library
-+FIND_PATH(HTTP_PARSER_INCLUDE_DIR NAMES http_parser.h)
-+FIND_LIBRARY(HTTP_PARSER_LIBRARY NAMES http_parser libhttp_parser)
-+
-+# Found the header, read version
-+if (HTTP_PARSER_INCLUDE_DIR AND EXISTS "${HTTP_PARSER_INCLUDE_DIR}/http_parser.h")
-+      FILE(READ "${HTTP_PARSER_INCLUDE_DIR}/http_parser.h" HTTP_PARSER_H)
-+      IF (HTTP_PARSER_H)
-+              STRING(REGEX REPLACE ".*#define[\t ]+HTTP_PARSER_VERSION_MAJOR[\t ]+([0-9]+).*" "\\1" HTTP_PARSER_VERSION_MAJOR "${HTTP_PARSER_H}")
-+              STRING(REGEX REPLACE ".*#define[\t ]+HTTP_PARSER_VERSION_MINOR[\t ]+([0-9]+).*" "\\1" HTTP_PARSER_VERSION_MINOR "${HTTP_PARSER_H}")
-+              SET(HTTP_PARSER_VERSION_STRING "${HTTP_PARSER_VERSION_MAJOR}.${HTTP_PARSER_VERSION_MINOR}")
-+      ENDIF()
-+      UNSET(HTTP_PARSER_H)
-+ENDIF()
-+
-+# Handle the QUIETLY and REQUIRED arguments and set HTTP_PARSER_FOUND
-+# to TRUE if all listed variables are TRUE
-+INCLUDE(FindPackageHandleStandardArgs)
-+FIND_PACKAGE_HANDLE_STANDARD_ARGS(HTTP_Parser REQUIRED_VARS HTTP_PARSER_INCLUDE_DIR HTTP_PARSER_LIBRARY)
-+
-+# Hide advanced variables
-+MARK_AS_ADVANCED(HTTP_PARSER_INCLUDE_DIR HTTP_PARSER_LIBRARY)
-+
-+# Set standard variables
-+IF (HTTP_PARSER_FOUND)
-+      SET(HTTP_PARSER_LIBRARIES ${HTTP_PARSER_LIBRARY})
-+      set(HTTP_PARSER_INCLUDE_DIRS ${HTTP_PARSER_INCLUDE_DIR})
-+ENDIF()
--- 
-1.8.3
-
index f5caed33c9bc2ccace9d2ad3441ef45e7e4bf01e..85da836b9c87f6ef09db78e74ca9f8fd10405dd2 100644 (file)
@@ -6,17 +6,17 @@
 Summary:       C git library
 Summary(pl.UTF-8):     Biblioteka git dla C
 Name:          libgit2
-Version:       0.18.0
+Version:       0.19.0
 Release:       1
 License:       GPL v2 with linking exception
 Group:         Libraries
-Source0:       https://github.com/libgit2/libgit2/archive/v%{version}.tar.gz?/%{name}-version.tgz
-# Source0-md5: ce6845df0dd084ef2633a69dba64929c
-Patch0:                %{name}-http-parser.patch
-Patch1:                %{name}-test-online.patch
+Source0:       https://github.com/libgit2/libgit2/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
+# Source0-md5: d682d9424d95f697bf3f89b358fe8e1a
+Patch0:                %{name}-test-online.patch
 URL:           http://libgit2.github.com/
 BuildRequires: cmake >= 2.6
 BuildRequires: http-parser-devel
+BuildRequires: libssh2-devel
 BuildRequires: openssl-devel
 %{?with_tests:BuildRequires:   python}
 BuildRequires: zlib-devel
@@ -51,12 +51,12 @@ Pliki nagłówkowe biblioteki libgit2.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
 install -d build
 cd build
-%cmake %{?with_tests_online:-DONLINE_TESTS=1} ..
+%cmake .. \
+       %{?with_tests_online:-DONLINE_TESTS=1}
 %{__make}
 
 %{?with_tests:%{__make} test ARGS="-V"}
This page took 0.043162 seconds and 4 git commands to generate.