]> git.pld-linux.org Git - packages/libgit2.git/blob - libgit2.spec
63e21b01d6a889f4d7ed1387ce664ef2d7b86787
[packages/libgit2.git] / libgit2.spec
1 #
2 # Conditional build:
3 %bcond_without  curl            # Use cURL for HTTP
4 %bcond_without  kerberos5       # GSSAPI for SPNEGO auth
5 %bcond_without  libssh          # SSH support via libssh2
6 %bcond_without  tests           # build without tests
7
8 Summary:        C Git library
9 Summary(pl.UTF-8):      Biblioteka Git dla C
10 Name:           libgit2
11 Version:        0.27.4
12 Release:        4
13 License:        GPL v2 with linking exception
14 Group:          Libraries
15 #Source0Download: https://github.com/libgit2/libgit2/releases
16 Source0:        https://github.com/libgit2/libgit2/archive/v%{version}/%{name}-%{version}.tar.gz
17 # Source0-md5:  d38b06b3de52ff5ef0c29e7b5dbe415b
18 Patch0:         %{name}-no-libgit2-test.patch
19 URL:            http://libgit2.github.com/
20 BuildRequires:  cmake >= 2.8
21 %{?with_curl:BuildRequires:     curl-devel}
22 %{?with_kerberos5:BuildRequires:        heimdal-devel}
23 BuildRequires:  http-parser-devel >= 2
24 %{?with_libssh:BuildRequires:   libssh2-devel}
25 BuildRequires:  openssl-devel
26 BuildRequires:  pkgconfig
27 %{?with_tests:BuildRequires:    python}
28 BuildRequires:  rpmbuild(macros) >= 1.742
29 BuildRequires:  zlib-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 libgit2 is a portable, pure C implementation of the Git core methods
34 provided as a re-entrant linkable library with a solid API, allowing
35 you to write native speed custom Git applications in any language with
36 bindings.
37
38 %description -l pl.UTF-8
39 libgit2 to przenośna implementacja w czystym C głównych metod Gita,
40 udostępniona jako bezpieczna dla wątków biblioteka ze stałym API,
41 pozwalająca na pisanie własnych aplikacji dla Gita o natywnej
42 szybkości w dowolnym języku posiadającym odpowiednie wiązania.
43
44 %package devel
45 Summary:        Header files for libgit2 library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgit2
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       http-parser-devel
50 Requires:       libssh2-devel
51 Requires:       openssl-devel
52 Requires:       zlib-devel
53
54 %description devel
55 Header files for libgit2 library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki libgit2.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63
64 # Don't test network
65 sed -i 's/ionline/xonline/' tests/CMakeLists.txt
66
67 %build
68 install -d build
69 cd build
70 # CMakeLists.txt supports only relative LIB_INSTALL_DIR and INCLUDE_INSTALL_DIR
71 # (otherwise .pc file is generated incorrectly).
72 # Type (:PATH or :STRING) must be specified explicitly to avoid expansion
73 # relative to cwd.
74 %cmake .. \
75         -DINCLUDE_INSTALL_DIR:PATH=include \
76         -DLIB_INSTALL_DIR:PATH=%{_lib} \
77         %{cmake_on_off tests BUILD_CLAR} \
78         %{cmake_on_off curl CURL} \
79         %{cmake_on_off kerberos5 USE_GSSAPI} \
80         %{cmake_on_off libssh USE_SSH} \
81         -DTHREADSAFE:BOOL=ON
82 %{__make}
83
84 %{?with_tests:%{__make} test ARGS="-V"}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} -C build install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS CONTRIBUTING.md COPYING README.md
100 %attr(755,root,root) %{_libdir}/libgit2.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libgit2.so.27
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libgit2.so
106 %{_includedir}/git2.h
107 %{_includedir}/git2
108 %{_pkgconfigdir}/libgit2.pc
This page took 0.049427 seconds and 2 git commands to generate.