]> git.pld-linux.org Git - packages/libgee.git/blob - libgee.spec
f963cab02c20548f14f1ba7c7c0af9d50906d9fb
[packages/libgee.git] / libgee.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation (valadoc)
4 %bcond_without  static_libs     # static library
5 %bcond_with     bootstrap       # bootstrap without apidocs subpackage (alias for without_apidocs)
6
7 %if %{with bootstrap}
8 %undefine       with_apidocs
9 %endif
10 Summary:        libgee - GObject collection library
11 Summary(pl.UTF-8):      libgee - biblioteka kolekcji oparta na GObject
12 Name:           libgee
13 Version:        0.20.3
14 Release:        1
15 License:        LGPL v2+
16 Group:          Libraries
17 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libgee/0.20/%{name}-%{version}.tar.xz
18 # Source0-md5:  e574b3952b93d219b5ec7c74c5892c33
19 Patch0:         %{name}-doc.patch
20 URL:            https://wiki.gnome.org/Projects/Libgee
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake >= 1:1.11
23 BuildRequires:  glib2-devel >= 1:2.36.0
24 BuildRequires:  gobject-introspection-devel >= 0.9.0
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  tar >= 1:1.22
28 %{?with_apidocs:BuildRequires:  valadoc}
29 BuildRequires:  xz
30 # not required for stable releases (all generated files are included)
31 #BuildRequires: vala >= 2:0.25.1
32 Requires:       glib2 >= 1:2.36.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 libgee is a collection library providing GObject-based interfaces and
37 classes for commonly used data structures.
38
39 %description -l pl.UTF-8
40 libgee jest biblioteką udostępniajacą oparte na bibliotece GObject
41 interfejsy oraz klasy powszechnie używanych struktur danych.
42
43 %package devel
44 Summary:        Header files for libgee library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgee
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 1:2.36.0
49
50 %description devel
51 Header files for libgee library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki libgee.
55
56 %package static
57 Summary:        Static libgee library
58 Summary(pl.UTF-8):      Statyczna biblioteka libgee
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static libgee library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka libgee.
67
68 %package -n vala-libgee
69 Summary:        libgee API for Vala language
70 Summary(pl.UTF-8):      API libgee dla języka Vala
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73 Requires:       vala >= 2:0.25.1
74 %if "%{_rpmversion}" >= "5"
75 BuildArch:      noarch
76 %endif
77
78 %description -n vala-libgee
79 libgee API for Vala language.
80
81 %description -n vala-libgee -l pl.UTF-8
82 API libgee dla języka Vala.
83
84 %package apidocs
85 Summary:        API documentation for libgee library
86 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgee
87 Group:          Documentation
88 %if "%{_rpmversion}" >= "5"
89 BuildArch:      noarch
90 %endif
91
92 %description apidocs
93 API documentation for libgee library.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API biblioteki libgee.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 %build
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108 %configure \
109         %{?with_apidocs:--enable-doc} \
110         --disable-silent-rules \
111         %{?with_static_libs:--enable-static}
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgee-0.8.la
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
131 %attr(755,root,root) %{_libdir}/libgee-0.8.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libgee-0.8.so.2
133 %{_libdir}/girepository-1.0/Gee-0.8.typelib
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libgee-0.8.so
138 %{_pkgconfigdir}/gee-0.8.pc
139 %{_includedir}/gee-0.8
140 %{_datadir}/gir-1.0/Gee-0.8.gir
141
142 %if %{with static_libs}
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libgee-0.8.a
146 %endif
147
148 %files -n vala-libgee
149 %defattr(644,root,root,755)
150 %{_datadir}/vala/vapi/gee-0.8.vapi
151
152 %if %{with apidocs}
153 %files apidocs
154 %defattr(644,root,root,755)
155 %{_datadir}/devhelp/references/gee-0.8
156 %endif
This page took 0.065567 seconds and 2 git commands to generate.