]> git.pld-linux.org Git - packages/libgda3.git/blob - libgda3.spec
- release 15 (by relup.sh)
[packages/libgda3.git] / libgda3.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # don't generate html documentation
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_with     gamin           # use gamin instead of fam library
6 %bcond_without  gnomevfs        # build without gnome-vfs support
7 %bcond_without  gnome           # without gnomevfs (convenience alias)
8 # - database plugins:
9 %bcond_without  firebird        # build without firebird plugin
10 %bcond_with     freetds         # build with freetds plugin
11 %bcond_without  ldap            # build without ldap plugin
12 %bcond_without  mdb             # build without MDB plugin
13 %bcond_without  mysql           # build without MySQL plugin
14 %bcond_without  odbc            # build without unixODBC
15 %bcond_without  pgsql           # build without PostgreSQL plugin
16 %bcond_without  sqlite          # build without sqlite plugin
17 %bcond_without  sybase          # build without sybase plugin
18 %bcond_without  xbase           # build without xbase plugin
19 #
20 %if %{without gnome}
21 %undefine       with_gnomevfs
22 %endif
23 %ifnarch %{ix86} sparc sparcv9 alpha
24 %undefine       with_firebird
25 %endif
26 Summary:        GNU Data Access library
27 Summary(pl.UTF-8):      Biblioteka GNU Data Access
28 Name:           libgda3
29 Version:        3.1.5
30 Release:        15
31 License:        LGPL v2+/GPL v2+
32 Group:          Libraries
33 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgda/3.1/libgda-%{version}.tar.bz2
34 # Source0-md5:  eb7da5286a112e7cff3111c89fba4456
35 Patch0:         %{name}-configure.patch
36 Patch1:         %{name}-am.patch
37 Patch2:         glib232.patch
38 URL:            http://www.gnome-db.org/
39 %{?with_firebird:BuildRequires: Firebird-devel}
40 BuildRequires:  autoconf >= 2.59
41 BuildRequires:  automake >= 1:1.8
42 BuildRequires:  bison
43 BuildRequires:  db-devel
44 BuildRequires:  docbook-dtd412-xml
45 %{!?with_gamin:BuildRequires:   fam-devel}
46 BuildRequires:  flex
47 %{?with_freetds:BuildRequires:  freetds-devel = 0.64}
48 %{?with_sybase:BuildRequires:   freetds-devel >= 0.82}
49 %{?with_gamin:BuildRequires:    gamin-devel >= 0.1.8}
50 BuildRequires:  gettext-devel
51 BuildRequires:  glib2-devel >= 1:2.12.0
52 BuildRequires:  gnome-common >= 2.12.0
53 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.20}
54 BuildRequires:  gtk-doc >= 1.6
55 BuildRequires:  intltool >= 0.35.5
56 BuildRequires:  libgcrypt-devel >= 1.1.42
57 BuildRequires:  libtool
58 BuildRequires:  libxml2-devel >= 1:2.6.26
59 BuildRequires:  libxslt-devel >= 1.1.17
60 %{?with_mdb:BuildRequires:      mdbtools-devel >= 0.6}
61 %{?with_mysql:BuildRequires:    mysql-devel}
62 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
63 BuildRequires:  perl-base
64 BuildRequires:  pkgconfig
65 BuildRequires:  popt-devel
66 %{?with_pgsql:BuildRequires:    postgresql-devel}
67 BuildRequires:  readline-devel >= 5.0
68 BuildRequires:  rpmbuild(macros) >= 1.213
69 %{?with_sqlite:BuildRequires:   sqlite3-devel >= 3.5.0-2}
70 %{?with_odbc:BuildRequires:     unixODBC-devel}
71 %{?with_xbase:BuildRequires:    xbase-devel >= 2.0.0}
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _libgdadir      libgda-3.0
75 %define         _providersdir   %{_libdir}/%{_libgdadir}/providers
76
77 %description
78 GNU Data Access is an attempt to provide uniform access to different
79 kinds of data sources (databases, information servers, mail spools,
80 etc). It is a complete architecture that provides all you need to
81 access your data.
82
83 libgda was part of the GNOME-DB project but has been separated from it
84 to allow non-GNOME applications to be developed based on it.
85
86 %description -l pl.UTF-8
87 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
88 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
89 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
90 potrzebujesz do dostępu do danych.
91
92 libgda była częścią projektu GNOME-DB, ale została wydzielona, aby
93 pozwolić na używanie przez niegnomowe aplikacje.
94
95 %package devel
96 Summary:        GNU Data Access development files
97 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GNU Data Access
98 Group:          Development/Libraries
99 Requires:       %{name} = %{version}-%{release}
100 %{!?with_gamin:Requires:        fam-devel}
101 %{?with_gamin:Requires: gamin-devel >= 0.1.8}
102 Requires:       glib2-devel >= 1:2.12.0
103 %{?with_gnomevfs:Requires:      gnome-vfs2-devel >= 2.20}
104 Requires:       gtk-doc-common
105 Requires:       libgcrypt-devel >= 1.1.42
106 Requires:       libxml2-devel >= 1:2.6.26
107 Requires:       libxslt-devel >= 1.1.17
108 Obsoletes:      libgda0-devel
109
110 %description devel
111 GNU Data Access is an attempt to provide uniform access to different
112 kinds of data sources (databases, information servers, mail spools,
113 etc). It is a complete architecture that provides all you need to
114 access your data. This subpackage contains development files.
115
116 %description devel -l pl.UTF-8
117 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
118 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
119 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
120 potrzebujesz do dostępu do danych. Ten podpakiet zawiera pliki dla
121 programistów używających libgda.
122
123 %package static
124 Summary:        GNU Data Access static libraries
125 Summary(pl.UTF-8):      Statyczne biblioteki GNU Data Access
126 Group:          Development/Libraries
127 Requires:       %{name}-devel = %{version}-%{release}
128
129 %description static
130 GNU Data Access static libraries.
131
132 %description static -l pl.UTF-8
133 Statyczne biblioteki GNU Data Access.
134
135 %package provider-db
136 Summary:        GDA Berkeley DB provider
137 Summary(pl.UTF-8):      Źródło danych Berkeley DB dla GDA
138 Group:          Libraries
139 Requires:       %{name} = %{version}-%{release}
140
141 %description provider-db
142 This package contains the GDA Berkeley DB provider.
143
144 %description provider-db -l pl.UTF-8
145 Pakiet dostaczający dane z Berkeley DB dla GDA.
146
147 %package provider-firebird
148 Summary:        GDA Firebird provider
149 Summary(pl.UTF-8):      Źródło danych Firebird dla GDA
150 Group:          Libraries
151 Requires:       %{name} = %{version}-%{release}
152
153 %description provider-firebird
154 This package contains the GDA Firebird provider.
155
156 %description provider-firebird -l pl.UTF-8
157 Pakiet dostarczający dane z Firebird dla GDA.
158
159 %package provider-freetds
160 Summary:        GDA FreeTDS provider
161 Summary(pl.UTF-8):      Źródło danych FreeTDS dla GDA
162 Group:          Libraries
163 Requires:       %{name} = %{version}-%{release}
164
165 %description provider-freetds
166 This package contains the GDA FreeTDS provider.
167
168 %description provider-freetds -l pl.UTF-8
169 Pakiet dostarczający dane z FreeTDS dla GDA.
170
171 %package provider-ldap
172 Summary:        GDA LDAP provider
173 Summary(pl.UTF-8):      Źródło danych LDAP dla GDA
174 Group:          Libraries
175 Requires:       %{name} = %{version}-%{release}
176
177 %description provider-ldap
178 This package contains the GDA LDAP provider.
179
180 %description provider-ldap -l pl.UTF-8
181 Pakiet dostarczający dane z LDAP dla GDA
182
183 %package provider-mdb
184 Summary:        GDA MDB provider
185 Summary(pl.UTF-8):      Źródło danych MDB
186 Group:          Libraries
187 Requires:       %{name} = %{version}-%{release}
188 Requires:       mdbtools-libs >= 0.6
189
190 %description provider-mdb
191 This package contains the GDA MDB provider.
192
193 %description provider-mdb -l pl.UTF-8
194 Pakiet dostarczający dane z MDB dla GDA.
195
196 %package provider-mysql
197 Summary:        GDA MySQL provider
198 Summary(pl.UTF-8):      Źródło danych MySQL dla GDA
199 Group:          Libraries
200 Requires:       %{name} = %{version}-%{release}
201 Obsoletes:      libgda-mysql0
202
203 %description provider-mysql
204 This package contains the GDA MySQL provider.
205
206 %description provider-mysql -l pl.UTF-8
207 Pakiet dostarczający dane z MySQL dla GDA.
208
209 %package provider-odbc
210 Summary:        GDA ODBC provider
211 Summary(pl.UTF-8):      Źródło danych ODBC dla GDA
212 Group:          Libraries
213 Requires:       %{name} = %{version}-%{release}
214
215 %description provider-odbc
216 This package contains the GDA ODBC provider.
217
218 %description provider-odbc -l pl.UTF-8
219 Pakiet dostarczający dane z ODBC dla GDA.
220
221 %package provider-postgres
222 Summary:        GDA PostgreSQL provider
223 Summary(pl.UTF-8):      Źródło danych PostgreSQL dla GDA
224 Group:          Libraries
225 Requires:       %{name} = %{version}-%{release}
226 Obsoletes:      libgda-postgres0
227
228 %description provider-postgres
229 This package contains the GDA PostgreSQL provider.
230
231 %description provider-postgres -l pl.UTF-8
232 Pakiet dostarczający dane z PostgreSQL dla GDA.
233
234 %package provider-sqlite
235 Summary:        GDA SQLite provider
236 Summary(pl.UTF-8):      Źródło danych SQLite dla GDA
237 Group:          Libraries
238 Requires:       %{name} = %{version}-%{release}
239
240 %description provider-sqlite
241 This package contains the GDA SQLite provider.
242
243 %description provider-sqlite -l pl.UTF-8
244 Pakiet dostarczający dane z SQLite dla GDA.
245
246 %package provider-sybase
247 Summary:        GDA Sybase provider
248 Summary(pl.UTF-8):      Źródło danych Sybase dla GDA
249 Group:          Libraries
250 Requires:       %{name} = %{version}-%{release}
251
252 %description provider-sybase
253 This package contains the GDA Sybase provider.
254
255 %description provider-sybase -l pl.UTF-8
256 Pakiet dostarczający dane z Sybase dla GDA.
257
258 %package provider-xbase
259 Summary:        GDA xBase provider
260 Summary(pl.UTF-8):      Źródło danych xBase dla GDA
261 Group:          Libraries
262 Requires:       %{name} = %{version}-%{release}
263
264 %description provider-xbase
265 This package contains the GDA xBase (dBase, Clipper, FoxPro) provider.
266
267 %description provider-xbase -l pl.UTF-8
268 Pakiet dostarczający dane z xBase (dBase, Clippera, FoxPro) dla GDA.
269
270 %prep
271 %setup -q -n libgda-%{version}
272 %patch0 -p1
273 %patch1 -p1
274 %patch2 -p1
275
276 %if %{without gamin}
277 sed -i -e 's#PKG_CHECK_MODULES(GAMIN.*)#have_fam=no#g' configure.in
278 %endif
279 %if %{without gnomevfs}
280 sed -i -e 's#PKG_CHECK_MODULES(GNOMEVFS.*)#have_gnomevfs=no#g' configure.in
281 %endif
282
283 %build
284 CXXFLAGS="%{rpmcxxflags} -fno-rtti -fno-exceptions"
285 %{__intltoolize}
286 %{__libtoolize}
287 %{__aclocal}
288 %{__autoconf}
289 %{__automake}
290 %configure \
291         %{!?with_static_libs:--disable-static} \
292         %{?with_doc:--enable-gtk-doc} \
293         --with-html-dir=%{_gtkdocdir} \
294         --with%{!?with_firebird:out}-firebird \
295         --with%{!?with_ldap:out}-ldap \
296         --with%{!?with_mdb:out}-mdb \
297         --with%{!?with_mysql:out}-mysql \
298         --with%{!?with_odbc:out}-odbc \
299         --with%{!?with_pgsql:out}-postgres \
300         --with%{!?with_sqlite:out}-sqlite \
301         --with%{!?with_freetds:out}-tds \
302         --with%{!?with_xbase:out}-xbase \
303         %{?with_sybase:--with-sybase=/usr} \
304         --without-oracle
305 %{__make} -j1
306
307 %install
308 rm -rf $RPM_BUILD_ROOT
309
310 %{__make} install \
311         DESTDIR=$RPM_BUILD_ROOT \
312         HTML_DIR=%{_gtkdocdir}
313
314 # modules dlopened by *.so through libgmodule
315 %if %{with static_libs}
316 %{__rm} $RPM_BUILD_ROOT%{_providersdir}/*.a
317 %endif
318 %{__rm} $RPM_BUILD_ROOT{%{_providersdir},%{_libdir}}/*.la
319
320 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{sr@Latn,sr@latin}
321
322 %find_lang libgda-3.0
323
324 %clean
325 rm -rf $RPM_BUILD_ROOT
326
327 %post   -p /sbin/ldconfig
328 %postun -p /sbin/ldconfig
329
330 %files -f libgda-3.0.lang
331 %defattr(644,root,root,755)
332 %doc AUTHORS ChangeLog NEWS README
333 %attr(755,root,root) %{_bindir}/gda-config-tool-3.0
334 %attr(755,root,root) %{_bindir}/gda-list-server-op-3.0
335 %attr(755,root,root) %{_libdir}/libgda-3.0.so.*.*.*
336 %attr(755,root,root) %ghost %{_libdir}/libgda-3.0.so.3
337 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so.*.*.*
338 %attr(755,root,root) %ghost %{_libdir}/libgda-report-3.0.so.3
339 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so.*.*.*
340 %attr(755,root,root) %ghost %{_libdir}/libgda-xslt-3.0.so.0
341 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so.*.*.*
342 %attr(755,root,root) %ghost %{_libdir}/libgdasql-3.0.so.3
343 %dir %{_libdir}/%{_libgdadir}
344 %dir %{_providersdir}
345 %{_datadir}/libgda-3.0
346 %dir %{_sysconfdir}/libgda-3.0
347 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libgda-3.0/config
348 %{_mandir}/man1/gda-config-tool-3.0.1*
349 %{_mandir}/man5/gda-config-3.0.5*
350
351 %files devel
352 %defattr(644,root,root,755)
353 %attr(755,root,root) %{_bindir}/gda-author-dict-file-3.0
354 %attr(755,root,root) %{_bindir}/gda-bdb-test
355 %attr(755,root,root) %{_bindir}/gda-diagnose-3.0
356 %attr(755,root,root) %{_bindir}/gda-inspect-dict-file-3.0
357 %attr(755,root,root) %{_bindir}/gda-list-config-3.0
358 %attr(755,root,root) %{_bindir}/gda-sql-3.0
359 %attr(755,root,root) %{_bindir}/gda-test-connection-3.0
360 %attr(755,root,root) %{_libdir}/libgda-3.0.so
361 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so
362 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so
363 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so
364 %{_includedir}/libgda-3.0
365 %{_pkgconfigdir}/libgda-3.0.pc
366 %{_pkgconfigdir}/libgda-*-3.0.pc
367 %{_sysconfdir}/libgda-3.0/sales_test.db
368 %{?with_doc:%{_gtkdocdir}/libgda-3.0}
369
370 %if %{with static_libs}
371 %files static
372 %defattr(644,root,root,755)
373 %{_libdir}/libgda-3.0.a
374 %{_libdir}/libgda-report-3.0.a
375 %{_libdir}/libgda-xslt-3.0.a
376 %{_libdir}/libgdasql-3.0.a
377 %endif
378
379 %files provider-db
380 %defattr(644,root,root,755)
381 %attr(755,root,root) %{_providersdir}/libgda-bdb.so
382
383 %if %{with firebird}
384 %files provider-firebird
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{_providersdir}/libgda-firebird.so
387 %endif
388
389 %if %{with freetds}
390 %files provider-freetds
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_providersdir}/libgda-freetds.so
393 %endif
394
395 %if %{with ldap}
396 %files provider-ldap
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_providersdir}/libgda-ldap.so
399 %endif
400
401 %if %{with mdb}
402 %files provider-mdb
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_providersdir}/libgda-mdb.so
405 %endif
406
407 %if %{with mysql}
408 %files provider-mysql
409 %defattr(644,root,root,755)
410 %attr(755,root,root) %{_providersdir}/libgda-mysql.so
411 %endif
412
413 %if %{with odbc}
414 %files provider-odbc
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_providersdir}/libgda-odbc.so
417 %endif
418
419 %if %{with pgsql}
420 %files provider-postgres
421 %defattr(644,root,root,755)
422 %attr(755,root,root) %{_providersdir}/libgda-postgres.so
423 %endif
424
425 %if %{with sqlite}
426 %files provider-sqlite
427 %defattr(644,root,root,755)
428 %attr(755,root,root) %{_providersdir}/libgda-sqlite.so
429 %endif
430
431 %if %{with sybase}
432 %files provider-sybase
433 %defattr(644,root,root,755)
434 %attr(755,root,root) %{_providersdir}/libgda-sybase.so
435 %endif
436
437 %if %{with xbase}
438 %files provider-xbase
439 %defattr(644,root,root,755)
440 %attr(755,root,root) %{_providersdir}/libgda-xbase.so
441 %endif
This page took 0.115399 seconds and 4 git commands to generate.