]> git.pld-linux.org Git - packages/libgda3.git/blob - libgda3.spec
- fixed freetds BRs, release 3
[packages/libgda3.git] / libgda3.spec
1 #
2 # TODO: package dotnet-gda-sharp
3 #
4 # Conditional build:
5 %bcond_without  doc             # don't generate html documentation
6 %bcond_without  static_libs     # don't build static libraries
7 %bcond_with     gamin           # use gamin instead of fam library
8 %bcond_without  gnomevfs        # build without gnome-vfs support
9 %bcond_without  gnome           # without gnomevfs (convenience alias)
10 # - database plugins:
11 %bcond_without  firebird        # build without firebird plugin
12 %bcond_without  freetds         # build without freetds plugin
13 %bcond_without  ldap            # build without ldap plugin
14 %bcond_without  mdb             # build without MDB plugin
15 %bcond_without  mysql           # build without MySQL plugin
16 %bcond_without  odbc            # build without unixODBC
17 %bcond_without  pgsql           # build without PostgreSQL plugin
18 %bcond_without  sqlite          # build without sqlite plugin
19 %bcond_without  sybase          # build without sybase plugin
20 %bcond_without  xbase           # build without xbase plugin
21 #
22 %if %{without gnome}
23 %undefine       with_gnomevfs
24 %endif
25 %ifnarch %{ix86} sparc sparcv9 alpha
26 %undefine       with_firebird
27 %endif
28 Summary:        GNU Data Access library
29 Summary(pl.UTF-8):      Biblioteka GNU Data Access
30 Name:           libgda3
31 Version:        3.1.4
32 Release:        3
33 License:        LGPL v2+/GPL v2+
34 Group:          Libraries
35 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgda/3.1/libgda-%{version}.tar.bz2
36 # Source0-md5:  e584211e04b502d3fb747236c913378e
37 Patch1:         %{name}-configure.patch
38 URL:            http://www.gnome-db.org/
39 %{?with_firebird:BuildRequires: Firebird-devel}
40 BuildRequires:  autoconf >= 2.59
41 BuildRequires:  automake >= 1:1.8
42 BuildRequires:  bison
43 BuildRequires:  db-devel
44 %{!?with_gamin:BuildRequires:   fam-devel}
45 BuildRequires:  flex
46 %{?with_freetds:BuildRequires:  freetds-devel >= 0.82}
47 %{?with_gamin:BuildRequires:    gamin-devel >= 0.1.8}
48 BuildRequires:  glib2-devel >= 1:2.12.0
49 BuildRequires:  gnome-common >= 2.12.0
50 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.20}
51 BuildRequires:  gtk-doc >= 1.6
52 BuildRequires:  intltool >= 0.35.5
53 BuildRequires:  libgcrypt-devel >= 1.1.42
54 BuildRequires:  libtool
55 BuildRequires:  libxml2-devel >= 1:2.6.26
56 BuildRequires:  libxslt-devel >= 1.1.17
57 %{?with_mdb:BuildRequires:      mdbtools-devel >= 0.6}
58 %{?with_mysql:BuildRequires:    mysql-devel}
59 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
60 BuildRequires:  perl-base
61 BuildRequires:  popt-devel
62 %{?with_pgsql:BuildRequires:    postgresql-devel}
63 BuildRequires:  readline-devel >= 5.0
64 BuildRequires:  rpmbuild(macros) >= 1.213
65 %{?with_sqlite:BuildRequires:   sqlite3-devel >= 3.5.0-2}
66 %{?with_sybase:BuildRequires:   freetds-devel >= 0.82}
67 %{?with_odbc:BuildRequires:     unixODBC-devel}
68 %{?with_xbase:BuildRequires:    xbase-devel >= 2.0.0}
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _libgdadir      libgda-3.0
72 %define         _providersdir   %{_libdir}/%{_libgdadir}/providers
73
74 %description
75 GNU Data Access is an attempt to provide uniform access to different
76 kinds of data sources (databases, information servers, mail spools,
77 etc). It is a complete architecture that provides all you need to
78 access your data.
79
80 libgda was part of the GNOME-DB project but has been separated from it
81 to allow non-GNOME applications to be developed based on it.
82
83 %description -l pl.UTF-8
84 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
85 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
86 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
87 potrzebujesz do dostępu do danych.
88
89 libgda była częścią projektu GNOME-DB, ale została wydzielona, aby
90 pozwolić na używanie przez niegnomowe aplikacje.
91
92 %package devel
93 Summary:        GNU Data Access development files
94 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GNU Data Access
95 Group:          Development/Libraries
96 Requires:       %{name} = %{version}-%{release}
97 %{!?with_gamin:Requires:        fam-devel}
98 %{?with_gamin:Requires: gamin-devel >= 0.1.8}
99 Requires:       glib2-devel >= 1:2.12.0
100 %{?with_gnomevfs:Requires:      gnome-vfs2-devel >= 2.20}
101 Requires:       gtk-doc-common
102 Requires:       libgcrypt-devel >= 1.1.42
103 Requires:       libxml2-devel >= 1:2.6.26
104 Requires:       libxslt-devel >= 1.1.17
105 Obsoletes:      libgda0-devel
106
107 %description devel
108 GNU Data Access is an attempt to provide uniform access to different
109 kinds of data sources (databases, information servers, mail spools,
110 etc). It is a complete architecture that provides all you need to
111 access your data. This subpackage contains development files.
112
113 %description devel -l pl.UTF-8
114 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
115 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
116 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
117 potrzebujesz do dostępu do danych. Ten podpakiet zawiera pliki dla
118 programistów używających libgda.
119
120 %package static
121 Summary:        GNU Data Access static libraries
122 Summary(pl.UTF-8):      Statyczne biblioteki GNU Data Access
123 Group:          Development/Libraries
124 Requires:       %{name}-devel = %{version}-%{release}
125
126 %description static
127 GNU Data Access static libraries.
128
129 %description static -l pl.UTF-8
130 Statyczne biblioteki GNU Data Access.
131
132 %package provider-db
133 Summary:        GDA Berkeley DB provider
134 Summary(pl.UTF-8):      Źródło danych Berkeley DB dla GDA
135 Group:          Libraries
136 Requires:       %{name} = %{version}-%{release}
137
138 %description provider-db
139 This package contains the GDA Berkeley DB provider.
140
141 %description provider-db -l pl.UTF-8
142 Pakiet dostaczający dane z Berkeley DB dla GDA.
143
144 %package provider-firebird
145 Summary:        GDA Firebird provider
146 Summary(pl.UTF-8):      Źródło danych Firebird dla GDA
147 Group:          Libraries
148 Requires:       %{name} = %{version}-%{release}
149
150 %description provider-firebird
151 This package contains the GDA Firebird provider.
152
153 %description provider-firebird -l pl.UTF-8
154 Pakiet dostarczający dane z Firebird dla GDA.
155
156 %package provider-freetds
157 Summary:        GDA FreeTDS provider
158 Summary(pl.UTF-8):      Źródło danych FreeTDS dla GDA
159 Group:          Libraries
160 Requires:       %{name} = %{version}-%{release}
161
162 %description provider-freetds
163 This package contains the GDA FreeTDS provider.
164
165 %description provider-freetds -l pl.UTF-8
166 Pakiet dostarczający dane z FreeTDS dla GDA.
167
168 %package provider-ldap
169 Summary:        GDA LDAP provider
170 Summary(pl.UTF-8):      Źródło danych LDAP dla GDA
171 Group:          Libraries
172 Requires:       %{name} = %{version}-%{release}
173
174 %description provider-ldap
175 This package contains the GDA LDAP provider.
176
177 %description provider-ldap -l pl.UTF-8
178 Pakiet dostarczający dane z LDAP dla GDA
179
180 %package provider-mdb
181 Summary:        GDA MDB provider
182 Summary(pl.UTF-8):      Źródło danych MDB
183 Group:          Libraries
184 Requires:       %{name} = %{version}-%{release}
185 Requires:       mdbtools-libs >= 0.6
186
187 %description provider-mdb
188 This package contains the GDA MDB provider.
189
190 %description provider-mdb -l pl.UTF-8
191 Pakiet dostarczający dane z MDB dla GDA.
192
193 %package provider-mysql
194 Summary:        GDA MySQL provider
195 Summary(pl.UTF-8):      Źródło danych MySQL dla GDA
196 Group:          Libraries
197 Requires:       %{name} = %{version}-%{release}
198 Obsoletes:      libgda-mysql0
199
200 %description provider-mysql
201 This package contains the GDA MySQL provider.
202
203 %description provider-mysql -l pl.UTF-8
204 Pakiet dostarczający dane z MySQL dla GDA.
205
206 %package provider-odbc
207 Summary:        GDA ODBC provider
208 Summary(pl.UTF-8):      Źródło danych ODBC dla GDA
209 Group:          Libraries
210 Requires:       %{name} = %{version}-%{release}
211
212 %description provider-odbc
213 This package contains the GDA ODBC provider.
214
215 %description provider-odbc -l pl.UTF-8
216 Pakiet dostarczający dane z ODBC dla GDA.
217
218 %package provider-postgres
219 Summary:        GDA PostgreSQL provider
220 Summary(pl.UTF-8):      Źródło danych PostgreSQL dla GDA
221 Group:          Libraries
222 Requires:       %{name} = %{version}-%{release}
223 Obsoletes:      libgda-postgres0
224
225 %description provider-postgres
226 This package contains the GDA PostgreSQL provider.
227
228 %description provider-postgres -l pl.UTF-8
229 Pakiet dostarczający dane z PostgreSQL dla GDA.
230
231 %package provider-sqlite
232 Summary:        GDA SQLite provider
233 Summary(pl.UTF-8):      Źródło danych SQLite dla GDA
234 Group:          Libraries
235 Requires:       %{name} = %{version}-%{release}
236
237 %description provider-sqlite
238 This package contains the GDA SQLite provider.
239
240 %description provider-sqlite -l pl.UTF-8
241 Pakiet dostarczający dane z SQLite dla GDA.
242
243 %package provider-sybase
244 Summary:        GDA Sybase provider
245 Summary(pl.UTF-8):      Źródło danych Sybase dla GDA
246 Group:          Libraries
247 Requires:       %{name} = %{version}-%{release}
248
249 %description provider-sybase
250 This package contains the GDA Sybase provider.
251
252 %description provider-sybase -l pl.UTF-8
253 Pakiet dostarczający dane z Sybase dla GDA.
254
255 %package provider-xbase
256 Summary:        GDA xBase provider
257 Summary(pl.UTF-8):      Źródło danych xBase dla GDA
258 Group:          Libraries
259 Requires:       %{name} = %{version}-%{release}
260
261 %description provider-xbase
262 This package contains the GDA xBase (dBase, Clipper, FoxPro) provider.
263
264 %description provider-xbase -l pl.UTF-8
265 Pakiet dostarczający dane z xBase (dBase, Clippera, FoxPro) dla GDA.
266
267 %prep
268 %setup -q -n libgda-%{version}
269 %patch1 -p1
270
271 %if %{without gamin}
272 sed -i -e 's#PKG_CHECK_MODULES(GAMIN.*)#have_fam=no#g' configure.in
273 %endif
274 %if %{without gnomevfs}
275 sed -i -e 's#PKG_CHECK_MODULES(GNOMEVFS.*)#have_gnomevfs=no#g' configure.in
276 %endif
277
278 %build
279 CXXFLAGS="%{rpmcxxflags} -fno-rtti -fno-exceptions"
280 %{__intltoolize}
281 %{__libtoolize}
282 %{__aclocal}
283 %{__autoconf}
284 %{__automake}
285 %configure \
286         %{!?with_static_libs:--disable-static} \
287         %{?with_doc:--enable-gtk-doc} \
288         --with-html-dir=%{_gtkdocdir} \
289         --with%{!?with_firebird:out}-firebird \
290         --with%{!?with_ldap:out}-ldap \
291         --with%{!?with_mdb:out}-mdb \
292         --with%{!?with_mysql:out}-mysql \
293         --with%{!?with_odbc:out}-odbc \
294         --with%{!?with_pgsql:out}-postgres \
295         --with%{!?with_sqlite:out}-sqlite \
296         --with%{!?with_freetds:out}-tds \
297         --with%{!?with_xbase:out}-xbase \
298         %{?with_sybase:--with-sybase=/usr} \
299         --without-oracle
300 %{__make} -j1
301
302 %install
303 rm -rf $RPM_BUILD_ROOT
304
305 %{__make} install \
306         DESTDIR=$RPM_BUILD_ROOT \
307         HTML_DIR=%{_gtkdocdir}
308
309 # modules dlopened by *.so through libgmodule
310 rm -f $RPM_BUILD_ROOT%{_providersdir}/*.{a,la}
311
312 %find_lang libgda-3.0
313
314 %clean
315 rm -rf $RPM_BUILD_ROOT
316
317 %post   -p /sbin/ldconfig
318 %postun -p /sbin/ldconfig
319
320 %files -f libgda-3.0.lang
321 %defattr(644,root,root,755)
322 %doc AUTHORS ChangeLog NEWS README
323 %attr(755,root,root) %{_bindir}/gda-config-tool-3.0
324 %attr(755,root,root) %{_bindir}/gda-list-server-op-3.0
325 %attr(755,root,root) %{_libdir}/libgda-3.0.so.*.*.*
326 %attr(755,root,root) %ghost %{_libdir}/libgda-3.0.so.3
327 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so.*.*.*
328 %attr(755,root,root) %ghost %{_libdir}/libgda-report-3.0.so.3
329 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so.*.*.*
330 %attr(755,root,root) %ghost %{_libdir}/libgda-xslt-3.0.so.0
331 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so.*.*.*
332 %attr(755,root,root) %ghost %{_libdir}/libgdasql-3.0.so.3
333 %dir %{_libdir}/%{_libgdadir}
334 %dir %{_providersdir}
335 %{_datadir}/libgda-3.0
336 %dir %{_sysconfdir}/libgda-3.0
337 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libgda-3.0/config
338 %{_mandir}/man1/gda-config-tool-3.0.1*
339 %{_mandir}/man5/gda-config-3.0.5*
340
341 %files devel
342 %defattr(644,root,root,755)
343 %attr(755,root,root) %{_bindir}/gda-author-dict-file-3.0
344 %attr(755,root,root) %{_bindir}/gda-bdb-test
345 %attr(755,root,root) %{_bindir}/gda-diagnose-3.0
346 %attr(755,root,root) %{_bindir}/gda-inspect-dict-file-3.0
347 %attr(755,root,root) %{_bindir}/gda-list-config-3.0
348 %attr(755,root,root) %{_bindir}/gda-sql-3.0
349 %attr(755,root,root) %{_bindir}/gda-test-connection-3.0
350 %attr(755,root,root) %{_libdir}/libgda-3.0.so
351 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so
352 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so
353 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so
354 %{_libdir}/libgda-3.0.la
355 %{_libdir}/libgda-report-3.0.la
356 %{_libdir}/libgda-xslt-3.0.la
357 %{_libdir}/libgdasql-3.0.la
358 %{_includedir}/libgda-3.0
359 %{_pkgconfigdir}/libgda-3.0.pc
360 %{_pkgconfigdir}/libgda-*-3.0.pc
361 %{_sysconfdir}/libgda-3.0/sales_test.db
362 %{?with_doc:%{_gtkdocdir}/libgda-3.0}
363
364 %if %{with static_libs}
365 %files static
366 %defattr(644,root,root,755)
367 %{_libdir}/libgda-3.0.a
368 %{_libdir}/libgda-report-3.0.a
369 %{_libdir}/libgda-xslt-3.0.a
370 %{_libdir}/libgdasql-3.0.a
371 %endif
372
373 %files provider-db
374 %defattr(644,root,root,755)
375 %attr(755,root,root) %{_providersdir}/libgda-bdb.so
376
377 %if %{with firebird}
378 %files provider-firebird
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{_providersdir}/libgda-firebird.so
381 %endif
382
383 %if %{with freetds}
384 %files provider-freetds
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{_providersdir}/libgda-freetds.so
387 %endif
388
389 %if %{with ldap}
390 %files provider-ldap
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_providersdir}/libgda-ldap.so
393 %endif
394
395 %if %{with mdb}
396 %files provider-mdb
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_providersdir}/libgda-mdb.so
399 %endif
400
401 %if %{with mysql}
402 %files provider-mysql
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_providersdir}/libgda-mysql.so
405 %endif
406
407 %if %{with odbc}
408 %files provider-odbc
409 %defattr(644,root,root,755)
410 %attr(755,root,root) %{_providersdir}/libgda-odbc.so
411 %endif
412
413 %if %{with pgsql}
414 %files provider-postgres
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_providersdir}/libgda-postgres.so
417 %endif
418
419 %if %{with sqlite}
420 %files provider-sqlite
421 %defattr(644,root,root,755)
422 %attr(755,root,root) %{_providersdir}/libgda-sqlite.so
423 %endif
424
425 %if %{with sybase}
426 %files provider-sybase
427 %defattr(644,root,root,755)
428 %attr(755,root,root) %{_providersdir}/libgda-sybase.so
429 %endif
430
431 %if %{with xbase}
432 %files provider-xbase
433 %defattr(644,root,root,755)
434 %attr(755,root,root) %{_providersdir}/libgda-xbase.so
435 %endif
This page took 0.078737 seconds and 4 git commands to generate.