]> git.pld-linux.org Git - packages/libgda3.git/blob - libgda3.spec
cb64fb51d905e995051650769f5c1fcc2a9a3402
[packages/libgda3.git] / libgda3.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # don't generate html documentation
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_with     gamin           # use gamin instead of fam library
6 %bcond_without  gnomevfs        # build without gnome-vfs support
7 %bcond_without  gnome           # without gnomevfs (convenience alias)
8 # - database plugins:
9 %bcond_without  firebird        # build without firebird plugin
10 %bcond_with     freetds         # build with freetds plugin
11 %bcond_without  ldap            # build without ldap plugin
12 %bcond_without  mdb             # build without MDB plugin
13 %bcond_without  mysql           # build without MySQL plugin
14 %bcond_without  odbc            # build without unixODBC
15 %bcond_without  pgsql           # build without PostgreSQL plugin
16 %bcond_without  sqlite          # build without sqlite plugin
17 %bcond_without  sybase          # build without sybase plugin
18 %bcond_without  xbase           # build without xbase plugin
19 #
20 %if %{without gnome}
21 %undefine       with_gnomevfs
22 %endif
23 %ifnarch %{ix86} sparc sparcv9 alpha
24 %undefine       with_firebird
25 %endif
26 Summary:        GNU Data Access library
27 Summary(pl.UTF-8):      Biblioteka GNU Data Access
28 Name:           libgda3
29 Version:        3.1.5
30 Release:        11
31 License:        LGPL v2+/GPL v2+
32 Group:          Libraries
33 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgda/3.1/libgda-%{version}.tar.bz2
34 # Source0-md5:  eb7da5286a112e7cff3111c89fba4456
35 Patch0:         %{name}-configure.patch
36 Patch1:         %{name}-am.patch
37 URL:            http://www.gnome-db.org/
38 %{?with_firebird:BuildRequires: Firebird-devel}
39 BuildRequires:  autoconf >= 2.59
40 BuildRequires:  automake >= 1:1.8
41 BuildRequires:  bison
42 BuildRequires:  db-devel
43 BuildRequires:  docbook-dtd412-xml
44 %{!?with_gamin:BuildRequires:   fam-devel}
45 BuildRequires:  flex
46 %{?with_freetds:BuildRequires:  freetds-devel = 0.64}
47 %{?with_sybase:BuildRequires:   freetds-devel >= 0.82}
48 %{?with_gamin:BuildRequires:    gamin-devel >= 0.1.8}
49 BuildRequires:  gettext-devel
50 BuildRequires:  glib2-devel >= 1:2.12.0
51 BuildRequires:  gnome-common >= 2.12.0
52 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.20}
53 BuildRequires:  gtk-doc >= 1.6
54 BuildRequires:  intltool >= 0.35.5
55 BuildRequires:  libgcrypt-devel >= 1.1.42
56 BuildRequires:  libtool
57 BuildRequires:  libxml2-devel >= 1:2.6.26
58 BuildRequires:  libxslt-devel >= 1.1.17
59 %{?with_mdb:BuildRequires:      mdbtools-devel >= 0.6}
60 %{?with_mysql:BuildRequires:    mysql-devel}
61 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
62 BuildRequires:  perl-base
63 BuildRequires:  pkgconfig
64 BuildRequires:  popt-devel
65 %{?with_pgsql:BuildRequires:    postgresql-devel}
66 BuildRequires:  readline-devel >= 5.0
67 BuildRequires:  rpmbuild(macros) >= 1.213
68 %{?with_sqlite:BuildRequires:   sqlite3-devel >= 3.5.0-2}
69 %{?with_odbc:BuildRequires:     unixODBC-devel}
70 %{?with_xbase:BuildRequires:    xbase-devel >= 2.0.0}
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %define         _libgdadir      libgda-3.0
74 %define         _providersdir   %{_libdir}/%{_libgdadir}/providers
75
76 %description
77 GNU Data Access is an attempt to provide uniform access to different
78 kinds of data sources (databases, information servers, mail spools,
79 etc). It is a complete architecture that provides all you need to
80 access your data.
81
82 libgda was part of the GNOME-DB project but has been separated from it
83 to allow non-GNOME applications to be developed based on it.
84
85 %description -l pl.UTF-8
86 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
87 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
88 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
89 potrzebujesz do dostępu do danych.
90
91 libgda była częścią projektu GNOME-DB, ale została wydzielona, aby
92 pozwolić na używanie przez niegnomowe aplikacje.
93
94 %package devel
95 Summary:        GNU Data Access development files
96 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GNU Data Access
97 Group:          Development/Libraries
98 Requires:       %{name} = %{version}-%{release}
99 %{!?with_gamin:Requires:        fam-devel}
100 %{?with_gamin:Requires: gamin-devel >= 0.1.8}
101 Requires:       glib2-devel >= 1:2.12.0
102 %{?with_gnomevfs:Requires:      gnome-vfs2-devel >= 2.20}
103 Requires:       gtk-doc-common
104 Requires:       libgcrypt-devel >= 1.1.42
105 Requires:       libxml2-devel >= 1:2.6.26
106 Requires:       libxslt-devel >= 1.1.17
107 Obsoletes:      libgda0-devel
108
109 %description devel
110 GNU Data Access is an attempt to provide uniform access to different
111 kinds of data sources (databases, information servers, mail spools,
112 etc). It is a complete architecture that provides all you need to
113 access your data. This subpackage contains development files.
114
115 %description devel -l pl.UTF-8
116 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
117 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
118 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
119 potrzebujesz do dostępu do danych. Ten podpakiet zawiera pliki dla
120 programistów używających libgda.
121
122 %package static
123 Summary:        GNU Data Access static libraries
124 Summary(pl.UTF-8):      Statyczne biblioteki GNU Data Access
125 Group:          Development/Libraries
126 Requires:       %{name}-devel = %{version}-%{release}
127
128 %description static
129 GNU Data Access static libraries.
130
131 %description static -l pl.UTF-8
132 Statyczne biblioteki GNU Data Access.
133
134 %package provider-db
135 Summary:        GDA Berkeley DB provider
136 Summary(pl.UTF-8):      Źródło danych Berkeley DB dla GDA
137 Group:          Libraries
138 Requires:       %{name} = %{version}-%{release}
139
140 %description provider-db
141 This package contains the GDA Berkeley DB provider.
142
143 %description provider-db -l pl.UTF-8
144 Pakiet dostaczający dane z Berkeley DB dla GDA.
145
146 %package provider-firebird
147 Summary:        GDA Firebird provider
148 Summary(pl.UTF-8):      Źródło danych Firebird dla GDA
149 Group:          Libraries
150 Requires:       %{name} = %{version}-%{release}
151
152 %description provider-firebird
153 This package contains the GDA Firebird provider.
154
155 %description provider-firebird -l pl.UTF-8
156 Pakiet dostarczający dane z Firebird dla GDA.
157
158 %package provider-freetds
159 Summary:        GDA FreeTDS provider
160 Summary(pl.UTF-8):      Źródło danych FreeTDS dla GDA
161 Group:          Libraries
162 Requires:       %{name} = %{version}-%{release}
163
164 %description provider-freetds
165 This package contains the GDA FreeTDS provider.
166
167 %description provider-freetds -l pl.UTF-8
168 Pakiet dostarczający dane z FreeTDS dla GDA.
169
170 %package provider-ldap
171 Summary:        GDA LDAP provider
172 Summary(pl.UTF-8):      Źródło danych LDAP dla GDA
173 Group:          Libraries
174 Requires:       %{name} = %{version}-%{release}
175
176 %description provider-ldap
177 This package contains the GDA LDAP provider.
178
179 %description provider-ldap -l pl.UTF-8
180 Pakiet dostarczający dane z LDAP dla GDA
181
182 %package provider-mdb
183 Summary:        GDA MDB provider
184 Summary(pl.UTF-8):      Źródło danych MDB
185 Group:          Libraries
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       mdbtools-libs >= 0.6
188
189 %description provider-mdb
190 This package contains the GDA MDB provider.
191
192 %description provider-mdb -l pl.UTF-8
193 Pakiet dostarczający dane z MDB dla GDA.
194
195 %package provider-mysql
196 Summary:        GDA MySQL provider
197 Summary(pl.UTF-8):      Źródło danych MySQL dla GDA
198 Group:          Libraries
199 Requires:       %{name} = %{version}-%{release}
200 Obsoletes:      libgda-mysql0
201
202 %description provider-mysql
203 This package contains the GDA MySQL provider.
204
205 %description provider-mysql -l pl.UTF-8
206 Pakiet dostarczający dane z MySQL dla GDA.
207
208 %package provider-odbc
209 Summary:        GDA ODBC provider
210 Summary(pl.UTF-8):      Źródło danych ODBC dla GDA
211 Group:          Libraries
212 Requires:       %{name} = %{version}-%{release}
213
214 %description provider-odbc
215 This package contains the GDA ODBC provider.
216
217 %description provider-odbc -l pl.UTF-8
218 Pakiet dostarczający dane z ODBC dla GDA.
219
220 %package provider-postgres
221 Summary:        GDA PostgreSQL provider
222 Summary(pl.UTF-8):      Źródło danych PostgreSQL dla GDA
223 Group:          Libraries
224 Requires:       %{name} = %{version}-%{release}
225 Obsoletes:      libgda-postgres0
226
227 %description provider-postgres
228 This package contains the GDA PostgreSQL provider.
229
230 %description provider-postgres -l pl.UTF-8
231 Pakiet dostarczający dane z PostgreSQL dla GDA.
232
233 %package provider-sqlite
234 Summary:        GDA SQLite provider
235 Summary(pl.UTF-8):      Źródło danych SQLite dla GDA
236 Group:          Libraries
237 Requires:       %{name} = %{version}-%{release}
238
239 %description provider-sqlite
240 This package contains the GDA SQLite provider.
241
242 %description provider-sqlite -l pl.UTF-8
243 Pakiet dostarczający dane z SQLite dla GDA.
244
245 %package provider-sybase
246 Summary:        GDA Sybase provider
247 Summary(pl.UTF-8):      Źródło danych Sybase dla GDA
248 Group:          Libraries
249 Requires:       %{name} = %{version}-%{release}
250
251 %description provider-sybase
252 This package contains the GDA Sybase provider.
253
254 %description provider-sybase -l pl.UTF-8
255 Pakiet dostarczający dane z Sybase dla GDA.
256
257 %package provider-xbase
258 Summary:        GDA xBase provider
259 Summary(pl.UTF-8):      Źródło danych xBase dla GDA
260 Group:          Libraries
261 Requires:       %{name} = %{version}-%{release}
262
263 %description provider-xbase
264 This package contains the GDA xBase (dBase, Clipper, FoxPro) provider.
265
266 %description provider-xbase -l pl.UTF-8
267 Pakiet dostarczający dane z xBase (dBase, Clippera, FoxPro) dla GDA.
268
269 %prep
270 %setup -q -n libgda-%{version}
271 %patch0 -p1
272 %patch1 -p1
273
274 %if %{without gamin}
275 sed -i -e 's#PKG_CHECK_MODULES(GAMIN.*)#have_fam=no#g' configure.in
276 %endif
277 %if %{without gnomevfs}
278 sed -i -e 's#PKG_CHECK_MODULES(GNOMEVFS.*)#have_gnomevfs=no#g' configure.in
279 %endif
280
281 %build
282 CXXFLAGS="%{rpmcxxflags} -fno-rtti -fno-exceptions"
283 %{__intltoolize}
284 %{__libtoolize}
285 %{__aclocal}
286 %{__autoconf}
287 %{__automake}
288 %configure \
289         %{!?with_static_libs:--disable-static} \
290         %{?with_doc:--enable-gtk-doc} \
291         --with-html-dir=%{_gtkdocdir} \
292         --with%{!?with_firebird:out}-firebird \
293         --with%{!?with_ldap:out}-ldap \
294         --with%{!?with_mdb:out}-mdb \
295         --with%{!?with_mysql:out}-mysql \
296         --with%{!?with_odbc:out}-odbc \
297         --with%{!?with_pgsql:out}-postgres \
298         --with%{!?with_sqlite:out}-sqlite \
299         --with%{!?with_freetds:out}-tds \
300         --with%{!?with_xbase:out}-xbase \
301         %{?with_sybase:--with-sybase=/usr} \
302         --without-oracle
303 %{__make} -j1
304
305 %install
306 rm -rf $RPM_BUILD_ROOT
307
308 %{__make} install \
309         DESTDIR=$RPM_BUILD_ROOT \
310         HTML_DIR=%{_gtkdocdir}
311
312 # modules dlopened by *.so through libgmodule
313 %if %{with static_libs}
314 %{__rm} $RPM_BUILD_ROOT%{_providersdir}/*.a
315 %endif
316 %{__rm} $RPM_BUILD_ROOT{%{_providersdir},%{_libdir}}/*.la
317
318 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{sr@Latn,sr@latin}
319
320 %find_lang libgda-3.0
321
322 %clean
323 rm -rf $RPM_BUILD_ROOT
324
325 %post   -p /sbin/ldconfig
326 %postun -p /sbin/ldconfig
327
328 %files -f libgda-3.0.lang
329 %defattr(644,root,root,755)
330 %doc AUTHORS ChangeLog NEWS README
331 %attr(755,root,root) %{_bindir}/gda-config-tool-3.0
332 %attr(755,root,root) %{_bindir}/gda-list-server-op-3.0
333 %attr(755,root,root) %{_libdir}/libgda-3.0.so.*.*.*
334 %attr(755,root,root) %ghost %{_libdir}/libgda-3.0.so.3
335 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so.*.*.*
336 %attr(755,root,root) %ghost %{_libdir}/libgda-report-3.0.so.3
337 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so.*.*.*
338 %attr(755,root,root) %ghost %{_libdir}/libgda-xslt-3.0.so.0
339 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so.*.*.*
340 %attr(755,root,root) %ghost %{_libdir}/libgdasql-3.0.so.3
341 %dir %{_libdir}/%{_libgdadir}
342 %dir %{_providersdir}
343 %{_datadir}/libgda-3.0
344 %dir %{_sysconfdir}/libgda-3.0
345 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libgda-3.0/config
346 %{_mandir}/man1/gda-config-tool-3.0.1*
347 %{_mandir}/man5/gda-config-3.0.5*
348
349 %files devel
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_bindir}/gda-author-dict-file-3.0
352 %attr(755,root,root) %{_bindir}/gda-bdb-test
353 %attr(755,root,root) %{_bindir}/gda-diagnose-3.0
354 %attr(755,root,root) %{_bindir}/gda-inspect-dict-file-3.0
355 %attr(755,root,root) %{_bindir}/gda-list-config-3.0
356 %attr(755,root,root) %{_bindir}/gda-sql-3.0
357 %attr(755,root,root) %{_bindir}/gda-test-connection-3.0
358 %attr(755,root,root) %{_libdir}/libgda-3.0.so
359 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so
360 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so
361 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so
362 %{_includedir}/libgda-3.0
363 %{_pkgconfigdir}/libgda-3.0.pc
364 %{_pkgconfigdir}/libgda-*-3.0.pc
365 %{_sysconfdir}/libgda-3.0/sales_test.db
366 %{?with_doc:%{_gtkdocdir}/libgda-3.0}
367
368 %if %{with static_libs}
369 %files static
370 %defattr(644,root,root,755)
371 %{_libdir}/libgda-3.0.a
372 %{_libdir}/libgda-report-3.0.a
373 %{_libdir}/libgda-xslt-3.0.a
374 %{_libdir}/libgdasql-3.0.a
375 %endif
376
377 %files provider-db
378 %defattr(644,root,root,755)
379 %attr(755,root,root) %{_providersdir}/libgda-bdb.so
380
381 %if %{with firebird}
382 %files provider-firebird
383 %defattr(644,root,root,755)
384 %attr(755,root,root) %{_providersdir}/libgda-firebird.so
385 %endif
386
387 %if %{with freetds}
388 %files provider-freetds
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_providersdir}/libgda-freetds.so
391 %endif
392
393 %if %{with ldap}
394 %files provider-ldap
395 %defattr(644,root,root,755)
396 %attr(755,root,root) %{_providersdir}/libgda-ldap.so
397 %endif
398
399 %if %{with mdb}
400 %files provider-mdb
401 %defattr(644,root,root,755)
402 %attr(755,root,root) %{_providersdir}/libgda-mdb.so
403 %endif
404
405 %if %{with mysql}
406 %files provider-mysql
407 %defattr(644,root,root,755)
408 %attr(755,root,root) %{_providersdir}/libgda-mysql.so
409 %endif
410
411 %if %{with odbc}
412 %files provider-odbc
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_providersdir}/libgda-odbc.so
415 %endif
416
417 %if %{with pgsql}
418 %files provider-postgres
419 %defattr(644,root,root,755)
420 %attr(755,root,root) %{_providersdir}/libgda-postgres.so
421 %endif
422
423 %if %{with sqlite}
424 %files provider-sqlite
425 %defattr(644,root,root,755)
426 %attr(755,root,root) %{_providersdir}/libgda-sqlite.so
427 %endif
428
429 %if %{with sybase}
430 %files provider-sybase
431 %defattr(644,root,root,755)
432 %attr(755,root,root) %{_providersdir}/libgda-sybase.so
433 %endif
434
435 %if %{with xbase}
436 %files provider-xbase
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_providersdir}/libgda-xbase.so
439 %endif
This page took 0.080907 seconds and 2 git commands to generate.