]> git.pld-linux.org Git - packages/libgda3.git/blob - libgda3.spec
- release 2
[packages/libgda3.git] / libgda3.spec
1 #
2 # TODO: package dotnet-gda-sharp
3 #
4 # Conditional build:
5 %bcond_without  doc             # don't generate html documentation
6 %bcond_without  static_libs     # don't build static libraries
7 %bcond_with     gamin           # use gamin instead of fam library
8 #
9 %bcond_without  firebird        # build without firebird plugin
10 %bcond_without  freetds         # build without freetds plugin
11 %bcond_without  ldap            # build without ldap plugin
12 %bcond_without  mdb             # build without MDB plugin
13 %bcond_without  mysql           # build without MySQL plugin
14 %bcond_without  odbc            # build without unixODBC
15 %bcond_without  pgsql           # build without PostgreSQL plugin
16 %bcond_without  sqlite          # build without sqlite plugin
17 %bcond_without  xbase           # build without xbase plugin
18 #
19 %ifnarch %{ix86} sparc sparcv9 alpha
20 %undefine       with_firebird
21 %endif
22 Summary:        GNU Data Access library
23 Summary(pl.UTF-8):   Biblioteka GNU Data Access
24 Name:           libgda3
25 Version:        3.0.1
26 Release:        2
27 License:        LGPL v2/GPL v2
28 Group:          Applications/Databases
29 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgda/3.0/libgda-%{version}.tar.bz2
30 # Source0-md5:  1aaf23c27ba94d0b231f2b123350110a
31 Patch0:         %{name}-mdb.patch
32 Patch1:         %{name}-configure.patch
33 Patch2:         %{name}-firebird.patch
34 %{?with_firebird:BuildRequires: Firebird-devel}
35 BuildRequires:  autoconf >= 2.59
36 BuildRequires:  automake >= 1:1.8
37 BuildRequires:  bison
38 BuildRequires:  db-devel
39 %{!?with_gamin:BuildRequires:   fam-devel}
40 BuildRequires:  flex
41 %{?with_freetds:BuildRequires:  freetds-devel >= 0.64}
42 %{?with_gamin:BuildRequires:    gamin-devel}
43 BuildRequires:  glib2-devel >= 1:2.12.0
44 BuildRequires:  gnome-common >= 2.12.0
45 BuildRequires:  gtk-doc >= 1.6
46 BuildRequires:  intltool >= 0.35
47 BuildRequires:  libtool
48 BuildRequires:  libxml2-devel >= 1:.2.6.26
49 BuildRequires:  libxslt-devel >= 1.1.17
50 %{?with_mdb:BuildRequires:      mdbtools-devel}
51 %{?with_mysql:BuildRequires:    mysql-devel}
52 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
53 BuildRequires:  perl-base
54 BuildRequires:  popt-devel
55 %{?with_pgsql:BuildRequires:    postgresql-devel}
56 BuildRequires:  readline-devel >= 5.0
57 BuildRequires:  rpmbuild(macros) >= 1.213
58 #%{?with_sqlite:BuildRequires:  sqlite3-devel >= 3.3.100}
59 %{?with_odbc:BuildRequires:     unixODBC-devel}
60 %{?with_xbase:BuildRequires:    xbase-devel >= 2.0.0}
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         _libgdadir      libgda-%(echo %{version} | cut -d '.' -f 1-2 )
64 %define         _providersdir   %{_libdir}/%{_libgdadir}/providers
65
66 %description
67 GNU Data Access is an attempt to provide uniform access to different
68 kinds of data sources (databases, information servers, mail spools,
69 etc). It is a complete architecture that provides all you need to
70 access your data.
71
72 libgda was part of the GNOME-DB project but has been separated from it
73 to allow non-GNOME applications to be developed based on it.
74
75 %description -l pl.UTF-8
76 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
77 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
78 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
79 potrzebujesz do dostępu do danych.
80
81 libgda była częścią projektu GNOME-DB, ale została wydzielona, aby
82 pozwolić na używanie przez niegnomowe aplikacje.
83
84 %package devel
85 Summary:        GNU Data Access development
86 Summary(pl.UTF-8):   Dla programistów GNU Data Access
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}-%{release}
89 %{!?with_gamin:Requires:        fam-devel}
90 %{?with_gamin:Requires: gamin-devel}
91 Requires:       glib2-devel >= 1:2.12.0
92 Requires:       gtk-doc-common
93 Requires:       libxml2-devel >= 1:2.6.26
94 Requires:       libxslt-devel >= 1.1.17
95 Obsoletes:      libgda0-devel
96
97 %description devel
98 GNU Data Access is an attempt to provide uniform access to different
99 kinds of data sources (databases, information servers, mail spools,
100 etc). It is a complete architecture that provides all you need to
101 access your data. This subpackage contains development files.
102
103 %description devel -l pl.UTF-8
104 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
105 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
106 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
107 potrzebujesz do dostępu do danych. Ten podpakiet zawiera pliki dla
108 programistów używających libgda.
109
110 %package static
111 Summary:        GNU Data Access static libraries
112 Summary(pl.UTF-8):   Statyczne biblioteki GNU Data Access
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115
116 %description static
117 GNU Data Access static libraries.
118
119 %description static -l pl.UTF-8
120 Statyczne biblioteki GNU Data Access.
121
122 %package provider-db
123 Summary:        GDA Berkeley DB provider
124 Summary(pl.UTF-8):   Źródło danych Berkeley DB dla GDA
125 Group:          Applications/Databases
126 Requires:       %{name} = %{version}-%{release}
127
128 %description provider-db
129 This package contains the GDA Berkeley DB provider.
130
131 %description provider-db -l pl.UTF-8
132 Pakiet dostaczający dane z Berkeley DB dla GDA.
133
134 %package provider-firebird
135 Summary:        GDA Firebird provider
136 Summary(pl.UTF-8):   Źródło danych Firebird dla GDA
137 Group:          Applications/Databases
138 Requires:       %{name} = %{version}-%{release}
139
140 %description provider-firebird
141 This package contains the GDA Firebird provider.
142
143 %description provider-firebird -l pl.UTF-8
144 Pakiet dostarczający dane z Firebird dla GDA.
145
146 %package provider-freetds
147 Summary:        GDA FreeTDS provider
148 Summary(pl.UTF-8):   Źródło danych FreeTDS dla GDA
149 Group:          Applications/Databases
150 Requires:       %{name} = %{version}-%{release}
151
152 %description provider-freetds
153 This package contains the GDA FreeTDS provider.
154
155 %description provider-freetds -l pl.UTF-8
156 Pakiet dostarczający dane z FreeTDS dla GDA.
157
158 %package provider-ldap
159 Summary:        GDA LDAP provider
160 Summary(pl.UTF-8):   Źródło danych LDAP dla GDA
161 Group:          Applications/Databases
162 Requires:       %{name} = %{version}-%{release}
163
164 %description provider-ldap
165 This package contains the GDA LDAP provider.
166
167 %description provider-ldap -l pl.UTF-8
168 Pakiet dostarczający dane z LDAP dla GDA
169
170 %package provider-mdb
171 Summary:        GDA MDB provider
172 Summary(pl.UTF-8):   Źródło danych MDB
173 Group:          Applications/Databases
174 Requires:       %{name} = %{version}-%{release}
175
176 %description provider-mdb
177 This package contains the GDA MDB provider.
178
179 %description provider-mdb -l pl.UTF-8
180 Pakiet dostarczający dane z MDB dla GDA.
181
182 %package provider-mysql
183 Summary:        GDA MySQL provider
184 Summary(pl.UTF-8):   Źródło danych MySQL dla GDA
185 Group:          Applications/Databases
186 Requires:       %{name} = %{version}-%{release}
187 Obsoletes:      libgda-mysql0
188
189 %description provider-mysql
190 This package contains the GDA MySQL provider.
191
192 %description provider-mysql -l pl.UTF-8
193 Pakiet dostarczający dane z MySQL dla GDA.
194
195 %package provider-odbc
196 Summary:        GDA ODBC provider
197 Summary(pl.UTF-8):   Źródło danych ODBC dla GDA
198 Group:          Applications/Databases
199 Requires:       %{name} = %{version}-%{release}
200
201 %description provider-odbc
202 This package contains the GDA ODBC provider.
203
204 %description provider-odbc -l pl.UTF-8
205 Pakiet dostarczający dane z ODBC dla GDA.
206
207 %package provider-postgres
208 Summary:        GDA PostgreSQL provider
209 Summary(pl.UTF-8):   Źródło danych PostgreSQL dla GDA
210 Group:          Applications/Databases
211 Requires:       %{name} = %{version}-%{release}
212 Obsoletes:      libgda-postgres0
213
214 %description provider-postgres
215 This package contains the GDA PostgreSQL provider.
216
217 %description provider-postgres -l pl.UTF-8
218 Pakiet dostarczający dane z PostgreSQL dla GDA.
219
220 %package provider-sqlite
221 Summary:        GDA SQLite provider
222 Summary(pl.UTF-8):   Źródło danych SQLite dla GDA
223 Group:          Applications/Databases
224 Requires:       %{name} = %{version}-%{release}
225
226 %description provider-sqlite
227 This package contains the GDA SQLite provider.
228
229 %description provider-sqlite -l pl.UTF-8
230 Pakiet dostarczający dane z SQLite dla GDA.
231
232 %package provider-xbase
233 Summary:        GDA xBase provider
234 Summary(pl.UTF-8):   Źródło danych xBase dla GDA
235 Group:          Applications/Databases
236 Requires:       %{name} = %{version}-%{release}
237
238 %description provider-xbase
239 This package contains the GDA xBase (dBase, Clipper, FoxPro) provider.
240
241 %description provider-xbase -l pl.UTF-8
242 Pakiet dostarczający dane z xBase (dBase, Clippera, FoxPro) dla GDA.
243
244 %prep
245 %setup -q -n libgda-%{version}
246 %patch0 -p1
247 %patch1 -p1
248 %patch2 -p1
249
250 %if ! %{with gamin}
251 sed -i -e 's#\(PKG_CHECK_MODULES(GAMIN.*\)#dnl \1#g' configure.in
252 %endif
253
254 %build
255 CXXFLAGS="%{rpmcxxflags} -fno-rtti -fno-exceptions"
256 %{__intltoolize}
257 %{__libtoolize}
258 %{__aclocal}
259 %{__autoconf}
260 %{__automake}
261 %configure \
262         %{?with_doc:--enable-gtk-doc} \
263         %{!?with_static_libs:--enable-static=no} \
264         --with-html-dir=%{_gtkdocdir} \
265         --with%{!?with_firebird:out}-firebird \
266         --with%{!?with_ldap:out}-ldap \
267         --with%{!?with_mdb:out}-mdb \
268         --with%{!?with_mysql:out}-mysql \
269         --with%{!?with_odbc:out}-odbc \
270         --with%{!?with_pgsql:out}-postgres \
271         --with%{!?with_sqlite:out}-sqlite \
272         --with%{!?with_freetds:out}-tds \
273         --with%{!?with_xbase:out}-xbase \
274         --without-oracle
275 %{__make} -j1
276
277 %install
278 rm -rf $RPM_BUILD_ROOT
279
280 %{__make} install \
281         DESTDIR=$RPM_BUILD_ROOT \
282         HTML_DIR=%{_gtkdocdir}
283
284 # modules dlopened by *.so through libgmodule
285 rm -f $RPM_BUILD_ROOT%{_providersdir}/*.{a,la}
286
287 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
288
289 %find_lang libgda-3.0
290
291 %clean
292 rm -rf $RPM_BUILD_ROOT
293
294 %post   -p /sbin/ldconfig
295 %postun -p /sbin/ldconfig
296
297 %files -f libgda-3.0.lang
298 %defattr(644,root,root,755)
299 %doc AUTHORS ChangeLog NEWS README
300 %attr(755,root,root) %{_bindir}/gda-config-tool-3.0
301 %attr(755,root,root) %{_libdir}/libgda-3.0.so.*.*.*
302 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so.*.*.*
303 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so.*.*.*
304 %dir %{_libdir}/%{_libgdadir}
305 %dir %{_providersdir}
306 %{_datadir}/libgda-3.0
307 %dir %{_sysconfdir}/libgda-3.0
308 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libgda-3.0/config
309 %{_mandir}/man1/gda-config-tool-3.0.1*
310 %{_mandir}/man5/gda-config-3.0.5*
311
312 %files devel
313 %defattr(644,root,root,755)
314 %attr(755,root,root) %{_bindir}/gda-author-dict-file-3.0
315 %attr(755,root,root) %{_bindir}/gda-diagnose-3.0
316 %attr(755,root,root) %{_bindir}/gda-inspect-dict-file-3.0
317 %attr(755,root,root) %{_bindir}/gda-list-config-3.0
318 %attr(755,root,root) %{_bindir}/gda-report-test-3.0
319 %attr(755,root,root) %{_bindir}/gda-run-3.0
320 %attr(755,root,root) %{_bindir}/gda-test-connection-3.0
321 %attr(755,root,root) %{_libdir}/libgda-3.0.so
322 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so
323 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so
324 %{_libdir}/libgda-3.0.la
325 %{_libdir}/libgda-report-3.0.la
326 %{_libdir}/libgdasql-3.0.la
327 %{_includedir}/libgda-3.0
328 %{_pkgconfigdir}/libgda-3.0.pc
329 %{_pkgconfigdir}/libgda-*-3.0.pc
330 %{?with_doc:%{_gtkdocdir}/libgda-3.0}
331
332 %if %{with static_libs}
333 %files static
334 %defattr(644,root,root,755)
335 %{_libdir}/libgda-3.0.a
336 %{_libdir}/libgda-report-3.0.a
337 %{_libdir}/libgdasql-3.0.a
338 %endif
339
340 %files provider-db
341 %defattr(644,root,root,755)
342 %attr(755,root,root) %{_providersdir}/libgda-bdb.so
343
344 %if %{with firebird}
345 %files provider-firebird
346 %defattr(644,root,root,755)
347 %attr(755,root,root) %{_providersdir}/libgda-firebird.so
348 %endif
349
350 %if %{with freetds}
351 %files provider-freetds
352 %defattr(644,root,root,755)
353 %attr(755,root,root) %{_providersdir}/libgda-freetds.so
354 %endif
355
356 %if %{with ldap}
357 %files provider-ldap
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_providersdir}/libgda-ldap.so
360 %endif
361
362 %if %{with mdb}
363 %files provider-mdb
364 %defattr(644,root,root,755)
365 %attr(755,root,root) %{_providersdir}/libgda-mdb.so
366 %endif
367
368 %if %{with mysql}
369 %files provider-mysql
370 %defattr(644,root,root,755)
371 %attr(755,root,root) %{_providersdir}/libgda-mysql.so
372 %endif
373
374 %if %{with odbc}
375 %files provider-odbc
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_providersdir}/libgda-odbc.so
378 %endif
379
380 %if %{with pgsql}
381 %files provider-postgres
382 %defattr(644,root,root,755)
383 %attr(755,root,root) %{_providersdir}/libgda-postgres.so
384 %endif
385
386 %if %{with sqlite}
387 %files provider-sqlite
388 %defattr(644,root,root,755)
389 %attr(755,root,root) %{_providersdir}/libgda-sqlite.so
390 %endif
391
392 %if %{with xbase}
393 %files provider-xbase
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_providersdir}/libgda-xbase.so
396 %endif
This page took 0.312749 seconds and 3 git commands to generate.