]> git.pld-linux.org Git - packages/libgda.git/blob - libgda.spec
- rel.2.1
[packages/libgda.git] / libgda.spec
1 #
2 # Conditional build:
3 %bcond_with     firebird        # build without firebird plugin
4 %bcond_without  freetds         # build without freetds plugin
5 %bcond_without  ldap            # build without ldap plugin
6 %bcond_without  mdb             # build without MDB plugin
7 %bcond_without  mysql           # build without MySQL plugin
8 %bcond_without  odbc            # build without unixODBC
9 %bcond_without  pgsql           # build without PostgreSQL plugin
10 %bcond_without  sqlite          # build without sqlite plugin
11 %bcond_without  xbase           # build without xbase plugin
12
13 %ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
14 %undefine       with_firebird
15 %endif
16 Summary:        GNU Data Access library
17 Summary(pl):    Biblioteka GNU Data Access
18 Name:           libgda
19 Version:        1.2.3
20 Release:        2.1
21 Epoch:          1
22 License:        LGPL v2/GPL v2
23 Group:          Applications/Databases
24 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgda/1.2/%{name}-%{version}.tar.bz2
25 # Source0-md5:  eb9c31c3102d542de728f5f55674d511
26 Patch0:         %{name}-gcc34.patch
27 Patch1:         %{name}-mdb.patch
28 Patch2:         %{name}-freetds063.patch
29 Patch3:         %{name}-sqlite.patch
30 Patch4:         %{name}-configure.patch
31 %{?with_firebird:BuildRequires: Firebird-devel}
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake >= 1:1.8
34 BuildRequires:  bison
35 BuildRequires:  db-devel
36 BuildRequires:  flex
37 %{?with_freetds:BuildRequires:  freetds-devel >= 0.63}
38 BuildRequires:  glib2-devel >= 2.2.0
39 BuildRequires:  gnome-common >= 2.8.0
40 BuildRequires:  gtk-doc >= 1.0
41 BuildRequires:  intltool >= 0.30
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel
44 BuildRequires:  libxslt-devel >= 1.0.9
45 %{?with_mdb:BuildRequires:      mdbtools-devel}
46 %{?with_mysql:BuildRequires:    mysql-devel}
47 %{?with_ldap:BuildRequires:     openldap-devel}
48 BuildRequires:  perl-base
49 BuildRequires:  popt-devel
50 %{?with_pgsql:BuildRequires:    postgresql-devel}
51 BuildRequires:  readline-devel >= 5.0
52 BuildRequires:  rpmbuild(macros) >= 1.213
53 BuildRequires:  scrollkeeper
54 %{?with_sqlite:BuildRequires:   sqlite3-devel}
55 %{?with_odbc:BuildRequires:     unixODBC-devel}
56 %{?with_xbase:BuildRequires:    xbase-devel >= 2.0.0}
57 Requires(post,postun):  scrollkeeper
58 Requires:       scrollkeeper
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 GNU Data Access is an attempt to provide uniform access to different
63 kinds of data sources (databases, information servers, mail spools,
64 etc). It is a complete architecture that provides all you need to
65 access your data.
66
67 libgda was part of the GNOME-DB project but has been separated from it
68 to allow non-GNOME applications to be developed based on it.
69
70 %description -l pl
71 GNU Data Access to próba zapewnienia jednolitego dostêpu do ró¿nych
72 ¼róde³ danych (bazy danych, serwery informacji, katalogi z poczt±
73 itp.). Jest kompletn± architektur± dostarczaj±c± wszystko, czego
74 potrzebujesz do dostêpu do danych.
75
76 libgda by³a czê¶ci± projektu GNOME-DB, ale zosta³a wydzielona, aby
77 pozwoliæ na u¿ywanie przez niegnomowe aplikacje.
78
79 %package devel
80 Summary:        GNU Data Access development
81 Summary(pl):    Dla programistów GNU Data Access
82 Group:          Development/Libraries
83 Requires:       %{name} = %{epoch}:%{version}-%{release}
84 Requires:       glib2-devel >= 2.2.0
85 Requires:       gtk-doc-common
86 Requires:       libxml2-devel
87 Requires:       libxslt-devel >= 1.0.9
88 Obsoletes:      libgda0-devel
89
90 %description devel
91 GNU Data Access is an attempt to provide uniform access to different
92 kinds of data sources (databases, information servers, mail spools,
93 etc). It is a complete architecture that provides all you need to
94 access your data. This subpackage contains development files.
95
96 %description devel -l pl
97 GNU Data Access to próba zapewnienia jednolitego dostêpu do ró¿nych
98 ¼róde³ danych (bazy danych, serwery informacji, katalogi z poczt±
99 itp.). Jest kompletn± architektur± dostarczaj±c± wszystko, czego
100 potrzebujesz do dostêpu do danych. Ten podpakiet zawiera pliki dla
101 programistów u¿ywaj±cych libgda.
102
103 %package static
104 Summary:        GNU Data Access static libraries
105 Summary(pl):    Statyczne biblioteki GNU Data Access
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108
109 %description static
110 GNU Data Access static libraries.
111
112 %description static -l pl
113 Statyczne biblioteki GNU Data Access.
114
115 %package -n gda-db
116 Summary:        GDA Berkeley DB provider
117 Summary(pl):    ¬ród³o danych Berkeley DB dla GDA
118 Group:          Applications/Databases
119 Requires:       %{name} = %{epoch}:%{version}-%{release}
120
121 %description -n gda-db
122 This package contains the GDA Berkeley DB provider.
123
124 %description -n gda-db -l pl
125 Pakiet dostaczaj±cy dane z Berkeley DB dla GDA.
126
127 %package -n gda-firebird
128 Summary:        GDA Firebird provider
129 Summary(pl):    ¬ród³o danych Firebird dla GDA
130 Group:          Applications/Databases
131 Requires:       %{name} = %{epoch}:%{version}-%{release}
132
133 %description -n gda-firebird
134 This package contains the GDA Firebird provider.
135
136 %description -n gda-firebird -l pl
137 Pakiet dostarczaj±cy dane z Firebird dla GDA.
138
139 %package -n gda-freetds
140 Summary:        GDA FreeTDS provider
141 Summary(pl):    ¬ród³o danych FreeTDS dla GDA
142 Group:          Applications/Databases
143 Requires:       %{name} = %{epoch}:%{version}-%{release}
144
145 %description -n gda-freetds
146 This package contains the GDA FreeTDS provider.
147
148 %description -n gda-freetds -l pl
149 Pakiet dostarczaj±cy dane z FreeTDS dla GDA.
150
151 %package -n gda-ldap
152 Summary:        GDA LDAP provider
153 Summary(pl):    ¬ród³o danych LDAP dla GDA
154 Group:          Applications/Databases
155 Requires:       %{name} = %{epoch}:%{version}-%{release}
156
157 %description -n gda-ldap
158 This package contains the GDA LDAP provider.
159
160 %description -n gda-ldap -l pl
161 Pakiet dostarczaj±cy dane z LDAP dla GDA
162
163 %package -n gda-mdb
164 Summary:        GDA MDB provider
165 Summary(pl):    ¬ród³o danych MDB
166 Group:          Applications/Databases
167 Requires:       %{name} = %{epoch}:%{version}-%{release}
168
169 %description -n gda-mdb
170 This package contains the GDA MDB provider.
171
172 %description -n gda-mdb -l pl
173 Pakiet dostarczaj±cy dane z MDB dla GDA.
174
175 %package -n gda-mysql
176 Summary:        GDA MySQL provider
177 Summary(pl):    ¬ród³o danych MySQL dla GDA
178 Group:          Applications/Databases
179 Requires:       %{name} = %{epoch}:%{version}-%{release}
180 Obsoletes:      libgda-mysql0
181
182 %description -n gda-mysql
183 This package contains the GDA MySQL provider.
184
185 %description -n gda-mysql -l pl
186 Pakiet dostarczaj±cy dane z MySQL dla GDA.
187
188 %package -n gda-odbc
189 Summary:        GDA ODBC provider
190 Summary(pl):    ¬ród³o danych ODBC dla GDA
191 Group:          Applications/Databases
192 Requires:       %{name} = %{epoch}:%{version}-%{release}
193
194 %description -n gda-odbc
195 This package contains the GDA ODBC provider.
196
197 %description -n gda-odbc -l pl
198 Pakiet dostarczaj±cy dane z ODBC dla GDA.
199
200 %package -n gda-postgres
201 Summary:        GDA PostgreSQL provider
202 Summary(pl):    ¬ród³o danych PostgreSQL dla GDA
203 Group:          Applications/Databases
204 Requires:       %{name} = %{epoch}:%{version}-%{release}
205 Obsoletes:      libgda-postgres0
206
207 %description -n gda-postgres
208 This package contains the GDA PostgreSQL provider.
209
210 %description -n gda-postgres -l pl
211 Pakiet dostarczaj±cy dane z PostgreSQL dla GDA.
212
213 %package -n gda-sqlite
214 Summary:        GDA SQLite provider
215 Summary(pl):    ¬ród³o danych SQLite dla GDA
216 Group:          Applications/Databases
217 Requires:       %{name} = %{epoch}:%{version}-%{release}
218
219 %description -n gda-sqlite
220 This package contains the GDA SQLite provider.
221
222 %description -n gda-sqlite -l pl
223 Pakiet dostarczaj±cy dane z SQLite dla GDA.
224
225 %package -n gda-xbase
226 Summary:        GDA xBase provider
227 Summary(pl):    ¬ród³o danych xBase dla GDA
228 Group:          Applications/Databases
229 Requires:       %{name} = %{epoch}:%{version}-%{release}
230
231 %description -n gda-xbase
232 This package contains the GDA xBase (dBase, Clipper, FoxPro) provider.
233
234 %description -n gda-xbase -l pl
235 Pakiet dostarczaj±cy dane z xBase (dBase, Clippera, FoxPro) dla GDA.
236
237 %prep
238 %setup -q
239 %patch0 -p1
240 %patch1 -p1
241 %patch2 -p1
242 %patch3 -p1
243 %patch4 -p1
244
245 %build
246 CXXFLAGS="%{rpmcxxflags} -fno-rtti -fno-exceptions"
247 %{__intltoolize}
248 %{__libtoolize}
249 %{__aclocal}
250 %{__autoconf}
251 %{__automake}
252 %configure \
253         --enable-gtk-doc \
254         --with-html-dir=%{_gtkdocdir} \
255         --with%{!?with_firebird:out}-firebird \
256         --with%{!?with_ldap:out}-ldap \
257         --with%{!?with_mdb:out}-mdb \
258         --with%{!?with_mysql:out}-mysql \
259         --with%{!?with_odbc:out}-odbc \
260         --with%{!?with_pgsql:out}-postgres \
261         --with%{!?with_sqlite:out}-sqlite \
262         --with%{!?with_freetds:out}-tds \
263         --with%{!?with_xbase:out}-xbase \
264         --without-oracle
265 %{__make} -j1
266
267 %install
268 rm -rf $RPM_BUILD_ROOT
269
270 %{__make} install \
271         DESTDIR=$RPM_BUILD_ROOT \
272         HTML_DIR=%{_gtkdocdir} 
273
274 # modules dlopened by *.so through libgmodule
275 rm -f $RPM_BUILD_ROOT%{_libdir}/libgda/providers/*.{a,la}
276
277 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
278
279 %find_lang %{name} --with-gnome --all-name
280
281 %clean
282 rm -rf $RPM_BUILD_ROOT
283
284 %post
285 /sbin/ldconfig
286 %scrollkeeper_update_post
287
288 %postun
289 /sbin/ldconfig
290 %scrollkeeper_update_postun
291
292 %files -f %{name}.lang
293 %defattr(644,root,root,755)
294 %doc AUTHORS ChangeLog NEWS README
295 %attr(755,root,root) %{_bindir}/gda-config-tool
296 %attr(755,root,root) %{_libdir}/libgda-2.so.*.*
297 %attr(755,root,root) %{_libdir}/libgda-report-2.so.*.*
298 %attr(755,root,root) %{_libdir}/libgdasql.so.*.*
299 %dir %{_libdir}/libgda
300 %dir %{_libdir}/libgda/providers
301 %attr(755,root,root) %{_libdir}/libgda/providers/libgda-xml.so
302 %{_datadir}/libgda
303 %{_omf_dest_dir}/%{name}
304 %dir %{_sysconfdir}/libgda
305 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/libgda/config
306 %{_mandir}/man1/gda-config-tool.1*
307 %{_mandir}/man5/*
308
309 %files devel
310 %defattr(644,root,root,755)
311 %attr(755,root,root) %{_bindir}/gda-report-test
312 %attr(755,root,root) %{_bindir}/gda-run
313 %attr(755,root,root) %{_bindir}/gda-test
314 %attr(755,root,root) %{_libdir}/libgda-2.so
315 %attr(755,root,root) %{_libdir}/libgda-report-2.so
316 %attr(755,root,root) %{_libdir}/libgdasql.so
317 %{_libdir}/libgda-2.la
318 %{_libdir}/libgda-report-2.la
319 %{_libdir}/libgdasql.la
320 %{_includedir}/libgda-1.2
321 %{_pkgconfigdir}/*
322 %{_gtkdocdir}/*
323
324 %files static
325 %defattr(644,root,root,755)
326 %{_libdir}/lib*.a
327
328 %files -n gda-db
329 %defattr(644,root,root,755)
330 %attr(755,root,root) %{_libdir}/libgda/providers/libgda-bdb.so
331
332 %if %{with firebird}
333 %files -n gda-firebird
334 %defattr(644,root,root,755)
335 %attr(755,root,root) %{_libdir}/libgda/providers/libgda-firebird.so
336 %endif
337
338 %if %{with freetds}
339 %files -n gda-freetds
340 %defattr(644,root,root,755)
341 %attr(755,root,root) %{_libdir}/libgda/providers/libgda-freetds.so
342 %endif
343
344 %if %{with ldap}
345 %files -n gda-ldap
346 %defattr(644,root,root,755)
347 %attr(755,root,root) %{_libdir}/libgda/providers/libgda-ldap.so
348 %endif
349
350 %if %{with mdb}
351 %files -n gda-mdb
352 %defattr(644,root,root,755)
353 %attr(755,root,root) %{_libdir}/libgda/providers/libgda-mdb.so
354 %endif
355
356 %if %{with mysql}
357 %files -n gda-mysql
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_libdir}/libgda/providers/libgda-mysql.so
360 %endif
361
362 %if %{with odbc}
363 %files -n gda-odbc
364 %defattr(644,root,root,755)
365 %attr(755,root,root) %{_libdir}/libgda/providers/libgda-odbc.so
366 %endif
367
368 %if %{with pgsql}
369 %files -n gda-postgres
370 %defattr(644,root,root,755)
371 %attr(755,root,root) %{_libdir}/libgda/providers/libgda-postgres.so
372 %endif
373
374 %if %{with sqlite}
375 %files -n gda-sqlite
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_libdir}/libgda/providers/libgda-sqlite.so
378 %endif
379
380 %if %{with xbase}
381 %files -n gda-xbase
382 %defattr(644,root,root,755)
383 %attr(755,root,root) %{_libdir}/libgda/providers/libgda-xbase.so
384 %endif
This page took 0.068378 seconds and 3 git commands to generate.