]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- updated to 2.9.9
[packages/libfuse.git] / libfuse.spec
1 Summary:        Filesystem in Userspace
2 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika
3 Name:           libfuse
4 Version:        2.9.9
5 Release:        1
6 License:        LGPL v2 (library), GPL v2 (tools)
7 Group:          Applications/System
8 #Source0Download: https://github.com/libfuse/libfuse/releases
9 Source0:        https://github.com/libfuse/libfuse/releases/download/fuse-%{version}/fuse-%{version}.tar.gz
10 # Source0-md5:  8000410aadc9231fd48495f7642f3312
11 Patch0:         kernel-misc-fuse-Makefile.am.patch
12 URL:            https://github.com/libfuse/libfuse
13 BuildRequires:  autoconf >= 2.60
14 BuildRequires:  automake
15 BuildRequires:  libtool
16 BuildRequires:  sed >= 4.0
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 FUSE (Filesystem in Userspace) is a simple interface for userspace
21 programs to export a virtual filesystem to the Linux kernel. FUSE also
22 aims to provide a secure method for non privileged users to create and
23 mount their own filesystem implementations.
24
25 This package contains a shared library.
26
27 %description -l pl.UTF-8
28 FUSE stanowi prosty interfejs dla programów działających w przestrzeni
29 użytkownika eksportujący wirtualny system plików do jądra Linuksa.
30 FUSE ma również na celu udostępnienie bezpiecznej metody tworzenia i
31 montowania własnych implementacji systemów plików przez zwykłych
32 (nieuprzywilejowanych) użytkowników.
33
34 Ten pakiet zawiera bibliotekę współdzieloną.
35
36 %package devel
37 Summary:        Filesystem in Userspace - development header files
38 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - pliki nagłówkowe
39 License:        LGPL v2
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 FUSE libraries header files.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe bibliotek FUSE.
48
49 %package static
50 Summary:        Filesystem in Userspace - static libraries
51 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - biblioteki statyczne
52 License:        LGPL v2
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static FUSE libraries.
58
59 %description static -l pl.UTF-8
60 Statyczne biblioteki FUSE.
61
62 %package apidocs
63 Summary:        API documentation for FUSE library
64 Summary(pl.UTF-8):      Dokumentacja API bibliotek FUSE
65 Group:          Documentation
66
67 %description apidocs
68 API documentation for FUSE library.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API bibliotek FUSE.
72
73 %package tools
74 Summary:        Tools to mount FUSE based filesystems
75 Summary(pl.UTF-8):      Narzędzia do montowania systemów plików opartych na FUSE
76 License:        GPL v2
77 Group:          Applications/System
78 Requires(pre):  /usr/bin/getgid
79 Requires(pre):  /usr/sbin/groupadd
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       libfuse-common >= %{version}
82 Requires:       mount >= 2.18
83 Provides:       group(fuse)
84 Obsoletes:      fusermount
85
86 %description tools
87 Tools to mount FUSE based filesystems.
88
89 %description tools -l pl.UTF-8
90 Narzędzia do montowania systemów plików opartych na FUSE.
91
92 %prep
93 %setup -q -n fuse-%{version}
94 %patch0 -p1
95
96 sed -i '/FUSERMOUNT_PROG/s,fusermount,%{_bindir}/fusermount,' lib/mount.c
97
98 # gold is missing base versioning
99 install -d ld-dir
100 [ ! -x /usr/bin/ld.bfd ] || ln -sf /usr/bin/ld.bfd ld-dir/ld
101
102 %build
103 PATH=$(pwd)/ld-dir:$PATH
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         INIT_D_PATH=/etc/rc.d/init.d \
111         --disable-silent-rules \
112         --enable-lib \
113         --enable-util
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT{/%{_lib},%{_pkgconfigdir},%{_sysconfdir}}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %{__mv} $RPM_BUILD_ROOT%{_libdir}/libfuse.so.* $RPM_BUILD_ROOT/%{_lib}
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfuse.so
126 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libfuse.so.*.*) \
127         $RPM_BUILD_ROOT%{_libdir}/libfuse.so
128
129 install fuse.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
130
131 # part of default udev rules nowdays
132 %{__rm} $RPM_BUILD_ROOT/etc/udev/rules.d/99-fuse.rules
133
134 # not needed
135 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/fuse
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %pre tools
144 %groupadd -g 84 fuse
145
146 %files
147 %defattr(644,root,root,755)
148 %doc README.md NEWS ChangeLog AUTHORS doc/{how-fuse-works,kernel.txt}
149 %attr(755,root,root) /%{_lib}/libfuse.so.*.*.*
150 %attr(755,root,root) %ghost /%{_lib}/libfuse.so.2
151 %attr(755,root,root) %{_libdir}/libulockmgr.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libulockmgr.so.1
153
154 %files devel
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/libfuse.so
157 %attr(755,root,root) %{_libdir}/libulockmgr.so
158 %{_libdir}/libfuse.la
159 %{_libdir}/libulockmgr.la
160 %{_includedir}/fuse
161 %{_includedir}/fuse.h
162 %{_includedir}/ulockmgr.h
163 %{_pkgconfigdir}/fuse.pc
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libfuse.a
168 %{_libdir}/libulockmgr.a
169
170 %files apidocs
171 %defattr(644,root,root,755)
172 %doc doc/html/*
173
174 %files tools
175 %defattr(644,root,root,755)
176 %attr(4755,root,root) %{_bindir}/fusermount
177 %attr(755,root,root) %{_bindir}/ulockmgr_server
178 %attr(755,root,root) /sbin/mount.fuse
179 %{_mandir}/man1/fusermount.1*
180 %{_mandir}/man1/ulockmgr_server.1*
181 %{_mandir}/man8/mount.fuse.8*
This page took 0.037684 seconds and 3 git commands to generate.