]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- typos
[packages/libfuse.git] / libfuse.spec
1 Summary:        Filesystem in Userspace
2 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika
3 Name:           libfuse
4 Version:        2.9.7
5 Release:        2
6 License:        GPL v2
7 Group:          Applications/System
8 #Source0Download: https://github.com/libfuse/libfuse/releases
9 Source0:        https://github.com/libfuse/libfuse/releases/download/fuse-%{version}/fuse-%{version}.tar.gz
10 # Source0-md5:  9bd4ce8184745fd3d000ca2692adacdb
11 Source1:        fuse.conf
12 Patch0:         kernel-misc-fuse-Makefile.am.patch
13 URL:            https://github.com/libfuse/libfuse
14 BuildRequires:  autoconf >= 2.60
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  sed >= 4.0
18 Requires(pre):  /usr/bin/getgid
19 Requires(pre):  /usr/sbin/groupadd
20 Provides:       group(fuse)
21 Suggests:       mount >= 2.18
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 FUSE (Filesystem in Userspace) is a simple interface for userspace
26 programs to export a virtual filesystem to the Linux kernel. FUSE also
27 aims to provide a secure method for non privileged users to create and
28 mount their own filesystem implementations.
29
30 This package contains a shared library.
31
32 %description -l pl.UTF-8
33 FUSE stanowi prosty interfejs dla programów działających w przestrzeni
34 użytkownika eksportujący wirtualny system plików do jądra Linuksa.
35 FUSE ma również na celu udostępnienie bezpiecznej metody tworzenia i
36 montowania własnych implementacji systemów plików przez zwykłych
37 (nieuprzywilejowanych) użytkowników.
38
39 Ten pakiet zawiera bibliotekę współdzieloną.
40
41 %package devel
42 Summary:        Filesystem in Userspace - development header files
43 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - pliki nagłówkowe
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 FUSE libraries header files.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe bibliotek FUSE.
52
53 %package static
54 Summary:        Filesystem in Userspace - static libraries
55 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - biblioteki statyczne
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static FUSE libraries.
61
62 %description static -l pl.UTF-8
63 Statyczne biblioteki FUSE.
64
65 %prep
66 %setup -q -n fuse-%{version}
67 %patch0 -p1
68
69 sed -i '/FUSERMOUNT_PROG/s,fusermount,%{_bindir}/fusermount,' lib/mount.c
70
71 # gold is missing base versioning
72 install -d ld-dir
73 [ ! -x /usr/bin/ld.bfd ] || ln -sf /usr/bin/ld.bfd ld-dir/ld
74
75 %build
76 PATH=$(pwd)/ld-dir:$PATH
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82 %configure \
83         INIT_D_PATH=/etc/rc.d/init.d \
84         --disable-silent-rules \
85         --enable-lib \
86         --enable-util
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT{/%{_lib},%{_pkgconfigdir},%{_sysconfdir}}
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 mv -f $RPM_BUILD_ROOT%{_libdir}/libfuse.so.* $RPM_BUILD_ROOT/%{_lib}
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfuse.so
99 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo libfuse.so.*.*) \
100         $RPM_BUILD_ROOT%{_libdir}/libfuse.so
101
102 install fuse.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
103 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
104
105 # part of default udev rules nowdays
106 rm $RPM_BUILD_ROOT/etc/udev/rules.d/99-fuse.rules
107
108 # not needed
109 rm $RPM_BUILD_ROOT/etc/rc.d/init.d/fuse
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %pre
115 %groupadd -g 84 fuse
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc README.md NEWS ChangeLog AUTHORS doc/*
123 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fuse.conf
124 %attr(4755,root,root) %{_bindir}/fusermount
125 %attr(755,root,root) %{_bindir}/ulockmgr_server
126 %attr(755,root,root) /sbin/mount.fuse
127 %attr(755,root,root) /%{_lib}/libfuse.so.*.*.*
128 %attr(755,root,root) %ghost /%{_lib}/libfuse.so.2
129 %attr(755,root,root) %{_libdir}/libulockmgr.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libulockmgr.so.1
131 %{_mandir}/man1/fusermount.1*
132 %{_mandir}/man1/ulockmgr_server.1*
133 %{_mandir}/man8/mount.fuse.8*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libfuse.so
138 %attr(755,root,root) %{_libdir}/libulockmgr.so
139 %{_libdir}/libfuse.la
140 %{_libdir}/libulockmgr.la
141 %{_includedir}/fuse
142 %{_includedir}/fuse.h
143 %{_includedir}/ulockmgr.h
144 %{_pkgconfigdir}/fuse.pc
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libfuse.a
149 %{_libdir}/libulockmgr.a
This page took 0.440647 seconds and 3 git commands to generate.