]> git.pld-linux.org Git - packages/libfilezilla.git/blob - libfilezilla.spec
- updated to 0.10.1
[packages/libfilezilla.git] / libfilezilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # doxygen API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_without  tests           # "make check"
6 #
7 Summary:        Library for high-performing platform-independent programs
8 Summary(pl.UTF-8):      Biblioteka do wydajnych programów niezależnych od platformy
9 Name:           libfilezilla
10 Version:        0.10.1
11 Release:        1
12 License:        GPL v2
13 Group:          Libraries
14 Source0:        http://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
15 # Source0-md5:  0ab3b56ca55e608d601ada68dd86d673
16 URL:            http://lib.filezilla-project.org/
17 %{?with_tests:BuildRequires:    cppunit-devel >= 1.10.2}
18 %{?with_apidocs:BuildRequires:  doxygen}
19 %if %{with tests} && %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
20 BuildRequires:  glibc-localedb-all
21 %endif
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake
24 BuildRequires:  libtool >= 2:2
25 BuildRequires:  pkgconfig >= 1:0.7
26 # -std=c++14
27 BuildRequires:  libstdc++-devel >= 6:5
28 BuildRequires:  rpmbuild(macros) >= 1.583
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 libfilezilla is a free, open source C++ library, offering some basic
33 functionality to build high-performing, platform-independent programs.
34 Some of the highlights include:
35
36 - A typesafe, multi-threaded event system that's very simple to use
37   yet extremely efficient
38 - Timers for periodic events
39 - A datetime class that not only tracks timestamp but also their
40   accuracy, which simplifies dealing with timestamps originating from
41   different sources
42 - Simple process handling for spawning child processes with redirected
43   I/O
44
45 %description -l pl.UTF-8
46 libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
47 oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
48 programów niezależnych od platformy. Uwzględnione funkcje obejmują:
49 - bezpieczny pod względem typów, wielowątkowy system zdarzeń -
50   bardzo prosty w użyciu, a jednocześnie bardzo wydajny
51 - zegary do zdarzeń regularnych
52 - klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
53   dokładność, co upraszcza obsługę znaczników czasu pochodzących z
54   różnych źródeł
55 - prostą obsługę procesów do tworzenia procesów potomnych z
56   przekierowanym wejściem/wyjściem
57
58 %package devel
59 Summary:        Header files for libfilezilla library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libfilezilla
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       libstdc++-devel >= 6:5
64
65 %description devel
66 Header files for libfilezilla library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki libfilezilla.
70
71 %package static
72 Summary:        Static libfilezilla library
73 Summary(pl.UTF-8):      Statyczna biblioteka libfilezilla
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static libfilezilla library.
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka libfilezilla.
82
83 %package apidocs
84 Summary:        %{name} API documentation
85 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
86 Group:          Documentation
87
88 %description apidocs
89 API documentation for %{name} library.
90
91 %description apidocs -l pl.UTF-8
92 Dokumentacja API biblioteki %{name}.
93
94 %prep
95 %setup -q
96
97 %build
98 %{__libtoolize}
99 %{__aclocal} -I m4
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         %{!?with_static_libs:--disable-static}
105 %{__make}
106
107 %if %{with tests}
108 # wide char conversion test fails with plain C locale
109 LC_ALL=C.UTF-8 \
110 %{__make} check
111 %endif
112
113 %if %{with apidocs}
114 %{__make} -C doc html
115 %endif
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog NEWS README
134 %attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libfilezilla.so
140 %{_includedir}/libfilezilla
141 %{_pkgconfigdir}/libfilezilla.pc
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libfilezilla.a
147 %endif
148
149 %if %{with apidocs}
150 %files apidocs
151 %defattr(644,root,root,755)
152 %doc doc/doxygen-doc/html/*
153 %endif
This page took 0.742202 seconds and 3 git commands to generate.