]> git.pld-linux.org Git - packages/libextractor.git/commitdiff
- updated for 0.5.19a
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 22 Jan 2008 22:20:25 +0000 (22:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    libextractor-64bit.patch -> 1.2
    libextractor-make.patch -> 1.3

libextractor-64bit.patch
libextractor-make.patch

index 465f8091710e3135f2e02e32070ba5a94fac3035..2b3d618f968a0dc5b637c80d4e145fcfdd3d9365 100644 (file)
@@ -2,23 +2,23 @@ pack.c: In function 'cat_unpack':
 pack.c:407: warning: left shift count >= width of type
 pack.c:423: warning: left shift count >= width of type
 
---- libextractor-0.5.9/src/plugins/pack.c.orig 2005-09-18 11:54:35.000000000 +0200
-+++ libextractor-0.5.9/src/plugins/pack.c      2006-02-19 11:44:07.330679750 +0100
-@@ -404,7 +404,7 @@
-       *swordp |= *bp++ << 24;
-       
-       if ( (sizeof(swordp) > 4) && (*swordp & 0x80000000) )
--        *swordp |= (~0) << ((sizeof(sword)-4) * 8);
-+        *swordp |= (~0L) << ((sizeof(sword)-4) * 8);
-       
-       ++swordp;
-       npacked += 4;
-@@ -420,7 +420,7 @@
-       *swordp |= *bp++;
-       
-       if ( (sizeof(swordp) > 4) && (*swordp & 0x80000000) )
--        *swordp |= (~0) << ((sizeof(sword)-4) * 8);
-+        *swordp |= (~0L) << ((sizeof(sword)-4) * 8);
-       
-       ++swordp;
-       npacked += 4;
+--- libextractor-0.5.19/src/plugins/pack.c.orig        2007-07-29 10:35:18.000000000 +0200
++++ libextractor-0.5.19/src/plugins/pack.c     2008-01-22 21:39:53.811402372 +0100
+@@ -447,7 +447,7 @@
+               *swordp |= *bp++ << 24;
+               if ((sizeof (swordp) > 4) && (*swordp & 0x80000000))
+-                *swordp |= (~0) << ((sizeof (sword) - 4) * 8);
++                *swordp |= (~0L) << ((sizeof (sword) - 4) * 8);
+               ++swordp;
+               npacked += 4;
+@@ -464,7 +464,7 @@
+               *swordp |= *bp++;
+               if ((sizeof (swordp) > 4) && (*swordp & 0x80000000))
+-                *swordp |= (~0) << ((sizeof (sword) - 4) * 8);
++                *swordp |= (~0L) << ((sizeof (sword) - 4) * 8);
+               ++swordp;
+               npacked += 4;
index a79a136578b49565720e5bfc34973d04695d1eb7..afe044020935c55b209e9d736dc08bb61fa33895 100644 (file)
@@ -1,27 +1,11 @@
---- libextractor-0.5.16/src/plugins/Makefile.am.orig   2006-11-11 03:45:43.000000000 +0100
-+++ libextractor-0.5.16/src/plugins/Makefile.am        2006-11-19 12:06:59.851016250 +0100
-@@ -317,11 +317,11 @@
-   $(PLUGINFLAGS) $(retaincommand) -lQtCore4 -lQtGui4 $(svgflags)
+--- libextractor-0.5.19/src/plugins/Makefile.am.orig   2007-12-31 14:17:46.000000000 +0100
++++ libextractor-0.5.19/src/plugins/Makefile.am        2008-01-22 21:45:54.695968011 +0100
+@@ -373,7 +373,7 @@
+   $(QT_CFLAGS) $(QT_SVG_CFLAGS)
  
  install-exec-hook:
 -      mkdir -p $(DESTDIR)$(plugindir) &> /dev/null || true
 +      mkdir -p $(DESTDIR)$(plugindir) 2> /dev/null || true
-       rm -f $(DESTDIR)$(plugindir)/libextractor_thumbnail$(LIBEXT); \
-       rm -f $(DESTDIR)$(plugindir)/libextractor_thumbnail.la; \
-       if test "$(thumbdir)" != ""; then \
--              if test "$(thumbqt)" != ""; then \
-+              if false; then \
-                       $(LN_S) $(plugindir)/libextractor_thumbnailqt$(LIBEXT) \
-                               $(DESTDIR)$(plugindir)/libextractor_thumbnail$(LIBEXT); \
-               else \
---- libextractor-0.5.16/src/plugins/exiv2/Makefile.am.orig     2006-03-11 01:12:32.000000000 +0100
-+++ libextractor-0.5.16/src/plugins/exiv2/Makefile.am  2006-11-19 12:45:14.022393000 +0100
-@@ -6,7 +6,7 @@
-  libextractor_exiv2.la
- libextractor_exiv2_la_LINK = \
--  /bin/sh ../../../libtool --mode=link $(CXXLD) -o libextractor_exiv2.la
-+  /bin/sh ../../../libtool --mode=link $(CXXLD) $(LDFLAGS) $(libextractor_exiv2_la_LDFLAGS) -o libextractor_exiv2.la
- libextractor_exiv2_la_LDFLAGS = \
-   $(XTRA_CPPLIBS) -lpthread \
-   $(PLUGINFLAGS) $(retaincommand)
+       rm -f $(DESTDIR)$(plugindir)/libextractor_thumbnail$(LIBEXT)
+       rm -f $(DESTDIR)$(plugindir)/libextractor_thumbnail.la
+       if test "$(thumbgtk)" != ""; then \
This page took 0.039529 seconds and 4 git commands to generate.