]> git.pld-linux.org Git - packages/libextractor.git/commitdiff
- updated to 1.13 master auto/th/libextractor-1.13-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 13 Jan 2024 17:28:10 +0000 (18:28 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 13 Jan 2024 17:28:10 +0000 (18:28 +0100)
libextractor-exiv2-0.28.patch [deleted file]
libextractor-exiv2.patch [new file with mode: 0644]
libextractor.spec
no-ffmpeg.patch [deleted file]

diff --git a/libextractor-exiv2-0.28.patch b/libextractor-exiv2-0.28.patch
deleted file mode 100644 (file)
index d763b65..0000000
+++ /dev/null
@@ -1,333 +0,0 @@
-diff --git a/src/plugins/exiv2_extractor.cc b/src/plugins/exiv2_extractor.cc
-index 78f9bda..d32ed6a 100644
---- a/src/plugins/exiv2_extractor.cc
-+++ b/src/plugins/exiv2_extractor.cc
-@@ -90,7 +90,11 @@ virtual int close ();
-  * @param rcount number of bytes to read
-  * @return buffer with data read, empty buffer (!) on failure (!)
-  */
-+#if EXIV2_TEST_VERSION (0,28,0)
-+virtual Exiv2::DataBuf read (size_t rcount);
-+#else
- virtual Exiv2::DataBuf read (long rcount);
-+#endif
- /**
-  * Read up to 'rcount' bytes into 'buf'.
-@@ -99,8 +103,17 @@ virtual Exiv2::DataBuf read (long rcount);
-  * @param rcount size of 'buf'
-  * @return number of bytes read successfully, 0 on failure (!)
-  */
-+#if EXIV2_TEST_VERSION (0,28,0)
-+virtual size_t read (Exiv2::byte *buf,
-+                   size_t rcount);
-+#else
- virtual long read (Exiv2::byte *buf,
-                    long rcount);
-+#endif
-+
-+#if EXIV2_TEST_VERSION (0,28,0)
-+virtual void populateFakeData();
-+#endif
- /**
-  * Read a single character.
-@@ -117,8 +130,13 @@ virtual int getb ();
-  * @param wcount how many bytes to write
-  * @return -1 (always fails)
-  */
-+#if EXIV2_TEST_VERSION(0,28,0)
-+virtual size_t write (const Exiv2::byte *data,
-+                    size_t wcount);
-+#else
- virtual long write (const Exiv2::byte *data,
-                     long wcount);
-+#endif
- /**
-  * Write to stream.
-@@ -126,7 +144,11 @@ virtual long write (const Exiv2::byte *data,
-  * @param src stream to copy
-  * @return -1 (always fails)
-  */
-+#if EXIV2_TEST_VERSION(0,28,0)
-+virtual size_t write (Exiv2::BasicIo &src);
-+#else
- virtual long write (Exiv2::BasicIo &src);
-+#endif
- /**
-  * Write a single byte.
-@@ -150,7 +172,11 @@ virtual void transfer (Exiv2::BasicIo& s
-  * @parma pos offset is relative to where?
-  * @return -1 on failure, 0 on success
-  */
-+#if EXIV2_TEST_VERSION(0,28,0)
-+virtual int seek (int64_t offset,
-+#else
- virtual int seek (long offset,
-+#endif
-                   Exiv2::BasicIo::Position pos);
- /**
-@@ -172,7 +194,11 @@ virtual int munmap ();
-  *
-  * @return -1 on error
-  */
-+#if EXIV2_TEST_VERSION(0,28,0)
-+virtual size_t tell (void) const;
-+#else
- virtual long int tell (void) const;
-+#endif
- /**
-  * Return overall size of the file.
-@@ -213,7 +239,11 @@ virtual bool eof () const;
-  *
-  * @throws error
-  */
-+#if EXIV2_TEST_VERSION(0,28,0)
-+virtual const std::string& path () const noexcept;
-+#else
- virtual std::string path () const;
-+#endif
- #ifdef EXV_UNICODE_PATH
- /**
-@@ -230,7 +260,11 @@ virtual std::wstring wpath () const;
-  *
-  * @throws error
-  */
-+#if EXIV2_TEST_VERSION(0,28,0)
-+virtual Exiv2::BasicIo::UniquePtr temporary () const;
-+#else
- virtual Exiv2::BasicIo::AutoPtr temporary () const;
-+#endif
- };
-@@ -266,7 +300,11 @@ ExtractorIO::close ()
-  * @return buffer with data read, empty buffer (!) on failure (!)
-  */
- Exiv2::DataBuf
-+#if EXIV2_TEST_VERSION (0,28,0)
-+ExtractorIO::read (size_t rcount)
-+#else
- ExtractorIO::read (long rcount)
-+#endif
- {
-   void *data;
-   ssize_t ret;
-@@ -284,9 +322,15 @@ ExtractorIO::read (long rcount)
-  * @param rcount size of 'buf'
-  * @return number of bytes read successfully, 0 on failure (!)
-  */
-+#if EXIV2_TEST_VERSION (0,28,0)
-+size_t
-+ExtractorIO::read (Exiv2::byte *buf,
-+                   size_t rcount)
-+#else
- long
- ExtractorIO::read (Exiv2::byte *buf,
-                    long rcount)
-+#endif
- {
-   void *data;
-   ssize_t ret;
-@@ -305,6 +349,12 @@ ExtractorIO::read (Exiv2::byte *buf,
-   return got;
- }
-+#if EXIV2_TEST_VERSION (0,28,0)
-+void ExtractorIO::populateFakeData()
-+{
-+  return;
-+}
-+#endif
- /**
-  * Read a single character.
-@@ -319,7 +369,9 @@ ExtractorIO::getb ()
-   const unsigned char *r;
-   if (1 != ec->read (ec->cls, &data, 1))
--#if EXIV2_TEST_VERSION (0,27,0)
-+#if EXIV2_TEST_VERSION(0,28,0)
-+    throw Exiv2::Error (Exiv2::ErrorCode::kerDecodeLangAltQualifierFailed);
-+#elif EXIV2_TEST_VERSION (0,27,0)
-     throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
- #else
-     throw Exiv2::BasicError<char> (42 /* error code */);
-@@ -336,9 +388,15 @@ ExtractorIO::getb ()
-  * @param wcount how many bytes to write
-  * @return -1 (always fails)
-  */
-+#if EXIV2_TEST_VERSION(0,28,0)
-+size_t
-+ExtractorIO::write (const Exiv2::byte *data,
-+                    size_t wcount)
-+#else
- long
- ExtractorIO::write (const Exiv2::byte *data,
-                     long wcount)
-+#endif
- {
-   return -1;
- }
-@@ -350,7 +408,11 @@ ExtractorIO::write (const Exiv2::byte *data,
-  * @param src stream to copy
-  * @return -1 (always fails)
-  */
-+#if EXIV2_TEST_VERSION(0,28,0)
-+size_t
-+#else
- long
-+#endif
- ExtractorIO::write (Exiv2::BasicIo &src)
- {
-   return -1;
-@@ -378,7 +440,9 @@ ExtractorIO::putb (Exiv2::byte data)
- void
- ExtractorIO::transfer (Exiv2::BasicIo& src)
- {
--#if EXIV2_TEST_VERSION (0,27,0)
-+#if EXIV2_TEST_VERSION(0,28,0)
-+  throw Exiv2::Error (Exiv2::ErrorCode::kerDecodeLangAltQualifierFailed);
-+#elif EXIV2_TEST_VERSION (0,27,0)
-   throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
- #else
-   throw Exiv2::BasicError<char> (42 /* error code */);
-@@ -410,7 +462,11 @@ ExtractorIO::transfer (Exiv2::BasicIo& s
-  * @return -1 on failure, 0 on success
-  */
- int
-+#if EXIV2_TEST_VERSION(0,28,0)
-+ExtractorIO::seek (int64_t offset,
-+#else
- ExtractorIO::seek (long offset,
-+#endif
-                    Exiv2::BasicIo::Position pos)
- {
-   int rel;
-@@ -427,7 +491,9 @@ ExtractorIO::seek (long offset,
- Exiv2::byte *
- ExtractorIO::mmap (bool isWritable)
- {
--#if EXIV2_TEST_VERSION (0,27,0)
-+#if EXIV2_TEST_VERSION (0,28,0)
-+  throw Exiv2::Error (Exiv2::ErrorCode::kerDecodeLangAltQualifierFailed);
-+#elif EXIV2_TEST_VERSION (0,27,0)
-   throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
- #else
-   throw Exiv2::BasicError<char> (42 /* error code */);
-@@ -452,7 +518,11 @@ ExtractorIO::munmap ()
-  *
-  * @return -1 on error
-  */
-+#if EXIV2_TEST_VERSION(0,28,0)
-+size_t
-+#else
- long int
-+#endif
- ExtractorIO::tell (void) const
- {
-   return (long) ec->seek (ec->cls, 0, SEEK_CUR);
-@@ -516,10 +586,17 @@ ExtractorIO::eof () const
-  *
-  * @throws error
-  */
-+#if EXIV2_TEST_VERSION (0,28,0)
-+const std::string&
-+ExtractorIO::path () const noexcept
-+#else
- std::string
- ExtractorIO::path () const
-+#endif
- {
--#if EXIV2_TEST_VERSION (0,27,0)
-+#if EXIV2_TEST_VERSION (0,28,0)
-+  throw Exiv2::Error (Exiv2::ErrorCode::kerDecodeLangAltQualifierFailed);
-+#elif EXIV2_TEST_VERSION (0,27,0)
-   throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
- #else
-   throw Exiv2::BasicError<char> (42 /* error code */);
-@@ -536,7 +613,9 @@ ExtractorIO::path () const
- std::wstring
- ExtractorIO::wpath () const
- {
--#if EXIV2_TEST_VERSION (0,27,0)
-+#if EXIV2_TEST_VERSION (0,28,0)
-+  throw Exiv2::Error (Exiv2::ErrorCode::kerDecodeLangAltQualifierFailed);
-+#elif EXIV2_TEST_VERSION (0,27,0)
-   throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
- #else
-   throw Exiv2::BasicError<char> (42 /* error code */);
-@@ -552,11 +631,17 @@ ExtractorIO::wpath () const
-  *
-  * @throws error
-  */
-+#if EXIV2_TEST_VERSION(0,28,0)
-+Exiv2::BasicIo::UniquePtr
-+#else
- Exiv2::BasicIo::AutoPtr
-+#endif
- ExtractorIO::temporary () const
- {
-   fprintf (stderr, "throwing temporary error\n");
--#if EXIV2_TEST_VERSION (0,27,0)
-+#if EXIV2_TEST_VERSION(0,28,0)
-+  throw Exiv2::Error (Exiv2::ErrorCode::kerDecodeLangAltQualifierFailed);
-+#elif EXIV2_TEST_VERSION (0,27,0)
-   throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
- #else
-   throw Exiv2::BasicError<char> (42 /* error code */);
-@@ -737,8 +822,13 @@ EXTRACTOR_exiv2_extract_method (struct EXTRACTOR_ExtractContext *ec)
- #if ! EXIV2_TEST_VERSION (0,24,0)
-     Exiv2::LogMsg::setLevel (Exiv2::LogMsg::mute);
- #endif
-+#if EXIV2_TEST_VERSION(0,28,0)
-+    std::unique_ptr<Exiv2::BasicIo> eio (new ExtractorIO (ec));
-+    Exiv2::Image::UniquePtr image = Exiv2::ImageFactory::open (std::move(eio));
-+#else
-     std::auto_ptr<Exiv2::BasicIo> eio (new ExtractorIO (ec));
-     Exiv2::Image::AutoPtr image = Exiv2::ImageFactory::open (eio);
-+#endif
-     if (0 == image.get ())
-       return;
-     image->readMetadata ();
-@@ -822,7 +912,11 @@ EXTRACTOR_exiv2_extract_method (struct EXTRACTOR_ExtractContext *ec)
-       ADDXMP ("Xmp.lr.hierarchicalSubject", EXTRACTOR_METATYPE_SUBJECT);
-     }
-   }
-+#if EXIV2_TEST_VERSION (0,28,0)
-+  catch (const Exiv2::Error& e)
-+#else
-   catch (const Exiv2::AnyError& e)
-+#endif
-   {
- #if DEBUG
-     std::cerr << "Caught Exiv2 exception '" << e << "'\n";
---- libextractor-1.11/src/plugins/test_exiv2.c.orig    2021-01-30 14:20:23.000000000 +0100
-+++ libextractor-1.11/src/plugins/test_exiv2.c 2023-07-26 06:26:59.042456917 +0200
-@@ -49,8 +49,8 @@ main (int argc, char *argv[])
-       EXTRACTOR_METATYPE_GPS_LATITUDE,
-       EXTRACTOR_METAFORMAT_UTF8,
-       "text/plain",
--      "28deg 8' (18|17.585)\" ?",
--      strlen ("28deg 8' (18|17.585)\" ?") + 1,
-+      "28 ?deg 8' (18|17.58|17.585)\" ?",
-+      strlen ("28 ?deg 8' (18|17.58|17.585)\" ?") + 1,
-       0,
-       .regex = 1
-     },
-@@ -66,8 +66,8 @@ main (int argc, char *argv[])
-       EXTRACTOR_METATYPE_GPS_LONGITUDE,
-       EXTRACTOR_METAFORMAT_UTF8,
-       "text/plain",
--      "14deg 14' (22|21.713)\" ?",
--      strlen ("14deg 14' (22|21.713)\" ?"),
-+      "14 ?deg 14' (22|21.71|21.713)\" ?",
-+      strlen ("14 ?deg 14' (22|21.71|21.713)\" ?"),
-       0,
-       .regex = 1
-     },
diff --git a/libextractor-exiv2.patch b/libextractor-exiv2.patch
new file mode 100644 (file)
index 0000000..c1645b4
--- /dev/null
@@ -0,0 +1,24 @@
+--- libextractor-1.13/src/plugins/test_exiv2.c.orig    2021-04-08 13:30:42.000000000 +0200
++++ libextractor-1.13/src/plugins/test_exiv2.c 2024-01-13 15:43:17.804290064 +0100
+@@ -49,8 +49,8 @@ main (int argc, char *argv[])
+       EXTRACTOR_METATYPE_GPS_LATITUDE,
+       EXTRACTOR_METAFORMAT_UTF8,
+       "text/plain",
+-      "28deg 8' (18|17.585)\" ?",
+-      strlen ("28deg 8' (18|17.585)\" ?") + 1,
++      "28 ?deg 8' (18|17.58|17.585)\" ?",
++      strlen ("28 ?deg 8' (18|17.58|17.585)\" ?") + 1,
+       0,
+       .regex = 1
+     },
+@@ -66,8 +66,8 @@ main (int argc, char *argv[])
+       EXTRACTOR_METATYPE_GPS_LONGITUDE,
+       EXTRACTOR_METAFORMAT_UTF8,
+       "text/plain",
+-      "14deg 14' (22|21.713)\" ?",
+-      strlen ("14deg 14' (22|21.713)\" ?"),
++      "14 ?deg 14' (22|21.71|21.713)\" ?",
++      strlen ("14 ?deg 14' (22|21.71|21.713)\" ?"),
+       0,
+       .regex = 1
+     },
index 59b42f52ca65e47b637dc5ddd5427016b209ca7e..91c08a77b5a022f9261eb7c01a620ed60a7f3b0a 100644 (file)
 Summary:       Meta-data extraction library
 Summary(pl.UTF-8):     Biblioteka do ekstrakcji metadanych
 Name:          libextractor
-Version:       1.11
-Release:       3
+Version:       1.13
+Release:       1
 License:       GPL v3+
 Group:         Libraries
 Source0:       https://ftp.gnu.org/gnu/libextractor/%{name}-%{version}.tar.gz
-# Source0-md5: 934a53749d263c1f5b8a6aae5741ea3f
+# Source0-md5: 7f28aeb17fb360a78a71069375934e6f
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-rpm5.patch
-Patch2:                libextractor-exiv2-0.28.patch
-Patch3:                no-ffmpeg.patch
+Patch2:                %{name}-exiv2.patch
 URL:           http://www.gnu.org/software/libextractor/
-BuildRequires: autoconf >= 2.61
+BuildRequires: autoconf >= 2.71
 BuildRequires: automake >= 1:1.11
 BuildRequires: bzip2-devel
 BuildRequires: exiv2-devel
 BuildRequires: gdk-pixbuf2-devel >= 2.4
-BuildRequires: gettext-tools >= 0.16.1
+BuildRequires: gettext-tools >= 0.21
 BuildRequires: flac-devel
 BuildRequires: giflib-devel >= 5.1.0
 BuildRequires: glib2-devel >= 2.0.0
@@ -152,7 +151,6 @@ Statyczna wersja bibliotek libextractor.
 %patch0 -p1
 %{?with_rpm5:%patch1 -p1}
 %patch2 -p1
-%patch3 -p1
 
 %{__rm} po/stamp-po
 
@@ -213,6 +211,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_archive.so
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_deb.so
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_dvi.so
+%attr(755,root,root) %{_libdir}/%{name}/libextractor_elf.so
 # R: exiv2
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_exiv2.so
 # R: flac
@@ -246,6 +245,7 @@ rm -rf $RPM_BUILD_ROOT
 # R: zlib
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_png.so
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_ps.so
+%attr(755,root,root) %{_libdir}/%{name}/libextractor_real.so
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_riff.so
 # R: rpm-lib
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_rpm.so
diff --git a/no-ffmpeg.patch b/no-ffmpeg.patch
deleted file mode 100644 (file)
index 11750a7..0000000
+++ /dev/null
@@ -1,153 +0,0 @@
-diff --git a/ChangeLog b/ChangeLog
-index a1ba981..6cd0e63 100644
---- a/ChangeLog
-+++ b/ChangeLog
-@@ -1,3 +1,6 @@
-+Tue 20 Apr 2021 06:33:46 PM CEST
-+    Removing plugins depending on buggy, unstable libffmpeg library. -CG
-+
- Sat 30 Jan 2021 03:25:35 PM CET
-       Fix #6709: mask SIGPIPE to avoid test case failure
-       with latest librpm.  Remove plibc.h logic.
-diff --git a/configure.ac b/configure.ac
-index 456287a..80ce414 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -648,38 +648,6 @@ CPPFLAGS="$CPPFLAGS_OLD"
- AC_CHECK_PROG([HAVE_ZZUF],[zzuf], 1, 0)
- AM_CONDITIONAL(HAVE_ZZUF, test 0 != $HAVE_ZZUF)
--AC_MSG_CHECKING([whether to enable the FFmpeg thumbnail extractor])
--new_ffmpeg=0
--AC_ARG_ENABLE(ffmpeg,
-- [AC_HELP_STRING([--enable-ffmpeg],[Enable FFmpeg support])
--  AC_HELP_STRING([--disable-ffmpeg],[Disable FFmpeg support])],
-- [AS_CASE(["$enableval"],
--   [no],[
--      AC_MSG_RESULT(no)
--      ffmpeg_enabled=0
--   ],[
--      AC_MSG_RESULT(yes)
--      ffmpeg_enabled=1
--   ])],
--  [     AC_MSG_RESULT(yes)
--        ffmpeg_enabled=1])
--AS_IF([test x$ffmpeg_enabled = x1],
-- [ffmpeg_enabled=0
--  new_ffmpeg=0
--  AC_CHECK_HEADERS([libavutil/avutil.h libavformat/avformat.h libavcodec/avcodec.h libavutil/frame.h],
--    AC_CHECK_HEADERS([libavresample/avresample.h],
--      AC_CHECK_LIB(avutil, av_audio_fifo_alloc,
--        new_ffmpeg=1)))
--
--  AC_CHECK_LIB(swscale, sws_getContext,
--    AC_CHECK_LIB(avcodec, avcodec_alloc_context3,
--      ffmpeg_enabled=1))
--  AC_CHECK_HEADERS([libavutil/avutil.h ffmpeg/avutil.h libavformat/avformat.h ffmpeg/avformat.h libavcodec/avcodec.h ffmpeg/avcodec.h libswscale/swscale.h ffmpeg/swscale.h])
-- ])
--AM_CONDITIONAL(HAVE_FFMPEG, test x$ffmpeg_enabled != x0)
--AM_CONDITIONAL(HAVE_FFMPEG_NEW, test x$new_ffmpeg != x0)
--
--
- LE_INTLINCL=""
- LE_LIBINTL="$LTLIBINTL"
- AC_ARG_ENABLE(framework, [  --enable-framework      enable Mac OS X framework build helpers],enable_framework_build=$enableval)
-@@ -775,12 +743,6 @@ AS_IF([test "x$HAVE_GIF_TRUE" = "x#"],
- AS_IF([test "x$have_gsf" != "xtrue"],
-   [AC_MSG_NOTICE([NOTICE: libgsf not found, no OLE2 (MS Office) support])])
--AS_IF([test "x$ffmpeg_enabled" = "x0"],
--  [AC_MSG_NOTICE([NOTICE: FFmpeg thumbnailer plugin disabled])])
--
--AS_IF([test "x$new_ffmpeg" = "x0"],
--  [AC_MSG_NOTICE([NOTICE: FFmpeg/opus audio preview plugin disabled, It needs libav >= 10, or a FFmpeg with --enable-libavresample])])
--
- AS_IF([test "x$have_gdk_pixbuf" = "x0"],
-   [AC_MSG_NOTICE([NOTICE: libgdk-pixbuf not found, gtk thumbnail support disabled])])
-diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
-index 8cdd905..69cb1f7 100644
---- a/src/plugins/Makefile.am
-+++ b/src/plugins/Makefile.am
-@@ -68,17 +71,6 @@ if HAVE_MAGIC
- PLUGIN_MIME=libextractor_mime.la
- TEST_MIME=test_mime
--if HAVE_FFMPEG
--# FFmpeg-thumbnailer requires MAGIC and FFMPEG
--PLUGIN_FFMPEG=libextractor_thumbnailffmpeg.la
--TEST_FFMPEG=test_thumbnailffmpeg
--endif
--
--if HAVE_FFMPEG_NEW
--PLUGIN_PREVIEWOPUS=libextractor_previewopus.la
--TEST_PREVIEWOPUS=test_previewopus
--endif
--
- if HAVE_GDK_PIXBUF
- # Gtk-thumbnailer requires MAGIC and GDK_PIXBUF
- PLUGIN_GTK=libextractor_thumbnailgtk.la
-@@ -188,7 +182,6 @@ plugin_LTLIBRARIES = \
-   libextractor_xm.la \
-   $(PLUGIN_ARCHIVE) \
-   $(PLUGIN_EXIV2) \
--  $(PLUGIN_FFMPEG) \
-   $(PLUGIN_FLAC) \
-   $(PLUGIN_GIF) \
-   $(PLUGIN_GSF) \
-@@ -202,7 +195,6 @@ plugin_LTLIBRARIES = \
-   $(PLUGIN_MPEG) \
-   $(PLUGIN_OGG) \
-   $(PLUGIN_PDF) \
--  $(PLUGIN_PREVIEWOPUS) \
-   $(PLUGIN_RPM) \
-   $(PLUGIN_TIFF) \
-   $(PLUGIN_ZLIB)
-@@ -228,8 +222,6 @@ check_PROGRAMS = \
-   test_zip \
-   $(TEST_ARCHIVE) \
-   $(TEST_EXIV2) \
--  $(TEST_FFMPEG) \
--  $(TEST_PREVIEWOPUS) \
-   $(TEST_FLAC) \
-   $(TEST_GIF) \
-   $(TEST_GSF) \
-@@ -615,19 +634,6 @@ test_sid_LDADD = \
-   $(top_builddir)/src/plugins/libtest.la
--libextractor_thumbnailffmpeg_la_SOURCES = \
--  thumbnailffmpeg_extractor.c
--libextractor_thumbnailffmpeg_la_LDFLAGS = \
--  $(PLUGINFLAGS)
--libextractor_thumbnailffmpeg_la_LIBADD = \
--  -lavutil -lavformat -lavcodec -lswscale -lmagic $(XLIB)
--
--test_thumbnailffmpeg_SOURCES = \
--  test_thumbnailffmpeg.c
--test_thumbnailffmpeg_LDADD = \
--  $(top_builddir)/src/plugins/libtest.la
--
--
- libextractor_thumbnailgtk_la_SOURCES = \
-   thumbnailgtk_extractor.c
- libextractor_thumbnailgtk_la_LDFLAGS = \
-@@ -642,18 +648,6 @@ test_thumbnailgtk_SOURCES = \
- test_thumbnailgtk_LDADD = \
-   $(top_builddir)/src/plugins/libtest.la
--libextractor_previewopus_la_SOURCES = \
--  previewopus_extractor.c
--libextractor_previewopus_la_LDFLAGS = \
--  $(PLUGINFLAGS)
--libextractor_previewopus_la_LIBADD = \
--  -lavutil -lavformat -lavcodec -lswscale -lavresample  -lmagic $(XLIB)
--
--test_previewopus_SOURCES = \
--  test_previewopus.c
--test_previewopus_LDADD = \
--  $(top_builddir)/src/plugins/libtest.la
--
- libextractor_tiff_la_SOURCES = \
-   tiff_extractor.c
This page took 0.126713 seconds and 4 git commands to generate.