]> git.pld-linux.org Git - packages/libdom.git/blame_incremental - libdom.spec
- pl
[packages/libdom.git] / libdom.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4
5Summary: Implementation of W3C DOM
6Summary(pl.UTF-8): Implementacja W3C DOM
7Name: libdom
8Version: 0.1.0
9Release: 1
10License: MIT
11Group: Libraries
12Source0: http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13# Source0-md5: 055878cf633a935031517e2e209062f6
14URL: http://www.netsurf-browser.org/projects/libdom/
15BuildRequires: expat-devel >= 1.95
16BuildRequires: libhubbub-devel >= 0.3.0
17BuildRequires: libparserutils-devel >= 0.2.0
18BuildRequires: libwapcaplet-devel >= 0.2.1
19BuildRequires: libxml2-devel >= 2.0
20BuildRequires: netsurf-buildsystem >= 1.1
21BuildRequires: pkgconfig
22Requires: libparserutils >= 0.2.0
23Requires: libwapcaplet >= 0.2.1
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27LibDOM is an implementation of the W3C DOM, written in C. It is
28currently in development for use with NetSurf and is intended to be
29suitable for use in other projects too.
30
31%description -l pl.UTF-8
32LibDOM to implementacja W3C DOM, napisana w C. Jest rozwijana do
33wykorzystania w ramach projektu NetSurf, ale także z myślą o
34możliwości użycia w innych projektach.
35
36%package devel
37Summary: libdom library headers
38Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libdom
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41Requires: expat-devel
42Requires: libhubbub-devel >= 0.3.0
43
44%description devel
45This package contains the include files and other resources you can
46use to incorporate libdom into applications.
47
48%description devel -l pl.UTF-8
49Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
50programach.
51
52%package static
53Summary: libdom static library
54Summary(pl.UTF-8): Statyczna biblioteka libdom
55Group: Development/Libraries
56Requires: %{name}-devel = %{version}-%{release}
57
58%description static
59This is package with static libdom library.
60
61%description static -l pl.UTF-8
62Statyczna biblioteka libdom.
63
64%prep
65%setup -q
66
67%build
68export CC="%{__cc}"
69export CFLAGS="%{rpmcflags}"
70export LDFLAGS="%{rpmldflags}"
71
72%{__make} \
73 Q= \
74 PREFIX=%{_prefix} \
75 LIBDIR=%{_lib} \
76 COMPONENT_TYPE=lib-shared
77
78%if %{with static_libs}
79%{__make} \
80 Q= \
81 PREFIX=%{_prefix} \
82 LIBDIR=%{_lib} \
83 COMPONENT_TYPE=lib-static
84%endif
85
86%install
87rm -rf $RPM_BUILD_ROOT
88%{__make} install \
89 Q= \
90 PREFIX=%{_prefix} \
91 LIBDIR=%{_lib} \
92 COMPONENT_TYPE=lib-shared \
93 DESTDIR=$RPM_BUILD_ROOT
94
95%if %{with static_libs}
96%{__make} install \
97 Q= \
98 PREFIX=%{_prefix} \
99 LIBDIR=%{_lib} \
100 COMPONENT_TYPE=lib-static \
101 DESTDIR=$RPM_BUILD_ROOT
102%endif
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(644,root,root,755)
112%doc COPYING README
113%attr(755,root,root) %{_libdir}/libdom.so.*.*.*
114%attr(755,root,root) %ghost %{_libdir}/libdom.so.0
115
116%files devel
117%defattr(644,root,root,755)
118%attr(755,root,root) %{_libdir}/libdom.so
119%{_includedir}/dom
120%{_pkgconfigdir}/libdom.pc
121
122%if %{with static_libs}
123%files static
124%defattr(644,root,root,755)
125%{_libdir}/libdom.a
126%endif
This page took 0.12108 seconds and 4 git commands to generate.