]> git.pld-linux.org Git - packages/libdom.git/commitdiff
- pl auto/th/libdom-0.1.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 13 May 2014 16:17:23 +0000 (18:17 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 13 May 2014 16:17:23 +0000 (18:17 +0200)
- use LIBDIR to get proper libs directory, also in .pc files
- install time dependencies

libdom.spec

index 887ef9f3bc45ce62178b62f920c9e8f62b4dd058..f3ff74134f90f74a0c53ea7cc288f12de96e2e7a 100644 (file)
@@ -3,6 +3,7 @@
 %bcond_without static_libs     # don't build static library
 
 Summary:       Implementation of W3C DOM
+Summary(pl.UTF-8):     Implementacja W3C DOM
 Name:          libdom
 Version:       0.1.0
 Release:       1
@@ -11,11 +12,15 @@ Group:              Libraries
 Source0:       http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
 # Source0-md5: 055878cf633a935031517e2e209062f6
 URL:           http://www.netsurf-browser.org/projects/libdom/
+BuildRequires: expat-devel >= 1.95
 BuildRequires: libhubbub-devel >= 0.3.0
 BuildRequires: libparserutils-devel >= 0.2.0
 BuildRequires: libwapcaplet-devel >= 0.2.1
-BuildRequires: libxml2-devel
+BuildRequires: libxml2-devel >= 2.0
 BuildRequires: netsurf-buildsystem >= 1.1
+BuildRequires: pkgconfig
+Requires:      libparserutils >= 0.2.0
+Requires:      libwapcaplet >= 0.2.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -23,28 +28,35 @@ LibDOM is an implementation of the W3C DOM, written in C. It is
 currently in development for use with NetSurf and is intended to be
 suitable for use in other projects too.
 
+%description -l pl.UTF-8
+LibDOM to implementacja W3C DOM, napisana w C. Jest rozwijana do
+wykorzystania w ramach projektu NetSurf, ale także z myślą o
+możliwości użycia w innych projektach.
+
 %package devel
 Summary:       libdom library headers
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libdom
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      expat-devel
+Requires:      libhubbub-devel >= 0.3.0
 
 %description devel
-This is the libraries, include files and other resources you can use
-to incorporate libdom into applications.
+This package contains the include files and other resources you can
+use to incorporate libdom into applications.
 
 %description devel -l pl.UTF-8
 Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
 programach.
 
 %package static
-Summary:       libdom static libraries
-Summary(pl.UTF-8):     Statyczne biblioteki libdom
+Summary:       libdom static library
+Summary(pl.UTF-8):     Statyczna biblioteka libdom
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
-This is package with static libdom libraries.
+This is package with static libdom library.
 
 %description static -l pl.UTF-8
 Statyczna biblioteka libdom.
@@ -57,28 +69,34 @@ export CC="%{__cc}"
 export CFLAGS="%{rpmcflags}"
 export LDFLAGS="%{rpmldflags}"
 
-%{__make} Q= \
+%{__make} \
+       Q= \
        PREFIX=%{_prefix} \
+       LIBDIR=%{_lib} \
        COMPONENT_TYPE=lib-shared
 
 %if %{with static_libs}
-%{__make} Q= \
+%{__make} \
+       Q= \
        PREFIX=%{_prefix} \
+       LIBDIR=%{_lib} \
        COMPONENT_TYPE=lib-static
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install Q= \
-       lib=%{_lib} \
+%{__make} install \
+       Q= \
        PREFIX=%{_prefix} \
+       LIBDIR=%{_lib} \
        COMPONENT_TYPE=lib-shared \
        DESTDIR=$RPM_BUILD_ROOT
 
 %if %{with static_libs}
-%{__make} install Q= \
-       lib=%{_lib} \
+%{__make} install \
+       Q= \
        PREFIX=%{_prefix} \
+       LIBDIR=%{_lib} \
        COMPONENT_TYPE=lib-static \
        DESTDIR=$RPM_BUILD_ROOT
 %endif
@@ -91,12 +109,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
+%doc COPYING README
 %attr(755,root,root) %{_libdir}/libdom.so.*.*.*
-%ghost %{_libdir}/libdom.so.0
+%attr(755,root,root) %ghost %{_libdir}/libdom.so.0
 
 %files devel
 %defattr(644,root,root,755)
-%{_libdir}/libdom.so
+%attr(755,root,root) %{_libdir}/libdom.so
 %{_includedir}/dom
 %{_pkgconfigdir}/libdom.pc
 
This page took 0.091272 seconds and 4 git commands to generate.