]> git.pld-linux.org Git - packages/libdom.git/blame_incremental - libdom.spec
- updated -devel dependencies
[packages/libdom.git] / libdom.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4
5Summary: Implementation of W3C DOM
6Summary(pl.UTF-8): Implementacja W3C DOM
7Name: libdom
8Version: 0.1.2
9Release: 1
10License: MIT
11Group: Libraries
12Source0: http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13# Source0-md5: bbe55bf26733e3067170d61427ee6176
14Patch0: no-Werror.patch
15URL: http://www.netsurf-browser.org/projects/libdom/
16BuildRequires: expat-devel >= 1.95
17BuildRequires: libhubbub-devel >= 0.3.1
18BuildRequires: libparserutils-devel >= 0.2.1
19BuildRequires: libwapcaplet-devel >= 0.2.2
20BuildRequires: libxml2-devel >= 2.0
21BuildRequires: netsurf-buildsystem >= 1.3
22BuildRequires: pkgconfig
23Requires: libparserutils >= 0.2.1
24Requires: libwapcaplet >= 0.2.2
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28LibDOM is an implementation of the W3C DOM, written in C. It is
29currently in development for use with NetSurf and is intended to be
30suitable for use in other projects too.
31
32%description -l pl.UTF-8
33LibDOM to implementacja W3C DOM, napisana w C. Jest rozwijana do
34wykorzystania w ramach projektu NetSurf, ale także z myślą o
35możliwości użycia w innych projektach.
36
37%package devel
38Summary: libdom library headers
39Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libdom
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Requires: expat-devel >= 1.95
43Requires: libhubbub-devel >= 0.3.1
44
45%description devel
46This package contains the include files and other resources you can
47use to incorporate libdom into applications.
48
49%description devel -l pl.UTF-8
50Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
51programach.
52
53%package static
54Summary: libdom static library
55Summary(pl.UTF-8): Statyczna biblioteka libdom
56Group: Development/Libraries
57Requires: %{name}-devel = %{version}-%{release}
58
59%description static
60This is package with static libdom library.
61
62%description static -l pl.UTF-8
63Statyczna biblioteka libdom.
64
65%prep
66%setup -q
67%patch0 -p1
68
69%build
70export CC="%{__cc}"
71export CFLAGS="%{rpmcflags}"
72export LDFLAGS="%{rpmldflags}"
73
74%{__make} \
75 Q= \
76 PREFIX=%{_prefix} \
77 LIBDIR=%{_lib} \
78 COMPONENT_TYPE=lib-shared
79
80%if %{with static_libs}
81%{__make} \
82 Q= \
83 PREFIX=%{_prefix} \
84 LIBDIR=%{_lib} \
85 COMPONENT_TYPE=lib-static
86%endif
87
88%install
89rm -rf $RPM_BUILD_ROOT
90%{__make} install \
91 Q= \
92 PREFIX=%{_prefix} \
93 LIBDIR=%{_lib} \
94 COMPONENT_TYPE=lib-shared \
95 DESTDIR=$RPM_BUILD_ROOT
96
97%if %{with static_libs}
98%{__make} install \
99 Q= \
100 PREFIX=%{_prefix} \
101 LIBDIR=%{_lib} \
102 COMPONENT_TYPE=lib-static \
103 DESTDIR=$RPM_BUILD_ROOT
104%endif
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post -p /sbin/ldconfig
110%postun -p /sbin/ldconfig
111
112%files
113%defattr(644,root,root,755)
114%doc COPYING README
115%attr(755,root,root) %{_libdir}/libdom.so.*.*.*
116%attr(755,root,root) %ghost %{_libdir}/libdom.so.0
117
118%files devel
119%defattr(644,root,root,755)
120%attr(755,root,root) %{_libdir}/libdom.so
121%{_includedir}/dom
122%{_pkgconfigdir}/libdom.pc
123
124%if %{with static_libs}
125%files static
126%defattr(644,root,root,755)
127%{_libdir}/libdom.a
128%endif
This page took 0.039859 seconds and 4 git commands to generate.