]> git.pld-linux.org Git - packages/libdigidoc.git/blob - libdigidoc.spec
edbb8a000c18e5fc58a09b144107d6bf9d608a20
[packages/libdigidoc.git] / libdigidoc.spec
1 #
2 # Conditional build:
3 %bcond_with             static_libs     # build static libraries
4
5 Summary:        XAdES digital signature standard library
6 Name:           libdigidoc
7 Version:        3.9.1.1191
8 Release:        2
9 License:        LGPL v2+
10 Group:          Libraries
11 Source0:        https://installer.id.ee/media/sources/%{name}-%{version}.tar.gz
12 # Source0-md5:  ccf88b736dda572b051b7d7fef26984d
13 URL:            http://www.ria.ee/
14 BuildRequires:  cmake
15 BuildRequires:  libxml2-devel
16 BuildRequires:  openssl-devel
17 BuildRequires:  zlib-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 DigiDoc is a generic library implementing the XAdES digital signature
22 standard. It allows to create, sign, verify, and modify digidoc XML
23 containers. Support for doing hardware cryptographic signing
24 operations is porivded via PKCS#11.
25
26 %package devel
27 Summary:        Header files and development documentation for libdigidoc
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 Header files and development documentation for libdigidoc.
33
34 %package static
35 Summary:        Static libdigidoc library
36 Group:          Development/Libraries
37 Requires:       %{name}-devel = %{version}-%{release}
38
39 %description static
40 Static libdigidoc library.
41
42 %prep
43 %setup -q
44
45 %build
46 install -d build
47 cd build
48 %cmake ..
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} -C build install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post   -p /sbin/ldconfig
60 %postun -p /sbin/ldconfig
61
62 %files
63 %defattr(644,root,root,755)
64 %doc AUTHORS README RELEASE-NOTES.txt
65 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/digidoc.conf
66 %attr(755,root,root) %{_libdir}/%{name}.so.*.*
67 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.2
68 %attr(755,root,root) %{_bindir}/cdigidoc
69 %{_mandir}/man1/cdigidoc.1*
70
71 %files devel
72 %doc doc/*
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_libdir}/%{name}.so
75 %{_includedir}/%{name}
76 %{_pkgconfigdir}/%{name}.pc
77
78 %if %{with static_libs}
79 %files static
80 %defattr(644,root,root,755)
81 %{_libdir}/libdigidoc.a
82 %endif
This page took 0.039601 seconds and 2 git commands to generate.