]> git.pld-linux.org Git - packages/libcmis.git/blob - libcmis.spec
- icu/boost rebuild
[packages/libcmis.git] / libcmis.spec
1 #
2 # Conditonal build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        A C++ client library for the CMIS interface
6 Summary(pl.UTF-8):     Biblioteka klienta C++ dla inferfejsu CMIS
7 Name:           libcmis
8 Version:        0.5.2
9 Release:        2
10 License:        GPL v2+ or LGPL v2+ or MPL v1.1
11 Group:          Libraries
12 #Source0Download: https://github.com/tdf/libcmis/releases
13 Source0:        https://github.com/tdf/libcmis/releases/download/v%{version}/%{name}-%{version}.tar.xz
14 # Source0-md5:  3653bc54e1bcd17ae09a1a7086daa38b
15 #Source0:       http://downloads.sourceforge.net/libcmis/%{name}-%{version}.tar.gz
16 URL:            http://sourceforge.net/projects/libcmis/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.10
19 BuildRequires:  boost-devel >= 1.36
20 BuildRequires:  cppunit-devel >= 1.12
21 BuildRequires:  curl-devel >= 7.12.3
22 BuildRequires:  docbook2X >= 0.8.8-4
23 BuildRequires:  libstdc++-devel >= 6:4.7
24 BuildRequires:  libtool >= 2:2
25 BuildRequires:  libxml2-devel >= 2.0
26 BuildRequires:  pkgconfig
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Requires:       curl-libs >= 7.12.3
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 LibCMIS is a C++ client library for the CMIS interface. This allows
34 C++ applications to connect to any ECM behaving as a CMIS server like
35 Alfresco, Nuxeo for the open source ones.
36
37 %description -l pl.UTF-8
38 LibCMIS to biblioteka klienta C++ dla interfejsu CMIS. Pozwala ona 
39 aplikacjom C++ na łączenie się z każdym ECM zachowującym się jako
40 serwer CMIS, taki jak Alfresco, Nuxeo (biorąc pod uwagę implementacje
41 o otwartych źródłach).
42
43 %package devel
44 Summary:        Development files for CMIS library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CMIS
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       boost-devel >= 1.36
49 Requires:       curl-devel >= 7.12.3
50 Requires:       libstdc++-devel
51 Requires:       libxml2-devel >= 2.0
52
53 %description devel
54 This package contains the header files for developing applications
55 that use CMIS library.
56
57 %description devel -l pl.UTF-8
58 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
59 bibliotece CMIS
60
61 %package static
62 Summary:        Static CMIS library
63 Summary(pl.UTF-8):      Statyczna biblioteka CMIS
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static CMIS library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka CMIS.
72
73 %package tools
74 Summary:        Command line tool to access CMIS
75 Summary(pl.UTF-8):      Narzędzie wiersza poleceń dla CMIS
76 Group:          Applications/Publishing
77 Requires:       %{name} = %{version}-%{release}
78
79 %description tools
80 This package contains a tool for accessing CMIS from the command line.
81
82 %description tools -l pl.UTF-8
83 Ten pakiet zawiera narzędzie do łączenia się do CMIS z wiersza
84 poleceń.
85
86 %prep
87 %setup -q
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__automake}
94 %configure \
95         DOCBOOK2MAN=/usr/bin/docbook2X2man \
96         --disable-silent-rules \
97         %{!?with_static_libs:--disable-static} \
98         --disable-tests \
99         --disable-werror
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 # obsoleted by pkg-config
110 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS ChangeLog NEWS
121 %attr(755,root,root) %{_libdir}/libcmis-0.5.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libcmis-0.5.so.5
123 %attr(755,root,root) %{_libdir}/libcmis-c-0.5.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libcmis-c-0.5.so.5
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/libcmis-0.5.so
129 %attr(755,root,root) %{_libdir}/libcmis-c-0.5.so
130 %{_includedir}/libcmis-0.5
131 %{_includedir}/libcmis-c-0.5
132 %{_pkgconfigdir}/libcmis-0.5.pc
133 %{_pkgconfigdir}/libcmis-c-0.5.pc
134
135 %if %{with static_libs}
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libcmis-0.5.a
139 %{_libdir}/libcmis-c-0.5.a
140 %endif
141
142 %files tools
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/cmis-client
145 %{_mandir}/man1/cmis-client.1*
This page took 0.068202 seconds and 3 git commands to generate.