]> git.pld-linux.org Git - packages/libcap.git/commitdiff
This commit was manufactured by cvs2git to create branch 'AC-branch'. AC-branch
authorcvs2git <feedback@pld-linux.org>
Sun, 10 Jan 2010 18:36:05 +0000 (18:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Sprout from master 2010-01-10 18:36:05 UTC Elan Ruusamäe <glen@pld-linux.org> '- executable shared lib for rpm autodeps'
Cherrypick from master 2004-08-03 19:18:07 UTC Jakub Bogusz <qboosh@pld-linux.org> '- don't define capget/capset functions with syscall interfaces - they are provided':
    libcap-1.92-make.patch -> 1.1
    libcap-link.patch -> 1.4

libcap-1.92-make.patch [new file with mode: 0644]
libcap-link.patch [new file with mode: 0644]

diff --git a/libcap-1.92-make.patch b/libcap-1.92-make.patch
new file mode 100644 (file)
index 0000000..26c7489
--- /dev/null
@@ -0,0 +1,16 @@
+diff -urN libcap-1.92.orig/Make.Rules libcap-1.92/Make.Rules
+--- libcap-1.92.orig/Make.Rules        Fri May 14 07:26:51 1999
++++ libcap-1.92/Make.Rules     Tue Apr 25 04:14:58 2000
+@@ -44,10 +44,10 @@
+ CC=gcc
+ COPTFLAGS=-O2
+ DEBUG=-g #-DDEBUG
+-WARNINGS=-ansi -D_POSIX_SOURCE -Wall -Wwrite-strings \
++WARNINGS=-D_POSIX_SOURCE -Wall -Wwrite-strings \
+         -Wpointer-arith -Wcast-qual -Wcast-align \
+         -Wtraditional -Wstrict-prototypes -Wmissing-prototypes \
+-        -Wnested-externs -Winline -Wshadow -pedantic
++        -Wnested-externs -Winline -Wshadow
+ LD=ld
+ LDFLAGS=-s #-g
diff --git a/libcap-link.patch b/libcap-link.patch
new file mode 100644 (file)
index 0000000..2a24355
--- /dev/null
@@ -0,0 +1,37 @@
+--- libcap-1.92/libcap/Makefile.orig   Fri Apr 23 08:15:10 1999
++++ libcap-1.92/libcap/Makefile        Tue Oct 22 23:33:28 2002
+@@ -34,12 +34,12 @@
+ #     @sed -ne '/^#define[ \t]CAP[_A-Z]\+[ \t]\+[0-9]\+/{s/^#define CAP_\([^ \t]*\)[ \t]*\([^ \t]*\)/  \{ \2, \"\1\" \},/;y/ABCDEFGHIJKLMNOPQRSTUVWXYZ/abcdefghijklmnopqrstuvwxyz/;p;}' < /usr/include/linux/capability.h | fgrep -v 0x > cap_names.sed
+ $(MINLIBNAME): $(OBJS)
+-      $(LD) -soname $(MAJLIBNAME) -x -shared -o $@ $(OBJS)
++      $(CC) -Wl,-soname -Wl,$(MAJLIBNAME) -Wl,-x -shared -o $@ $(OBJS)
+       ln -sf $(MINLIBNAME) $(MAJLIBNAME)
+       ln -sf $(MAJLIBNAME) $(LIBNAME)
+ %.o: %.c $(INCLS)
+-      $(CC) $(CFLAGS) -c $< -o $@
++      $(CC) $(CFLAGS) -fPIC -c $< -o $@
+ install: all
+       mkdir -p -m 0755 $(INCDIR)/sys
+--- libcap-1.10/libcap/cap_sys.c.orig  1999-04-18 00:16:31.000000000 +0200
++++ libcap-1.10/libcap/cap_sys.c       2004-08-03 21:06:00.506249264 +0200
+@@ -8,16 +8,8 @@
+  */
+ #include "libcap.h"
+-#define __LIBRARY__
+-#include <linux/unistd.h>
+-_syscall2(int, capget,
+-        cap_user_header_t, header,
+-        cap_user_data_t, data)
+-
+-_syscall2(int, capset,
+-        cap_user_header_t, header,
+-        const cap_user_data_t, data)
++/* capget(), capset() syscalls are defined in libc */
+ /*
+  * $Log$
This page took 1.283902 seconds and 4 git commands to generate.