]> git.pld-linux.org Git - packages/libbpg.git/blob - libbpg.spec
up to 0.9.4
[packages/libbpg.git] / libbpg.spec
1 # TODO
2 # - dynamic lib
3 Summary:        A library of functions for manipulating BPG image format files
4 Name:           libbpg
5 Version:        0.9.4
6 Release:        0.1
7 License:        LGPL v2 and BSD
8 Group:          Libraries
9 Source0:        http://bellard.org/bpg/%{name}-%{version}.tar.gz
10 # Source0-md5:  4d7ed917ce57001d5481b465fe9a1735
11 URL:            http://bellard.org/bpg/
12 BuildRequires:  libjpeg-turbo-devel
13 BuildRequires:  libpng-devel
14 BuildRequires:  libstdc++-devel
15 ExclusiveArch:  %{ix86} %{x8664}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 BPG (Better Portable Graphics) is a image format whose purpose is to
20 replace the JPEG image format when quality or file size is an issue.
21
22 Its main advantages are:
23 - High compression ratio. Files are much smaller than JPEG for similar
24   quality.
25 - Supported by most Web browsers with a small Javascript decoder.
26 - Based on a subset of the HEVC open video compression standard.
27 - Supports the same chroma formats as JPEG (grayscale, YCbCr 4:2:0,
28   4:2:2, 4:4:4) to reduce the losses during the conversion. An alpha
29   channel is supported. The RGB, YCgCo and CMYK color spaces are also
30   supported.
31 - Native support of 8 to 14 bits per channel for a higher dynamic
32   range.
33 - Lossless compression is supported.
34 - Various metadata (such as EXIF, ICC profile, XMP) can be included.
35
36 %package devel
37 Summary:        Development files for %{name}
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 The %{name}-devel package contains libraries and header files for
43 developing applications that use %{name}.
44
45 %prep
46 %setup -q
47
48 %{__sed} -i -e 's,-Os,$(OPTFLAGS),' Makefile
49 %{__sed} -i -e 's#LDFLAGS=-g#LDFLAGS=%{rpmldflags}#' Makefile
50
51 %build
52 %{__make} \
53         CC="%{__cc}" \
54         CXX="%{__cxx}" \
55         OPTFLAGS="%{rpmcflags}" \
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
60 install -p bpgdec bpgenc $RPM_BUILD_ROOT%{_bindir}
61 cp -p bpgenc.h libbpg.h $RPM_BUILD_ROOT%{_includedir}
62 cp -p libbpg.a $RPM_BUILD_ROOT%{_libdir}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc doc html post.js
70 %attr(755,root,root) %{_bindir}/bpgdec
71 %attr(755,root,root) %{_bindir}/bpgenc
72
73 %files devel
74 %defattr(644,root,root,755)
75 %{_includedir}/bpgenc.h
76 %{_includedir}/libbpg.h
77 %{_libdir}/libbpg.a
This page took 0.135404 seconds and 3 git commands to generate.