]> git.pld-linux.org Git - packages/libbluray.git/commitdiff
upstream patch to fix build with latest java releases
authorJan Palus <atler@pld-linux.org>
Sat, 21 May 2022 12:40:38 +0000 (14:40 +0200)
committerJan Palus <atler@pld-linux.org>
Sat, 21 May 2022 12:40:38 +0000 (14:40 +0200)
java.patch [new file with mode: 0644]
libbluray.spec

diff --git a/java.patch b/java.patch
new file mode 100644 (file)
index 0000000..41f858c
--- /dev/null
@@ -0,0 +1,34 @@
+From 8f26777b1ce124ff761f80ef52d6be10bcea323e Mon Sep 17 00:00:00 2001
+From: Fridrich Strba <fstrba@suse.com>
+Date: Mon, 25 Apr 2022 14:28:58 +0300
+Subject: [PATCH] Fix build failure after Oracle Java CPU for April 2022
+
+---
+ src/libbluray/bdj/java/java/io/BDFileSystem.java | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/src/libbluray/bdj/java/java/io/BDFileSystem.java b/src/libbluray/bdj/java/java/io/BDFileSystem.java
+index 03add5d1..fabe57bc 100644
+--- a/src/libbluray/bdj/java/java/io/BDFileSystem.java
++++ b/src/libbluray/bdj/java/java/io/BDFileSystem.java
+@@ -227,6 +227,17 @@ public abstract class BDFileSystem extends FileSystem {
+         return fs.isAbsolute(f);
+     }
++    public boolean isInvalid(File f) {
++        try {
++            Method m = fs.getClass().getDeclaredMethod("isInvalid", new Class[] { File.class });
++            Object[] args = new Object[] {(Object)f};
++            Boolean result = (Boolean)m.invoke(fs, args);
++            return result.booleanValue();
++        } finally {
++            return false;
++        }
++    }
++
+     public String resolve(File f) {
+         if (!booted)
+             return fs.resolve(f);
+-- 
+GitLab
+
index d6816a729e1e0801f5af4154771c5a0aa5e0c3b9..121bd72c8c6425384b5bd638e36e9f481da4dff8 100644 (file)
@@ -12,6 +12,7 @@ License:      LGPL v2+
 Group:         Libraries
 Source0:       https://download.videolan.org/videolan/libbluray/%{version}/%{name}-%{version}.tar.bz2
 # Source0-md5: 55d69915d56d491637b8378ca54c3b7a
+Patch0:                java.patch
 URL:           http://www.videolan.org/developers/libbluray.html
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -92,6 +93,7 @@ Klasy obsługujące BD-Java dla libbluray.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
This page took 0.680048 seconds and 4 git commands to generate.