]> git.pld-linux.org Git - packages/libaio.git/blob - libaio.spec
- fix building on x32
[packages/libaio.git] / libaio.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make partcheck
4 #
5 Summary:        Linux-native asynchronous I/O access library
6 Summary(pl.UTF-8):      Biblioteka natywnego dla Linuksa asynchronicznego dostępu do wejścia/wyjścia
7 Name:           libaio
8 Version:        0.3.109
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        ftp://ftp.kernel.org/pub/linux/libs/aio/%{name}-%{version}.tar.gz
13 # Source0-md5:  435a5b16ca6198eaf01155263d855756
14 Patch0:         %{name}-DESTDIR.patch
15 Patch1:         %{name}-Werror.patch
16 Patch2:         x32.patch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The Linux-native asynchronous I/O facility ("async I/O", or "aio") has
21 a richer API and capability set than the simple POSIX async I/O
22 facility.
23
24 This library, libaio, provides the Linux-native API for async I/O. The
25 POSIX async I/O facility requires this library in order to provide
26 kernel-accelerated async I/O capabilities, as do applications which
27 require the Linux-native async I/O API.
28
29 %description -l pl.UTF-8
30 Natywna dla Linuksa obsługa asynchronicznego wejścia/wyjścia ("async
31 I/O" lub "aio") ma bogatsze API i zestaw możliwości niż proste
32 asynchroniczne wejście/wyjście zgodne z POSIX.
33
34 Ta biblioteka - libaio - udostępnia natywne Linuksowe API dla
35 asynchronicznego we/wy. Zgodne z POSIX asynchroniczne we/wy wymaga tej
36 biblioteki do udostępnienia przyspieszanych przez jądro możliwości
37 asynchronicznego we/wy, podobnie jak aplikacje wymagające natywnego
38 dla Linuksa API asynchronicznego we/wy.
39
40 %package devel
41 Summary:        Header files for libaio library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libaio
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for libaio library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki libaio.
51
52 %package static
53 Summary:        Static libaio library
54 Summary(pl.UTF-8):      Statyczna biblioteka libaio
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static libaio library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libaio.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 %patch1 -p1
68 %patch2 -p1
69
70 %build
71 %{__make} \
72         CC="%{__cc}" \
73         CFLAGS="%{rpmcppflags} %{rpmcflags} -fomit-frame-pointer -fPIC -Wall -I. -nostdlib -nostartfiles"
74
75 %{?with_tests:%{__make} CC="%{__cc}" partcheck}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT/%{_lib}
80
81 %{__make} install \
82         libdir=/%{_lib} \
83         usrlibdir=%{_libdir} \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 # omit some manuals:
87 # man2/io_* already included in man-pages
88 # some man3/aio_* already included in glibc-devel-doc (from man-pages)
89 install -d $RPM_BUILD_ROOT%{_mandir}/man3
90 cp -a man/aio{,_cancel64,_error64,_fsync64,_init,_read64,_return64,_suspend64,_write64}.3 $RPM_BUILD_ROOT%{_mandir}/man3
91 cp -a man/io*.3 $RPM_BUILD_ROOT%{_mandir}/man3
92 cp -a man/lio*.3 $RPM_BUILD_ROOT%{_mandir}/man3
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc ChangeLog TODO
103 %attr(755,root,root) /%{_lib}/libaio.so.*.*.*
104 %attr(755,root,root) %ghost /%{_lib}/libaio.so.1
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libaio.so
109 %{_includedir}/libaio.h
110 %{_mandir}/man3/aio*.3*
111 %{_mandir}/man3/io*.3*
112 %{_mandir}/man3/lio_*.3*
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libaio.a
This page took 0.148068 seconds and 3 git commands to generate.