]> git.pld-linux.org Git - packages/libaio.git/blob - libaio.spec
63057251f5d5c099822062e200314e363f734ec2
[packages/libaio.git] / libaio.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make partcheck
4 #
5 Summary:        Linux-native asynchronous I/O access library
6 Summary(pl.UTF-8):      Biblioteka natywnego dla Linuksa asynchronicznego dostępu do wejścia/wyjścia
7 Name:           libaio
8 Version:        0.3.109
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        ftp://ftp.kernel.org/pub/linux/libs/aio/%{name}-%{version}.tar.gz
13 # Source0-md5:  435a5b16ca6198eaf01155263d855756
14 Patch0:         %{name}-DESTDIR.patch
15 Patch1:         %{name}-Werror.patch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 The Linux-native asynchronous I/O facility ("async I/O", or "aio") has
20 a richer API and capability set than the simple POSIX async I/O
21 facility.
22
23 This library, libaio, provides the Linux-native API for async I/O. The
24 POSIX async I/O facility requires this library in order to provide
25 kernel-accelerated async I/O capabilities, as do applications which
26 require the Linux-native async I/O API.
27
28 %description -l pl.UTF-8
29 Natywna dla Linuksa obsługa asynchronicznego wejścia/wyjścia ("async
30 I/O" lub "aio") ma bogatsze API i zestaw możliwości niż proste
31 asynchroniczne wejście/wyjście zgodne z POSIX.
32
33 Ta biblioteka - libaio - udostępnia natywne Linuksowe API dla
34 asynchronicznego we/wy. Zgodne z POSIX asynchroniczne we/wy wymaga tej
35 biblioteki do udostępnienia przyspieszanych przez jądro możliwości
36 asynchronicznego we/wy, podobnie jak aplikacje wymagające natywnego
37 dla Linuksa API asynchronicznego we/wy.
38
39 %package devel
40 Summary:        Header files for libaio library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libaio
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for libaio library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki libaio.
50
51 %package static
52 Summary:        Static libaio library
53 Summary(pl.UTF-8):      Statyczna biblioteka libaio
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static libaio library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka libaio.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 %patch1 -p1
67
68 %build
69 %{__make} \
70         CC="%{__cc}" \
71         CFLAGS="%{rpmcppflags} %{rpmcflags} -fomit-frame-pointer -fPIC -Wall -I. -nostdlib -nostartfiles"
72
73 %{?with_tests:%{__make} CC="%{__cc}" partcheck}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT/%{_lib}
78
79 %{__make} install \
80         libdir=/%{_lib} \
81         usrlibdir=%{_libdir} \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 # omit some manuals:
85 # man2/io_* already included in man-pages
86 # some man3/aio_* already included in glibc-devel-doc (from man-pages)
87 install -d $RPM_BUILD_ROOT%{_mandir}/man3
88 cp -a man/aio{,_cancel64,_error64,_fsync64,_init,_read64,_return64,_suspend64,_write64}.3 $RPM_BUILD_ROOT%{_mandir}/man3
89 cp -a man/io*.3 $RPM_BUILD_ROOT%{_mandir}/man3
90 cp -a man/lio*.3 $RPM_BUILD_ROOT%{_mandir}/man3
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc ChangeLog TODO
101 %attr(755,root,root) /%{_lib}/libaio.so.*.*.*
102 %attr(755,root,root) %ghost /%{_lib}/libaio.so.1
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libaio.so
107 %{_includedir}/libaio.h
108 %{_mandir}/man3/aio*.3*
109 %{_mandir}/man3/io*.3*
110 %{_mandir}/man3/lio_*.3*
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libaio.a
This page took 0.036747 seconds and 2 git commands to generate.