]> git.pld-linux.org Git - packages/libafdt.git/blob - libafdt.spec
- link libafdt with libevent
[packages/libafdt.git] / libafdt.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  tests           # skip tests
6
7 Summary:        LIBrary for Asynchronous File Descriptor Transfer
8 Name:           libafdt
9 Version:        0.1.0
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/project/libafdt/%{name}-%{version}.tar.gz
14 # Source0-md5:  8051b4e88c5804ce34e221cb62c5e672
15 URL:            http://libafdt.sourceforge.net/
16 %{?with_apidocs:BuildRequires:  doxygen}
17 BuildRequires:  libevent-devel >= 1.4.5
18 %{?with_tests:BuildRequires:    python}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 libafdt is a library for "a"synchronous "f"ile "d"escriptor
23 "t"ransfers. It provides a simple interface that allows libevent-based
24 programs to set up a Unix domain socket to accept connections and
25 transfer file descriptors to clients, or to be a client and request a
26 file descriptor from a libafdt server. Low-level and synchronous
27 interfaces are also provided for programs that do not use libevent.
28
29 %package devel
30 Summary:        Header files for libafdt library
31 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libafdt
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Header files for libafdt library.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe biblioteki libafdt.
40
41 %package static
42 Summary:        Static libafdt library
43 Summary(pl.UTF-8):      Statyczna biblioteka libafdt
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}-%{release}
46
47 %description static
48 Static libafdt library.
49
50 %description static -l pl.UTF-8
51 Statyczna biblioteka libafdt.
52
53 %package apidocs
54 Summary:        libafdt API documentation
55 Summary(pl.UTF-8):      Dokumentacja API biblioteki libafdt
56 Group:          Documentation
57
58 %description apidocs
59 API and internal documentation for libafdt library.
60
61 %description apidocs -l pl.UTF-8
62 Dokumentacja API biblioteki libafdt.
63
64 %prep
65 %setup -q
66
67 %build
68 %configure \
69         --enable-shared \
70         %{!?with_static_libs:--disable-static}
71
72 %{__make}
73
74 %{?with_tests:%{__make} check}
75
76 %{?with_apidocs:doxygen}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README
92 %attr(755,root,root) %{_libdir}/libafdt.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libafdt.so.0
94
95 %files devel
96 %defattr(644,root,root,755)
97 %{_libdir}/libafdt.so
98 %{_libdir}/libafdt.la
99 %{_includedir}/afdt.h
100
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libafdt.a
104
105 %if %{with apidocs}
106 %files apidocs
107 %defattr(644,root,root,755)
108 %doc doxygen-out/html/*
109 %endif
This page took 0.10644 seconds and 3 git commands to generate.