]> git.pld-linux.org Git - packages/libafdt.git/blob - libafdt.spec
4631067b5f226d507c9384c3587fe6278d536eb7
[packages/libafdt.git] / libafdt.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  tests           # skip tests
6
7 Summary:        LIBrary for Asynchronous File Descriptor Transfer
8 Name:           libafdt
9 Version:        0.1.0
10 Release:        4
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/libafdt/%{name}-%{version}.tar.gz
14 # Source0-md5:  8051b4e88c5804ce34e221cb62c5e672
15 URL:            http://facebook.github.io/libafdt/
16 Patch0:         %{name}-link.patch
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 %{?with_apidocs:BuildRequires:  doxygen}
20 BuildRequires:  libevent-devel >= 1.4.5
21 BuildRequires:  libtool
22 %{?with_tests:BuildRequires:    python}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 libafdt is a library for "a"synchronous "f"ile "d"escriptor
27 "t"ransfers. It provides a simple interface that allows libevent-based
28 programs to set up a Unix domain socket to accept connections and
29 transfer file descriptors to clients, or to be a client and request a
30 file descriptor from a libafdt server. Low-level and synchronous
31 interfaces are also provided for programs that do not use libevent.
32
33 %package devel
34 Summary:        Header files for libafdt library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libafdt
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for libafdt library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki libafdt.
44
45 %package static
46 Summary:        Static libafdt library
47 Summary(pl.UTF-8):      Statyczna biblioteka libafdt
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static libafdt library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka libafdt.
56
57 %package apidocs
58 Summary:        libafdt API documentation
59 Summary(pl.UTF-8):      Dokumentacja API biblioteki libafdt
60 Group:          Documentation
61 %if "%{_rpmversion}" >= "5"
62 BuildArch:      noarch
63 %endif
64
65 %description apidocs
66 API and internal documentation for libafdt library.
67
68 %description apidocs -l pl.UTF-8
69 Dokumentacja API biblioteki libafdt.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74
75 %build
76 %{__libtoolize}
77 %{__aclocal} -I m4
78 %{__autoconf}
79 %{__automake}
80 %configure \
81         --enable-shared \
82         %{!?with_static_libs:--disable-static}
83
84 %{__make}
85
86 %{?with_tests:%{__make} check}
87
88 %{?with_apidocs:doxygen}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc README
104 %attr(755,root,root) %{_libdir}/libafdt.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libafdt.so.0
106
107 %files devel
108 %defattr(644,root,root,755)
109 %{_libdir}/libafdt.so
110 %{_libdir}/libafdt.la
111 %{_includedir}/afdt.h
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libafdt.a
116
117 %if %{with apidocs}
118 %files apidocs
119 %defattr(644,root,root,755)
120 %doc doxygen-out/html/*
121 %endif
This page took 0.151235 seconds and 2 git commands to generate.