]> git.pld-linux.org Git - packages/lftp.git/commitdiff
- rel 2; fix mirror segfault auto/th/lftp-4.7.2-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 24 Jun 2016 15:54:08 +0000 (17:54 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 24 Jun 2016 15:54:08 +0000 (17:54 +0200)
lftp-bug-250.patch [new file with mode: 0644]
lftp.spec

diff --git a/lftp-bug-250.patch b/lftp-bug-250.patch
new file mode 100644 (file)
index 0000000..78d7277
--- /dev/null
@@ -0,0 +1,22 @@
+From f94bf44ec4bbd5511302e8a0d76bde881c9f0211 Mon Sep 17 00:00:00 2001
+From: "Alexander V. Lukyanov" <lavv17f@gmail.com>
+Date: Fri, 24 Jun 2016 18:26:28 +0300
+Subject: [PATCH] fish: fixed #250 - a segfault in ARRAY_INFO mode.
+
+---
+ src/Fish.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Fish.cc b/src/Fish.cc
+index a634927..0d8a91c 100644
+--- a/src/Fish.cc
++++ b/src/Fish.cc
+@@ -394,7 +394,7 @@ void Fish::SendArrayInfoRequests()
+ void Fish::SendMethod()
+ {
+-   const char *e=alloca_strdup(shell_encode(file));
++   const char *e=file?alloca_strdup(shell_encode(file)):0;
+    const char *e1=shell_encode(file1);
+    switch((open_mode)mode)
+    {
index 7f5b86dd454af2716c85cc98b81c8db8ee22aea8..84251e7628be342c664e2cd517a53d8b86fb7f45 100644 (file)
--- a/lftp.spec
+++ b/lftp.spec
@@ -24,7 +24,7 @@ Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (client
 Summary(zh_CN.UTF-8):  lftp 客户端程序
 Name:          lftp
 Version:       4.7.2
-Release:       1
+Release:       2
 License:       GPL v3+
 Group:         Applications/Networking
 Source0:       http://lftp.yar.ru/ftp/%{name}-%{version}.tar.xz
@@ -40,6 +40,7 @@ Patch2:               aliases.patch
 # when updated attach at https://github.com/lavv17/lftp/issues
 Patch3:                %{name}-pl.po-update.patch
 Patch4:                %{name}-am.patch
+Patch5:                lftp-bug-250.patch
 URL:           http://lftp.yar.ru/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
@@ -97,6 +98,7 @@ o arquivo FEATURES para uma lista mais detalhada.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %{__rm} po/stamp-po
 
This page took 0.029838 seconds and 4 git commands to generate.