]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- up to 4.0.8
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
18 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
19 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN.UTF-8):   lftp 客户端程序
21 Name:           lftp
22 Version:        4.0.8
23 Release:        1
24 License:        GPL v3+
25 Group:          Applications/Networking
26 Source0:        http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.lzma
27 # Source0-md5:  a8900b3481b1f8e2be7f01e6acfedbae
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Source3:        %{name}-icon.png
32 Patch0:         %{name}-home_etc.patch
33 Patch1:         %{name}-makefile.patch
34 # ALWAYS send updated patch to lftp mailing lists
35 Patch2:         %{name}-pl.po-update.patch
36 Patch3:         %{name}-m4.patch
37 URL:            http://lftp.yar.ru/
38 BuildRequires:  autoconf >= 2.60
39 BuildRequires:  automake
40 BuildRequires:  gettext-devel >= 0.14.2
41 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
42 BuildRequires:  libstdc++-devel
43 BuildRequires:  libtool >= 1:1.4.2-9
44 BuildRequires:  ncurses-devel >= 5.2
45 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
46 BuildRequires:  pkgconfig
47 BuildRequires:  readline-devel >= 4.2
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
51 %if %{_gcc_ver} == 2
52 %define         __cxx           "%{__cc}"
53 %endif
54
55 %description
56 LFTP is a shell-like command line FTP/HTTP client. The main two
57 advantages over other FTP clients are reliability and ability to
58 perform tasks in background. It will reconnect and reget the file
59 being transferred if the connection broke. You can start a transfer in
60 background and continue browsing on the FTP site. It does this all in
61 one process. When you have started background jobs and feel you are
62 done, you can just exit lftp and it automatically moves to nohup mode
63 and completes the transfers. It has also such nice features as reput
64 and mirror.
65
66 %description -l pl.UTF-8
67 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
68 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
69 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
70 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
71 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
72 jako aplikacja do mirrorowania serwerów FTP.
73
74 %description -l pt_BR.UTF-8
75 O lftp é um programa de transferência de arquivos por linha de
76 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
77 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
78 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
79 o arquivo FEATURES para uma lista mais detalhada.
80
81 %prep
82 %setup -q
83 #%%patch0 -p1
84 %patch1 -p1
85 #%patch2 -p1
86 %patch3 -p1
87
88 rm -f po/stamp-po
89
90 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
91
92 %build
93 %{__libtoolize}
94 %{__gettextize}
95 %{__aclocal} -I m4
96 %{__autoconf}
97 %{__automake}
98 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
99 %configure \
100         --with-modules \
101         --with%{!?with_openssl:out}-openssl \
102         --with%{!?with_gnutls:out}-gnutls
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
114 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
115 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
116
117 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
118 rm -f $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
119 rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
120
121 %find_lang %{name}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
132 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
133 %attr(755,root,root) %{_bindir}/lftp
134 %attr(755,root,root) %{_bindir}/lftpget
135 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
137 %dir %{_libdir}/lftp
138 %attr(755,root,root) %{_libdir}/lftp/*.so
139 %attr(755,root,root) %{_datadir}/lftp
140 %{_mandir}/man1/lftp.1*
141 %{_mandir}/man1/lftpget.1*
142 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
143 %{_desktopdir}/lftp.desktop
144 %{_pixmapsdir}/lftp.png
This page took 0.085112 seconds and 4 git commands to generate.