]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- added pl.po-update patch
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
18 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
19 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN.UTF-8):   lftp 客户端程序
21 Name:           lftp
22 Version:        4.3.0
23 Release:        1
24 License:        GPL v3+
25 Group:          Applications/Networking
26 Source0:        http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
27 # Source0-md5:  ae32e290b096d50856129b45a99411dc
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Source3:        %{name}-icon.png
32 # outdated and nobody cared for 8+ years... will be dropped
33 Patch0:         %{name}-home_etc.patch
34 Patch1:         %{name}-makefile.patch
35 Patch2:         %{name}-m4.patch
36 Patch3:         aliases.patch
37 Patch4:         %{name}-pl.po-update.patch
38 URL:            http://lftp.yar.ru/
39 BuildRequires:  autoconf >= 2.60
40 BuildRequires:  automake
41 BuildRequires:  gettext-devel >= 0.14.2
42 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool >= 1:1.4.2-9
45 BuildRequires:  ncurses-devel >= 5.2
46 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
47 BuildRequires:  pkgconfig
48 BuildRequires:  readline-devel >= 4.2
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  xz
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
54 %if %{_gcc_ver} == 2
55 %define         __cxx           "%{__cc}"
56 %endif
57
58 %description
59 LFTP is a shell-like command line FTP/HTTP client. The main two
60 advantages over other FTP clients are reliability and ability to
61 perform tasks in background. It will reconnect and reget the file
62 being transferred if the connection broke. You can start a transfer in
63 background and continue browsing on the FTP site. It does this all in
64 one process. When you have started background jobs and feel you are
65 done, you can just exit lftp and it automatically moves to nohup mode
66 and completes the transfers. It has also such nice features as reput
67 and mirror.
68
69 %description -l pl.UTF-8
70 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
71 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
72 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
73 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
74 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
75 jako aplikacja do mirrorowania serwerów FTP.
76
77 %description -l pt_BR.UTF-8
78 O lftp é um programa de transferência de arquivos por linha de
79 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
80 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
81 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
82 o arquivo FEATURES para uma lista mais detalhada.
83
84 %prep
85 %setup -q
86 #%%patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p1
90 %patch4 -p1
91
92 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
93
94 %build
95 %{__libtoolize}
96 %{__gettextize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__automake}
100 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
101 %configure \
102         --with-modules \
103         --with%{!?with_openssl:out}-openssl \
104         --with%{!?with_gnutls:out}-gnutls
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
115 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
116 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
117
118 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
119 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
121
122 %find_lang %{name}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files -f %{name}.lang
131 %defattr(644,root,root,755)
132 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
133 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
134 %attr(755,root,root) %{_bindir}/lftp
135 %attr(755,root,root) %{_bindir}/lftpget
136 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
138 %dir %{_libdir}/lftp
139 %attr(755,root,root) %{_libdir}/lftp/*.so
140 %attr(755,root,root) %{_datadir}/lftp
141 %{_mandir}/man1/lftp.1*
142 %{_mandir}/man1/lftpget.1*
143 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
144 %{_mandir}/man5/lftp.conf.5*
145 %{_desktopdir}/lftp.desktop
146 %{_pixmapsdir}/lftp.png
This page took 1.626156 seconds and 4 git commands to generate.