]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- rebuild with expat 2.1.0
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
18 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
19 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN.UTF-8):   lftp 客户端程序
21 Name:           lftp
22 Version:        4.4.0
23 Release:        2
24 License:        GPL v3+
25 Group:          Applications/Networking
26 Source0:        http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
27 # Source0-md5:  b057e3e01686a200c35753c3496c2130
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Source3:        %{name}-icon.png
32 Patch0:         %{name}-makefile.patch
33 Patch1:         %{name}-m4.patch
34 Patch2:         aliases.patch
35 # maintained by me, sent upstream from time to time  --qboosh
36 Patch3:         %{name}-pl.po-update.patch
37 Patch4:         lftp-4.3.8-gets.patch
38 URL:            http://lftp.yar.ru/
39 BuildRequires:  autoconf >= 2.60
40 BuildRequires:  automake
41 BuildRequires:  expat-devel
42 BuildRequires:  gettext-devel >= 0.14.2
43 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  libtool >= 1:1.4.2-9
46 BuildRequires:  ncurses-devel >= 5.2
47 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
48 BuildRequires:  pkgconfig
49 BuildRequires:  readline-devel >= 4.2
50 BuildRequires:  tar >= 1:1.22
51 BuildRequires:  xz
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
55 %if %{_gcc_ver} == 2
56 %define         __cxx           "%{__cc}"
57 %endif
58
59 %description
60 LFTP is a shell-like command line FTP/HTTP client. The main two
61 advantages over other FTP clients are reliability and ability to
62 perform tasks in background. It will reconnect and reget the file
63 being transferred if the connection broke. You can start a transfer in
64 background and continue browsing on the FTP site. It does this all in
65 one process. When you have started background jobs and feel you are
66 done, you can just exit lftp and it automatically moves to nohup mode
67 and completes the transfers. It has also such nice features as reput
68 and mirror.
69
70 %description -l pl.UTF-8
71 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
72 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
73 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
74 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
75 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
76 jako aplikacja do mirrorowania serwerów FTP.
77
78 %description -l pt_BR.UTF-8
79 O lftp é um programa de transferência de arquivos por linha de
80 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
81 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
82 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
83 o arquivo FEATURES para uma lista mais detalhada.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p1
90 %patch3 -p1
91 %patch4 -p1
92
93 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
94
95 %build
96 %{__libtoolize}
97 %{__gettextize}
98 %{__aclocal} -I m4
99 %{__autoconf}
100 %{__automake}
101 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
102 %configure \
103         --with-modules \
104         --with%{!?with_openssl:out}-openssl \
105         --with%{!?with_gnutls:out}-gnutls
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
116 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
117 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
118
119 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
120 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
122
123 %find_lang %{name}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files -f %{name}.lang
132 %defattr(644,root,root,755)
133 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
134 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
135 %attr(755,root,root) %{_bindir}/lftp
136 %attr(755,root,root) %{_bindir}/lftpget
137 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
139 %dir %{_libdir}/lftp
140 %attr(755,root,root) %{_libdir}/lftp/*.so
141 %attr(755,root,root) %{_datadir}/lftp
142 %{_mandir}/man1/lftp.1*
143 %{_mandir}/man1/lftpget.1*
144 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
145 %{_mandir}/man5/lftp.conf.5*
146 %{_desktopdir}/lftp.desktop
147 %{_pixmapsdir}/lftp.png
This page took 0.316684 seconds and 4 git commands to generate.