]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- upcoming 3.0.0 snapshot
[packages/lftp.git] / lftp.spec
1 #
2 # Conditional build:
3 %bcond_without ssl      # do not use SSL
4 #
5 %define snap    20040325
6 Summary:        Sophisticated command line ftp/http client
7 Summary(ko):    ¸í·ÉÁÙ¿¡¼­ µ¹¾Æ°¡´Â ftp/http Å¬¶óÀ̾ðÆ®
8 Summary(pl):    Zaawansowany klient ftp/http
9 Summary(pt_BR): Sofisticado programa de transferência de arquivos (cliente ftp/http)
10 Summary(zh_CN): lftp ¿Í»§¶Ë³ÌÐò
11 Name:           lftp
12 Version:        3.0.0
13 Release:        0.%{snap}.1
14 License:        GPL
15 Group:          Applications/Networking
16 Source0:        ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/devel/%{name}-pre%{version}-%{snap}.tar.gz
17 # Source0-md5:  38761cf75535f4eda16b8ca98104df98
18 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
19 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
20 Source2:        %{name}.desktop
21 Patch0:         %{name}-home_etc.patch
22 Icon:           ftp.gif
23 URL:            http://lftp.yar.ru/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  gettext-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  sed >= 4.0.0
29 BuildRequires:  libtool >= 1:1.4.2-9
30 BuildRequires:  ncurses-devel >= 5.2
31 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
32 BuildRequires:  readline-devel >= 4.2
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
36 %if %{_gcc_ver} == 2
37 %define         __cxx           "%{__cc}"
38 %endif
39
40 %description
41 LFTP is a shell-like command line ftp/http client. The main two
42 advantages over other ftp clients are reliability and ability to
43 perform tasks in background. It will reconnect and reget the file
44 being transferred if the connection broke. You can start a transfer in
45 background and continue browsing on the ftp site. It does this all in
46 one process. When you have started background jobs and feel you are
47 done, you can just exit lftp and it automatically moves to nohup mode
48 and completes the transfers. It has also such nice features as reput
49 and mirror.
50
51 %description -l pl
52 Lftp jest zaawansowanym klientem ftp/http. Potrafi automatycznie
53 po³±czyæ siê z serwerem ftp po zerwanym po³±czeniu i dokoñczyæ
54 ¶ci±ganie archiwów. Lftp mo¿e pracowaæ w tle i nie zrywa przy tym
55 po³±czenia po tym jak siê wylogujesz. Program ten honoruje komendy
56 pow³oki podczas sesji, np. `ls -al | less` itp. Doskonale siê spisuje
57 jako aplikacja do mirrorowania serwerów FTP.
58
59 %description -l pt_BR
60 O lftp é um programa de transferência de arquivos por linha de
61 comando. Ele suporta os protocolos ftp/http. Suporta: proxy ftp, proxy
62 http, ftp sobre http, opie/skey, transferências fxp, repetição de
63 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
64 o arquivo FEATURES para uma lista mais detalhada.
65
66 %prep
67 %setup -q -n %{name}-pre%{version}-%{snap}
68 #%patch0 -p1
69
70 %build
71 sed -i -e 's#pkgverlibdir.*=.*#pkgverlibdir = $(pkglibdir)#g' src/Makefile*
72 %{__libtoolize}
73 %{__gettextize}
74 %{__aclocal} -I m4
75 %{__autoconf}
76 %{__automake}
77 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
78 %configure \
79         --with-modules \
80         --with%{!?with_ssl:out}-ssl
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
91 install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
92 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
93
94 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
95
96 %find_lang %{name}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files -f %{name}.lang
102 %defattr(644,root,root,755)
103 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
104 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/lftp.conf
105 %attr(755,root,root) %{_bindir}/*
106 %dir %{_libdir}/lftp
107 %attr(755,root,root) %{_libdir}/lftp/cmd*.so
108 %attr(755,root,root) %{_libdir}/lftp/lib*.so
109 %attr(755,root,root) %{_libdir}/lftp/proto-*.so
110 %attr(755,root,root) %{_datadir}/lftp
111 %{_mandir}/man1/*
112 %lang(pl) %{_mandir}/pl/man1/*
113 %{_desktopdir}/lftp.desktop
114 %{_pixmapsdir}/lftp.png
This page took 0.078352 seconds and 4 git commands to generate.