]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- moved .desktop file to %%{_desktopdir}
[packages/lftp.git] / lftp.spec
1 #
2 # Conditional build:
3 # _without_ssl - do not use SSL
4 #
5 Summary:        Sophisticated command line ftp/http client
6 Summary(ko):    ¸í·ÉÁÙ¿¡¼­ µ¹¾Æ°¡´Â ftp/http Å¬¶óÀ̾ðÆ®
7 Summary(pl):    Zaawansowany klient ftp/http
8 Summary(pt_BR): Sofisticado programa de transferência de arquivos (cliente ftp/http)
9 Summary(zh_CN): lftp ¿Í»§¶Ë³ÌÐò
10 Name:           lftp
11 Version:        2.6.9
12 Release:        2
13 License:        GPL
14 Group:          Applications/Networking
15 Source0:        ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/%{name}-%{version}.tar.bz2
16 # Source0-md5:  34ae6b74b003e99ccae4dd82122192ed
17 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
18 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
19 Source2:        %{name}.desktop
20 Patch0:         %{name}-amfix.patch
21 Patch1:         %{name}-pl.po-update.patch
22 Patch2:         %{name}-no_pkgverlibdir.patch
23 Patch3:         %{name}-home_etc.patch
24 Patch4:         %{name}-acfix.patch
25 Icon:           ftp.gif
26 URL:            http://lftp.yar.ru/
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  gettext-devel
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtool >= 1:1.4.2-9
32 BuildRequires:  ncurses-devel >= 5.2
33 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.7c}
34 BuildRequires:  readline-devel >= 4.2
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
38 %if %{_gcc_ver} == 2
39 %define         __cxx           "%{__cc}"
40 %endif
41
42 %description
43 LFTP is a shell-like command line ftp/http client. The main two
44 advantages over other ftp clients are reliability and ability to
45 perform tasks in background. It will reconnect and reget the file
46 being transferred if the connection broke. You can start a transfer in
47 background and continue browsing on the ftp site. It does this all in
48 one process. When you have started background jobs and feel you are
49 done, you can just exit lftp and it automatically moves to nohup mode
50 and completes the transfers. It has also such nice features as reput
51 and mirror.
52
53 %description -l pl
54 Lftp jest zaawansowanym klientem ftp/http. Potrafi automatycznie
55 po³±czyæ siê z serwerem ftp po zerwanym po³±czeniu i dokoñczyæ
56 ¶ci±ganie archiwów. Lftp mo¿e pracowaæ w tle i nie zrywa przy tym
57 po³±czenia po tym jak siê wylogujesz. Program ten honoruje komendy
58 pow³oki podczas sesji, np. `ls -al | less` itp. Doskonale siê spisuje
59 jako aplikacja do mirrorowania serwerów FTP.
60
61 %description -l pt_BR
62 O lftp é um programa de transferência de arquivos por linha de
63 comando. Ele suporta os protocolos ftp/http. Suporta: proxy ftp, proxy
64 http, ftp sobre http, opie/skey, transferências fxp, repetição de
65 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
66 o arquivo FEATURES para uma lista mais detalhada.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71 %patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74 %patch4 -p1
75
76 %build
77 %{__libtoolize}
78 %{__gettextize}
79 %{__aclocal} -I m4
80 %{__autoconf}
81 %{__automake}
82 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
83 %configure \
84         --with-modules \
85         --with%{?_without_ssl:out}-ssl
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
96 install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
97 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
98
99 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
100
101 %find_lang %{name}
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files -f %{name}.lang
107 %defattr(644,root,root,755)
108 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
109 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/lftp.conf
110 %attr(755,root,root) %{_bindir}/*
111 %dir %{_libdir}/lftp
112 %attr(755,root,root) %{_libdir}/lftp/cmd-mirror.so
113 %attr(755,root,root) %{_libdir}/lftp/cmd-sleep.so
114 %attr(755,root,root) %{_libdir}/lftp/libnetwork.so
115 %attr(755,root,root) %{_libdir}/lftp/proto-file.so
116 %attr(755,root,root) %{_libdir}/lftp/proto-fish.so
117 %attr(755,root,root) %{_libdir}/lftp/proto-ftp.so
118 %attr(755,root,root) %{_libdir}/lftp/proto-http.so
119 %attr(755,root,root) %{_datadir}/lftp
120 %{_mandir}/man1/*
121 %lang(pl) %{_mandir}/pl/man1/*
122 %{_desktopdir}/lftp.desktop
123 %{_pixmapsdir}/lftp.png
This page took 0.055792 seconds and 3 git commands to generate.