]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- rel 2; fix mirror segfault
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7 # better just preload it instead forcing linking
8 %bcond_with     dante   # Dante-based SOCKS support
9 # broken currently https://www.dnssec-tools.org/trac/ticket/173
10 %bcond_with     dnssec  # DNSSEC local validation
11 #
12 %if %{with ssl}
13 %define with_openssl 1
14 %endif
15
16 %if %{with gnutls} && %{with ssl}
17 %undefine with_openssl
18 %endif
19
20 Summary:        Sophisticated command line FTP/HTTP client
21 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
22 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
23 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
24 Summary(zh_CN.UTF-8):   lftp 客户端程序
25 Name:           lftp
26 Version:        4.7.2
27 Release:        2
28 License:        GPL v3+
29 Group:          Applications/Networking
30 Source0:        http://lftp.yar.ru/ftp/%{name}-%{version}.tar.xz
31 # Source0-md5:  24b64dcd74426803eb1e9bf75a5a590a
32 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
33 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
34 Source2:        %{name}.desktop
35 Source3:        %{name}-icon.png
36 Patch100:       %{name}-git.patch
37 Patch0:         %{name}-makefile.patch
38 Patch1:         %{name}-m4.patch
39 Patch2:         aliases.patch
40 # when updated attach at https://github.com/lavv17/lftp/issues
41 Patch3:         %{name}-pl.po-update.patch
42 Patch4:         %{name}-am.patch
43 Patch5:         lftp-bug-250.patch
44 URL:            http://lftp.yar.ru/
45 BuildRequires:  autoconf >= 2.60
46 BuildRequires:  automake
47 %{?with_dante:BuildRequires:    dante-devel}
48 %{?with_dnssec:BuildRequires:   dnssec-tools-devel}
49 BuildRequires:  expat-devel
50 BuildRequires:  gettext-tools >= 0.14.2
51 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
52 BuildRequires:  libstdc++-devel
53 BuildRequires:  libtool >= 1:1.4.2-9
54 BuildRequires:  ncurses-devel >= 5.2
55 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
56 BuildRequires:  pkgconfig
57 BuildRequires:  readline-devel >= 4.2
58 BuildRequires:  tar >= 1:1.22
59 BuildRequires:  xz
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
63 %if %{_gcc_ver} == 2
64 %define         __cxx           "%{__cc}"
65 %endif
66
67 %description
68 LFTP is a shell-like command line FTP/HTTP client. The main two
69 advantages over other FTP clients are reliability and ability to
70 perform tasks in background. It will reconnect and reget the file
71 being transferred if the connection broke. You can start a transfer in
72 background and continue browsing on the FTP site. It does this all in
73 one process. When you have started background jobs and feel you are
74 done, you can just exit lftp and it automatically moves to nohup mode
75 and completes the transfers. It has also such nice features as reput
76 and mirror.
77
78 %description -l pl.UTF-8
79 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
80 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
81 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
82 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
83 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
84 jako aplikacja do mirrorowania serwerów FTP.
85
86 %description -l pt_BR.UTF-8
87 O lftp é um programa de transferência de arquivos por linha de
88 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
89 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
90 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
91 o arquivo FEATURES para uma lista mais detalhada.
92
93 %prep
94 %setup -q
95 #%patch100 -p1
96 %patch0 -p1
97 %patch1 -p1
98 %patch2 -p1
99 %patch3 -p1
100 %patch4 -p1
101 %patch5 -p1
102
103 %{__rm} po/stamp-po
104
105 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
106
107 %build
108 %{__libtoolize}
109 %{__gettextize}
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %{__automake}
113 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
114 %configure \
115         --without-included-regex \
116         --with-dnssec-local-validation%{!?with_dnssec:=no} \
117         --with-modules \
118         --with-socksdante%{!?with_dante:=no} \
119         --with%{!?with_openssl:out}-openssl \
120         --with%{!?with_gnutls:out}-gnutls
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
131 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
132 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
133
134 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
135 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
137
138 %find_lang %{name}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files -f %{name}.lang
147 %defattr(644,root,root,755)
148 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
149 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
150 %attr(755,root,root) %{_bindir}/lftp
151 %attr(755,root,root) %{_bindir}/lftpget
152 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
154 %dir %{_libdir}/lftp
155 %attr(755,root,root) %{_libdir}/lftp/*.so
156 %attr(755,root,root) %{_datadir}/lftp
157 %{_mandir}/man1/lftp.1*
158 %{_mandir}/man1/lftpget.1*
159 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
160 %{_mandir}/man5/lftp.conf.5*
161 %{_desktopdir}/lftp.desktop
162 %{_pixmapsdir}/lftp.png
This page took 0.082101 seconds and 3 git commands to generate.