]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
7ea8b0d18bdcf0352fb48abbf80aafba550002e8
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
18 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
19 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN.UTF-8):   lftp 客户端程序
21 Name:           lftp
22 Version:        3.7.6
23 Release:        1
24 License:        GPL v2+
25 Group:          Applications/Networking
26 Source0:        ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.bz2
27 # Source0-md5:  eed9891b8c2d034f296af5eb86898935
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Patch0:         %{name}-home_etc.patch
32 Patch1:         %{name}-makefile.patch
33 URL:            http://lftp.yar.ru/
34 BuildRequires:  autoconf >= 2.60
35 BuildRequires:  automake
36 BuildRequires:  gettext-devel >= 0.14.2
37 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 1:1.4.2-9
40 BuildRequires:  ncurses-devel >= 5.2
41 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
42 BuildRequires:  readline-devel >= 4.2
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
46 %if %{_gcc_ver} == 2
47 %define         __cxx           "%{__cc}"
48 %endif
49
50 %description
51 LFTP is a shell-like command line FTP/HTTP client. The main two
52 advantages over other FTP clients are reliability and ability to
53 perform tasks in background. It will reconnect and reget the file
54 being transferred if the connection broke. You can start a transfer in
55 background and continue browsing on the FTP site. It does this all in
56 one process. When you have started background jobs and feel you are
57 done, you can just exit lftp and it automatically moves to nohup mode
58 and completes the transfers. It has also such nice features as reput
59 and mirror.
60
61 %description -l pl.UTF-8
62 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
63 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
64 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
65 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
66 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
67 jako aplikacja do mirrorowania serwerów FTP.
68
69 %description -l pt_BR.UTF-8
70 O lftp é um programa de transferência de arquivos por linha de
71 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
72 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
73 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
74 o arquivo FEATURES para uma lista mais detalhada.
75
76 %prep
77 %setup -q
78 #%%patch0 -p1
79 %patch1 -p1
80
81 rm -f po/stamp-po
82
83 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
84
85 %build
86 %{__libtoolize}
87 %{__gettextize}
88 %{__aclocal} -I m4
89 %{__autoconf}
90 %{__automake}
91 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
92 %configure \
93         --with-modules \
94         --with%{!?with_openssl:out}-openssl \
95         --with%{!?with_gnutls:out}-gnutls
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
107 install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
108 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
109
110 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
111 rm -f $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
112 rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
113
114 %find_lang %{name}
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files -f %{name}.lang
123 %defattr(644,root,root,755)
124 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
125 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
126 %attr(755,root,root) %{_bindir}/lftp
127 %attr(755,root,root) %{_bindir}/lftpget
128 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
130 %dir %{_libdir}/lftp
131 %attr(755,root,root) %{_libdir}/lftp/*.so
132 %attr(755,root,root) %{_datadir}/lftp
133 %{_mandir}/man1/lftp.1*
134 %{_mandir}/man1/lftpget.1*
135 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
136 %{_desktopdir}/lftp.desktop
137 %{_pixmapsdir}/lftp.png
This page took 0.03052 seconds and 2 git commands to generate.