]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- updated to 4.2.0
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
18 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
19 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN.UTF-8):   lftp 客户端程序
21 Name:           lftp
22 Version:        4.2.0
23 Release:        1
24 License:        GPL v3+
25 Group:          Applications/Networking
26 Source0:        http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
27 # Source0-md5:  0ba993d4edda8d975a78b7e8f0c687d0
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Source3:        %{name}-icon.png
32 # outdated and nobody cared for 8+ years... will be dropped
33 Patch0:         %{name}-home_etc.patch
34 Patch1:         %{name}-makefile.patch
35 # ALWAYS send updated patch to lftp mailing lists
36 Patch2:         %{name}-pl.po-update.patch
37 Patch3:         %{name}-m4.patch
38 Patch4:         aliases.patch
39 URL:            http://lftp.yar.ru/
40 BuildRequires:  autoconf >= 2.60
41 BuildRequires:  automake
42 BuildRequires:  gettext-devel >= 0.14.2
43 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  libtool >= 1:1.4.2-9
46 BuildRequires:  ncurses-devel >= 5.2
47 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
48 BuildRequires:  pkgconfig
49 BuildRequires:  readline-devel >= 4.2
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
53 %if %{_gcc_ver} == 2
54 %define         __cxx           "%{__cc}"
55 %endif
56
57 %description
58 LFTP is a shell-like command line FTP/HTTP client. The main two
59 advantages over other FTP clients are reliability and ability to
60 perform tasks in background. It will reconnect and reget the file
61 being transferred if the connection broke. You can start a transfer in
62 background and continue browsing on the FTP site. It does this all in
63 one process. When you have started background jobs and feel you are
64 done, you can just exit lftp and it automatically moves to nohup mode
65 and completes the transfers. It has also such nice features as reput
66 and mirror.
67
68 %description -l pl.UTF-8
69 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
70 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
71 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
72 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
73 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
74 jako aplikacja do mirrorowania serwerów FTP.
75
76 %description -l pt_BR.UTF-8
77 O lftp é um programa de transferência de arquivos por linha de
78 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
79 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
80 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
81 o arquivo FEATURES para uma lista mais detalhada.
82
83 %prep
84 %setup -q
85 #%%patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88 %patch3 -p1
89 %patch4 -p1
90
91 %{__rm} po/stamp-po
92
93 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
94
95 %build
96 %{__libtoolize}
97 %{__gettextize}
98 %{__aclocal} -I m4
99 %{__autoconf}
100 %{__automake}
101 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
102 %configure \
103         --with-modules \
104         --with%{!?with_openssl:out}-openssl \
105         --with%{!?with_gnutls:out}-gnutls
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
116 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
117 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
118
119 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
120 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
122
123 %find_lang %{name}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files -f %{name}.lang
132 %defattr(644,root,root,755)
133 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
134 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
135 %attr(755,root,root) %{_bindir}/lftp
136 %attr(755,root,root) %{_bindir}/lftpget
137 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
139 %dir %{_libdir}/lftp
140 %attr(755,root,root) %{_libdir}/lftp/*.so
141 %attr(755,root,root) %{_datadir}/lftp
142 %{_mandir}/man1/lftp.1*
143 %{_mandir}/man1/lftpget.1*
144 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
145 %{_mandir}/man5/lftp.conf.5*
146 %{_desktopdir}/lftp.desktop
147 %{_pixmapsdir}/lftp.png
This page took 0.215957 seconds and 3 git commands to generate.