]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- 3.7.1
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
18 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
19 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN.UTF-8):   lftp 客户端程序
21 Name:           lftp
22 Version:        3.7.1
23 Release:        1
24 License:        GPL v2+
25 Group:          Applications/Networking
26 Source0:        ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.bz2
27 # Source0-md5:  60bb61fc1a5e96392bbd2dc88b938109
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Patch0:         %{name}-home_etc.patch
32 Patch1:         %{name}-makefile.patch
33 Patch2:         %{name}-as_needed-fix.patch
34 Patch3:         %{name}-pl.po-update.patch
35 URL:            http://lftp.yar.ru/
36 BuildRequires:  autoconf >= 2.60
37 BuildRequires:  automake
38 BuildRequires:  gettext-devel >= 0.14.2
39 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtool >= 1:1.4.2-9
42 BuildRequires:  ncurses-devel >= 5.2
43 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
44 BuildRequires:  readline-devel >= 4.2
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
48 %if %{_gcc_ver} == 2
49 %define         __cxx           "%{__cc}"
50 %endif
51
52 %description
53 LFTP is a shell-like command line FTP/HTTP client. The main two
54 advantages over other FTP clients are reliability and ability to
55 perform tasks in background. It will reconnect and reget the file
56 being transferred if the connection broke. You can start a transfer in
57 background and continue browsing on the FTP site. It does this all in
58 one process. When you have started background jobs and feel you are
59 done, you can just exit lftp and it automatically moves to nohup mode
60 and completes the transfers. It has also such nice features as reput
61 and mirror.
62
63 %description -l pl.UTF-8
64 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
65 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
66 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
67 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
68 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
69 jako aplikacja do mirrorowania serwerów FTP.
70
71 %description -l pt_BR.UTF-8
72 O lftp é um programa de transferência de arquivos por linha de
73 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
74 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
75 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
76 o arquivo FEATURES para uma lista mais detalhada.
77
78 %prep
79 %setup -q
80 #%%patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83 %patch3 -p1
84
85 rm -f po/stamp-po
86
87 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
88
89 %build
90 %{__libtoolize}
91 %{__gettextize}
92 %{__aclocal} -I m4
93 %{__autoconf}
94 %{__automake}
95 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
96 %configure \
97         --with-modules \
98         --with%{!?with_ssl:out}-ssl \
99         --with%{!?with_openssl:out}-openssl \
100         --with%{!?with_gnutls:out}-gnutls
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
112 install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
113 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
114
115 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
116 rm -f $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
117 rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
118
119 %find_lang %{name}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files -f %{name}.lang
128 %defattr(644,root,root,755)
129 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
130 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
131 %attr(755,root,root) %{_bindir}/lftp
132 %attr(755,root,root) %{_bindir}/lftpget
133 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
135 %dir %{_libdir}/lftp
136 %attr(755,root,root) %{_libdir}/lftp/*.so
137 %attr(755,root,root) %{_datadir}/lftp
138 %{_mandir}/man1/lftp.1*
139 %{_mandir}/man1/lftpget.1*
140 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
141 %{_desktopdir}/lftp.desktop
142 %{_pixmapsdir}/lftp.png
This page took 0.061125 seconds and 3 git commands to generate.